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7 SUMMARY:

This document contains information about changes in PcVue 15. It includes information up to
Maintenance Release 15.2.14.

Last update ‘ 02/04/2026

Revision ‘ 1.0

Confidentiality TLP:CLEAR

The information in this book is subject to change without notice and does not represent a commitment on the part of the
publisher. The software described in this book is furnished under a license agreement and may only be used or copied in
accordance with the terms of that agreement. It is against the law to copy software on any media except as specifically
allowed in the license agreement. No part of this manual may be reproduced or transmitted in any form or by any means
without the express permission of the publisher. The author and publisher make no representation or warranties of any
kind with regard to the completeness or accuracy of the contents herein and accept no liability of any kind including but
not limited to performance, merchantability, fitness for any particular purpose, or any losses or damages of any kind caused
or alleged to be caused directly or indirectly from this book. In particular, the information contained in this book does not
substitute to the instructions from the products’ vendor. This book may contain material belonging to third-parties. Such
information is used exclusively in internal work processes and is not intended to be disclosed. In addition, this notice is
not a claim of property on such third-party information.
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1. Maintenance Release 15.2.14 (15.2.14900)

1. Fixes

Application Explorer freeze (SPR #76377)

The Application Explorer could freeze when applying a modification using the the equipment
dialog box while a device with a frame was selected in Application Explorer.

Configuration
Environments >
Application Explorer

Fatal error with the RDS Networking wizard (SPR #76502, 71761)

A fatal error of the Application Explorer occurred upon creation of a Networking configuration
using the wizard.

Configuration
Environments >
Application Explorer

Also in: 16.0.0
Fatal error on disconnection Networking
A fatal error could occur on disconnection on an unstable network.
Server switchover failure (SPR #76465) Networking

Under some circumstances, the system variable indicating the status of a server station in an
association was not updated correctly and forcing a server switchover with the SCADA Basic
instruction LAN mode SET_SERVER_MODE failed.

The issue occurred in a scenario involving starting/stopping/re-starting servers belonging to an
association in a specific sequence. It was a regression introduced in 12.0.32 and 15.2.13.

Fatal error using print function (SPR #73477, 66171)

A fatal error occurred when loading a SCADA Basic script using the Print function with a string
longer than supported.

Scripting > SCADA
Basic
Also in: 16.3.0, 16.2.1

2. Critical fixes

Deadlock with the Xml Generic Import (SPR #76087, 74398)

A dead lock could occur when importing variables other than ‘Internal’. The issue manifested
itself with a freeze during Application Architect generation or synchronization, while using a
Smart Generator or the Xml Generic Import directly with the Xmlimporter.exe command line. A
forced exit of Sv32.exe occurred after the 10-minute watchdog timeout.

It was a known issue since 16.3.0.

Configuration
Environments
Also in: 16.3.3

3. Security

Multiple vulnerabilities affecting WebVue, the WebScheduler and
mobile apps (SPR #76380, 76379, 76378, 76376, 76375, 76374, 76373,
76372, 76370, 76369)

The following vulnerabilities are fixed. They affect the GraphicalData service, the WebClient
and/or the WebScheduler web apps:

® (CVE-2026-1692 - Missing origin validation in GraphicalData web service requests -
Affects all versions since 12.0.

® (CVE-2026-1693 - Use of vulnerable Resource Owner Password Credentials flow -
Affects all versions since 12.0.

® (CVE-2026-1694 - Server configuration details in HTTP headers - Affects all versions
since 12.0.

®  (CVE-2026-1695 - XSS vulnerability upon unsuccessful authentication - Affects all
versions since 12.0.
CVE-2026-1696 - Missing security HTTP headers - Affects all versions since 12.0.
CVE-2026-1697 - Use of unsecure cookies for the GraphicalData web service and the
WebClient web apps - Affects all versions since 12.0.

® (CVE-2026-1698 - HTTP Host header vulnerability in WebClient and WebScheduler web
apps - Affects all versions since 15.0.
See our Security alert page for more information.

Web Server Extensions
Also in: 16.3.4

Reference: PcVue 15 Release Notes
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4. Other fixes & enhancements

SPR #76290 Also in: 16.3.4
SPR #76292 Also in: 16.3.3
Reference: PcVue 15 Release Notes Last update: April 2, 2026
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2.  Maintenance Release 15.2.13 (15.2.13902)

1. Fixes

Wrong timestamp quality (SPR #75905)

A variable mapped onto an Integrated total ASDU had a timestamp quality 'PLC' even if it was
configured for not being time-tagged.

Data Acquisition > IEC
60870-5 Client

Also in: 16.3.2
Substitution strings not handled correctly (SPR #75173, 14462) HMI
Substitution strings #B10, #B11 and #B12 were not properly handled when used in a symbol. Also in: 16.3.3
Instructions TREEVIEW, COMBOBOX, CHECKLIST, LISTBOX and HMI > Form controls
OPTIONLIST - Mode SAVE (SPR #75626, 75625, 75463, 72798) Also in: 16.3.2
When using the mode SAVE, only texts in the current display language were saved. For bilingual
applications, texts for the second language were not saved.
Several stability fixes (SPR #76266, 76236, 76090, 76088) Networking

The list of fixes includes:
®  SPR #76088 - A fatal error could occur on disconnection on an unstable network.
®  SPR#76090 - Improved control of the outgoing Network Interface Card.

® SPR#76236 - A fatal error could occur at startup if an expected node could not be
found, typically after having deleted a node from a station and restarted.

SPR #76266 - A fatal error could occur on connection/disconnection.

Fix to audit counters: Size of receive buffer (in bytes), Deleting server objects, Deleting
client object.

Alsoin: 16.3.3, 12.0.32

Instruction SEQ_BUFFER mode PREVFIELD - Wrong return value (SPR
#75366)

Scripting > SCADA
Basic

The instruction always returned 0 when using the syntax that returns the value in a buffer (as Also in: 16.3.2
opposed to the syntax that returns a typed return value).
2.  Critical fixes
Alarms out of synch (SPR #75260) Alarms
Under some circumstances, when a delayed alarm was masked during its temporization period, Also in: 16.3.2

the actual value was not kept updated while it was masked and the alarm state in PcVue and on
the field appeared in discrepancy after unmasking.

Deferred attributes no longer archived (SPR #76007, 75523)

Historical data

The value of deferred extended attributes was no longer recorded as part of a log list if using Also in: 16.3.3
proprietary archive.

The issue was a regression introduced in 15.2.11, 16.2.5 and 16.3.0.

Multi-node no longer working (SPR #75685) Networking

The communication between two stations using more than one node no longer worked when
the security was not altered, only one could connect effectively.

The issue was a regression integrated with the security fix for CVE-2025-9998 and CVE-2025-
9999 (SB2025-4) in PcVue 12.0.31, 15.2.12 and 16.3.1.

Also in: 16.3.2, 12.0.32

Reference: PcVue 15 Release Notes
Copyright ©2026 - ARC Informatique. All rights reserved — LR NI\

Last update: April 2, 2026
Page 6/124



4
PcVue >

3. Enhancements

Instructions COMBOBOX, CHECKLIST, LISTBOX and OPTIONLIST - HMI > Form controls
New mode INSERT_ITEM (SPR #75443, 75442, 75441, 75440, 75013) Also in: 16.3.2

A new mode INSERT_ITEM is available to insert items in bilingual applications:

® COMBOBOX("INSERT_ITEM", Window, Branch, Identity, Text1, Text2, UserData],
Index])

CHECKLIST("INSERT_ITEM", Window, Branch, Identity, Text1, Text2, UserDatal, Index])
LISTBOX("INSERT_ITEM", Window, Branch, Identity, Text1, Text2, UserData[, Index])

OPTIONLIST("INSERT_ITEM", Window, Branch, Identity, Text1, Text2, UserDatal,
Index])
The parameter Text2 is the item's text in the second language.

4, Performance

Improved capability to handle large number of variables (SPR #75221) Networking

Improvements of read request handling over the client/server Networking for variables. Also in: 16.3.2

Improved time to subscribe variables (SPR #73834) Web Server Extensions
Reduced time to receive a response to subscribe with the Real time data web service. > Web Services Toolkit
Subscriptions are now handled by block and can be used for larger sets of variables at once .

(typically several thousands variables). Alsoin: 16.2.1

This change has visible effects if you are using a web services client developed in house, or a
third party product taking advantage of the Web Services Toolkit such as Micromedia Alert or
Dream Report.

5.  Security

Client/Server networking instability (SPR #76197, 76112) Networking

Since the introduction of the security fix described in the security bulletin SB2025-4, networking ~ Also in: 16.3.3, 12.0.32
packets could be falsely detected as malformed, causing a server station to force a

disconnection. This issue led to a situation where a client station would not be able to stay

connected to a server station in a stable way.

It was a known issue since 16.3.1, 15.2.12 and 12.0.31.

The security bulletin SB2025-4 is updated (Rev B).

Settings to maintain backward compatibility (SPR #76308, 76222) Networking

To make it possible to temporarily maintain compatibility while updating a system to a product  Also in: 16.3.3, 12.0.32
release offering hardened packet sequence control, a new setting on the Networking node

called 'Allow stations with altered security' and a new property also called 'Allow stations with

altered security' on station's node configuration are available.

To facilitate the station by station update, when re-starting an existing project, the new global

setting is checked by default. Once all stations of a system are updated, the setting shall be

unchecked and all nodes shall have the property set to 'No' to ensure the packet sequence

control is hardened for all client/server links.

6. Other fixes & enhancements

SPR #72680, 74145, 75827, 716247 Also in: 16.3.3

SPR #76274, 76284 Also in: 16.3.3, 12.0.32
SPR #73985, 75349, 75762 Also in: 16.3.2
Reference: PcVue 15 Release Notes Last update: April 2, 2026
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3. Maintenance Release 15.2.12 (15.2.12900)

1. New features

New license reference for Building Automation (SPR #75133)

The new reference HMI_BACS is available to cover the BMS needs for buildings up to 1000 m2.
It includes:

®  Data acquisition drivers - BACnet, Lonworks, KNX, Modbus, SIA Honneywell, IP500,
MQTT, LoRa, Modbus, SNMP, OCPP, Universal Data Connector

®  Smart control
®  Energy management with a bundled EmVue license
°

Desktop and web clients
[ ]

This reference may only be available under specific conditions and geographical areas. Please
contact your reseller for more information.

General > Licensing
Also in: 16.3.0, 16.2.5

2. Fixes

Incorrect success message (SPR #73071)

The Data export logged a trace 'generation succeeded' even when the HDS was not running or
the database was disconnected. It now fails gracefully.

The issue only affected data export when used with an HDS archive unit.

Data Export
Also in: 16.3.1

Support for non-Latin characters (SPR #73553)

Non-Latin characters could not be used as part of a filter on Text extended attributes when
configuring a log page.

Data Export
Also in: 16.3.1

3. Enhancements

OPC XML-DA - Array mapping onto a comma-separated value (SPR
#75172)

It is now possible to map an array onto a text variable to retrieve all array elements as a
comma-separated text value.

Data Acquisition > OPC

Client
Also in: 16.3.2

Instruction VARIABLE modes ASSOCLABEL and LONGLABEL - Added
language parameter (SPR #75016)

It is now possible to retrieve a variable's label in a language other than the current one by
specifying the optional Lang parameter.

VARIABLE("ASSOCLABEL", VarName[, Lang])

VARIABLE("LONGLABEL", VarName [, Lang])

Where Lang is of type INTEGER and can take the following values:

® (- Returns the label in the current language (default)
® 1 -Returnsthe label in language 1
® 2 -Returnsthe label in language 2

Scripting > SCADA
Basic
Also in: 16.3.2

4. Security

Null pointer dereference vulnerability (SPR #75116)

The following vulnerability is fixed. It affects the ICCP interface:

®  CVE-xxxx-x (in progress) - Denial-of-service vulnerability- Affects all versions since 15.1.

See our Security alert page for more information.

Communication
interfaces > ICCP
Also in: 16.3.0, 16.2.5

Certificate validity not properly verified (SPR #70331)
The following vulnerability is fixed:

®  (CVE-2025-4384 - Improper validation of certificate expiration
See our Security alert page for more information.

Communication
interfaces > MQTT
Pub-Sub

Also in: 16.3.0, 16.2.5

Reference: PcVue 15 Release Notes
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Vulnerabilities in the client/server Networking (SPR #74711, 74710, Networking

74709) Also in: 16.3.1, 12.0.31
The following vulnerabilities are fixed. They affect the TCP-based client/server Networking

feature:

® (CVE-2025-9998 - Improper validation of packets sequencing - Affects all versions.

®  (CVE-2025-9999 - Improper validation of payload elements - Affects all versions.
See our Security alert page for more information.
[Edit: The fix in 12.0.31, 15.2.12, 16.3.1 and 16.3.2 is not effective. Refer to the section Known
issues for more information.]

5. Other fixes & enhancements

SPR #75491 Also in: 16.3.1

Reference: PcVue 15 Release Notes Last update: April 2, 2026
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4. Maintenance Release 15.2.11 (15.2.11901)

1. New features

Support for EmVue (SPR #74871, 74084)

The Maintenance Release 15.2.11 supports the PcVue connector of EmVue version 1.
Among other elements, starting with 15.2.11, the WDC can be used to add the EmVue client
token type, so that EmVue can take advantage of the Web Services Toolkit authentication.

General

2. Fixes

Fatal error with mismatched configuration (SPR #74064)

Under some circumstances, a fatal error occurred when PcVue was configured as a called
Client/Server ICCP control center and the Remote domain or the BilateralTablelD configured in
the ICCP.ini file was different from the local domain or BilateralTablelD of the remote control
center that was connecting.

Communication
interfaces > ICCP

Fatal error upon receiving write requests (SPR #74343)

A fatal error could occur upon receiving a write request on the OPC Server interface if the
received value was out of range.

Communication
interfaces > OPC
Server

Also in: 16.3.0, 16.2.5

USER objects never released (SPR #74644, 74543)

When using the Data Export wizard, some USER objects were allocated and never released
upon closure.

Data Export

Fatal error during large import (SPR #74963, 74934)

A deadlock could occur when importing a large number of variables, causing a freeze and
potentially a fatal error.

The issue affected imports using the XML Generic Import in general, and
generation/synchronization with the Application Architect in particular.

Development kits >
XML Generic Import
Toolkit

Fatal error if branch started with '@' (SPR #74366, 74286)

A fatal error occurred upon opening a mimic containing an animation with a branch starting
with the '@' character if taking advantage of an HMI variable.

The issue did not occur with 1/O or internal variables.

HMI > Animations

Low plotting precision (SPR #74881)

When using the time shift capabilities of the trend viewer to compare data at different points in
time, plotting precision was too low for proper analysis when the time shift was large (1 year
for example).

HMI > Trend viewer

Memory leak with expressions on variables (SPR #74028)
A memory leak occurred with expressions having a result variable of type Text.

Real time data
Also in: 16.3.0, 16.2.5

Support for scientific notation (SPR #72044)

The following syntax elements can now be used in the variable property Format:
® fe: Use exponential notation [-]d.ddddE[+]-]dd[d]
®  HE: Use exponential notation [-]d.dddde[+]|-]dd[d]

Real time data

Instruction ALARMDISPLAY mode SELECNAME (SPR #74790)

The mode SELECTNAME no longer worked as designed when called in the context of the
desktop client.

Scripting > SCADA
Basic

Instruction TREND mode SET_VISIBLE (SPR #74672)

It did not work for trace number 0.

Scripting > SCADA
Basic

Delayed response for a trend request (SPR #74052)

If a variable was not trended, the response came only after the time-out instead of an
immediate response indicating that the variable is not trended.

The same occurred when no record existed for the requested time.

Web Server Extensions
> Web Services Toolkit

Also in: 16.3.0, 16.2.2

Ul frozen (SPR #73991)

The WebVue Ul could freeze after clicking on a small ellipse graphic element or clicking close to
the edge of such element.

Web Server Extensions

> WebVue

Reference: PcVue 15 Release Notes
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3. Critical fixes

Value discrepancy between client and server (SPR #74315) Data Acquisition > OPC
Under some circumstances, a discrepancy between a client station and a server station could Client

occur, showing a different VTQ for a given variable.

The issue occurred only with a variable mapped on an OPC server, in a scenario were more than

one VTQ are received in the same OPC group subscription refresh call back.

It was due to how variable changes are packed/unpacked for distribution to client stations.

4. Enhancements

Alarm timestamping on masking (SPR #74544) Alarms

When an alarm is masked by dependency on another variable, the timestamp of the other
variable and its source (SV or PLC) are now used as the timestamp and source for the masking
event. The same applies to an alarm unmasking event.

New audit counters (SPR #74147) Audit

New audit counters are available to monitor the time spent processing internal messages. Also in: 16.2.5

Improved support for custom system display scale factor (SPR #75006) HMI
Several UI/UX fixes and enhancements to better support custom scale factor setting:

®  Fixed sizing issue with graphic controls

®  Fixed missing content with Form controls

®  Fixed Legend tab in the Trend viewer

MaxNumberExceeded always false (SPR #74880, 73825) Web Server Extensions

When calling QueryTrendRequest and ExecuteTrendRequest of the HistoricalData web service, > Web Services Toolkit
the MaxNumberExceeded flag was always returned with value False even if more records were .

available. It is now set to True in that case. Also in: 16.3.0, 16.2.1

It was a documented feature limitation.

5. Performance

Reduced time to refresh variables (SPR #74992, 74124, 74019, 73988) Data Acquisition > IEC

Significant reduction of the load for refreshing variable VTQ, with gains on the CPU resources 60870-5 Client
and the time it takes to refresh variables on large projects.
It includes changes in:

® |nternal messages processing
®  System variables updates

®  Traces generation
This improvement follows a regression in performances introduced in 15.2.0 and goes beyond
in terms of gains.

Reduced memory footprint for trend (SPR #74172) Historical data

Memory buffers are no longer allocated on stations that only consume trend data, as opposed
to stations that produce trend data for archiving.

This change can significantly reduce the memory footprint on a typical client station, and also
reduces the time it takes to start a project.

Combo-box - Time to switch language (SPR #75017, 74535) HMI > Form controls
Improvement of the time it takes to switch language when a combo-box contains a large Also in: 16.3.0, 16.2.5
number of items (several hundreds).

In worst case scenarios, the Ul could freeze for several seconds.

Improved time to update variables (SPR #74545) Real time data
Enhancements to how data changes are processed to improve the time it takes to update Also in: 16.3.0, 16.2.5
variables.

The improvement can be significant on large projects.

Reference: PcVue 15 Release Notes Last update: April 2, 2026
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6. Installation

OPC UA Gateway version 1.6.1 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 16.3.0
section of the DVD.

7. Security

Null pointer dereference vulnerability (SPR #74471) Data Acquisition > IEC
The following vulnerability is fixed. It affects the IEC 61850 client driver: 61850 Client

®  CVE-xxxx-x (in progress) - Incorrect message processing in the Triangle MicroWork’s
IEC 61850 Client library - Affects all versions since 10.0.
See our Security alert page for more information.

Vulnerability of the Web backend (SPR #74150) General > Logging and
The following vulnerability is fixed. It affects the Web back end: tracing
®  (CVE-2024-12057 - Insertion of sensitive information into a log file - Affects versions 15
and 16.

User credentials (login & password) are inserted into log files when a user tries to
authenticate using a version of a Web client that is not compatible with that of the
Web back end.

See our Security alert page for more information.

8. Other fixes & enhancements

SPR #73387, 73952, 74065, 74111, 74124, 74139, 74282, 74649, 74915

SPR #74125 Also in: 12.0.30

Reference: PcVue 15 Release Notes Last update: April 2, 2026
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5. Maintenance Release 15.2.10 (15.2.10900)

1. Fixes

Instruction PUT _BUFFER - SYS MAXARGSTRINGS not taken into

account (SPR #73253)

The instruction PUT_BUFFER did not take the directive SYS MAXARGSTRINGS into account, thus
limiting its capability to handling the argument Data as a string of 2047 characters max.

Scripting > SCADA
Basic

Instruction SQL_COMMAND - SYS MAXARGSTRINGS not taken into

account (SPR #73253)

The instruction SQL_COMMAND did not take the directive SYS MAXARGSTRINGS into account,
thus limiting its capability to handling the argument Sq/Cmd as a string of 2047 characters max
(modes EXECREADER, EXECSCALAR,EXECNONQUERY).

Scripting > SCADA
Basic

Fatal error while navigating mimics (SPR #73242)

Under some circumstances, a fatal error of the Web back end station could occur while
navigating mimics in a WebVue client.

The issue occurred due to a race condition leading to executing an animation in a mimic that is
already closed.

Web Server Extensions
> WebVue

2. Critical fixes

Fatal error on exit (SPR #73781)

A fatal error occurred when shutting down PcVue if a station ran the IEC 60870-5 client data
acquisition driver.

The issue was a regression introduced in 15.2.0. It did not affect version 16 onward.

Data Acquisition > IEC
60870-5 Client

3. Performance

Minimize the number of messages (SPR #73683)

Improvements to internal diag messages to minimize the flow of messages and maximize data
change throughput.

Data Acquisition > IEC
60870-5 Client

Improve memory usage on server stations (SPR #73442)

To minimize the memory footprint on server stations, client subscriptions are now deleted as
soon as a client station shuts down.

Real time data
Also in: 16.3.0, 16.2.1

4. Other fixes & enhancements

SPR #73833, 73860

SPR #73861

Also in: 16.3.3

Reference: PcVue 15 Release Notes
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6. Maintenance Release 15.2.9 (15.2.09900)

1. Fixes

OPC XML-DA - Command handling (SPR #73463)

When sending a command on a variable mapped onto an OPC XML-DA server, the command
value was not refreshed immediately, and the command user action was not logged (if any log
list was configured to store user command actions).

Data Acquisition > OPC
Client

Error opening a mimic saved in Ascii (SPR #73488, 73481)

Run macro animations were no longer saved correctly and an error occurred when re-opening
the mimic.

The issue was a regression introduced in 15.2.8. It only affected mimics saved in Ascii format.

HMI

Wrong icon size with large toolbars (SPR #73535)

The large toolbar was showing 16x16 icons instead of 32x32 icons.

HMI > Alarm viewer

Wrong variable status after expression deletion (SPR #72154)

The status of a variable that is the result of an expression was not updated when deleting the
expression. As a consequence, the variable could have the status 'NS EXP' (invalid by
dependency on the expression) persisting despite no longer being dependent on the
expression.

Real time data

Instruction EXPORT_TREND mode GETAGGREGATED - Empty date
header (SPR #73411)

The optional argument TimeStampsFormat did not have a default value. If not set, the Date
header in the exported page was empty.

Scripting > SCADA
Basic

Commas in user credentials (SPR #68329)

A user having a comma in its username or password could not log in with WebVue, the
WebScheduler, TouchVue and SnapVue.

Web Server Extensions

Fatal error of the PcVue Web backend (SPR #72978)

Under some circumstances, a fatal error of the Web backend station could occur when opening
a mimic in WebVue. The issue occurred if the toolbar of an alarm viewer could not be created
at mimic opening.

Web Server Extensions
> WebVue

Scroll bar handling when system menu docked (SPR #71214)

Scroll bars are now displayed if the WebVue system menu is displayed and docked.

Web Server Extensions
> WebVue

2. Critical fixes

Fatal error on shutdown (SPR #73661)

Since 15.2.8, a fatal error occurred during shutdown if the IEC 60870-5 client driver was
configured.

Data Acquisition > IEC
60870-5 Client

3. Enhancements

Driver Udp Genisys - Support for redundancy (SPR #73476)

The Udp Genisys driver now supports field device redundancy.

Data Acquisition >
Other built-in drivers
Also in: 12.0.30

Driver Udp Genisys - Switch polling mode

The driver Udp Genisys now supports the following SCADA Basic instruction to switch indication
request from master poll to master recall:
CIMWAY(“SENDMSG”,“network.device”,“ResetRecallFlag”);

Data Acquisition >
Other built-in drivers
Also in: 12.0.30

Scrollbars in the legend area (SPR #70250)

In addition to the vertical scrollbar, it is now possible to use a horizontal scrollbar in the Legend
area of the trend viewer.

At design time, it is possible to specify if scrollbars should be displayed at runtime.

HMI > Trend viewer
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4. Security

Buffer overflow vulnerability (SPR #73486) Data Acquisition > IEC
The following vulnerability is fixed. It affects the IEC 61850 client driver: 61850 Client

®  (CVE-2024-34057 - Buffer overflow in the Triangle MicroWork’s IEC 61850 Client library Also in: 12.0.30
- Affects all versions since 10.0. o
See our Security alert page for more information

5. Other fixes & enhancements

SPR #73198, 73443, 73493

Reference: PcVue 15 Release Notes Last update: April 2, 2026
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7. Maintenance Release 15.2.8 (15.2.08900)

1. Fixes

Fatal error when configuring a Sql connection (SPR #70877, 70817)

Under some circumstances, a fatal error of the Application Explorer could occur while
configuring a Sqgl connection.

The issue occurred when an exception was raised while discovering the properties of an
ADO.Net provider connection string.

Communication
interfaces > Sql
connections

Freeze caused by Sql query parameters resolution (SPR #72849)

A freeze could occur when resolving Sql query parameters if using an indirect extended text
attribute.

Communication
interfaces > Sql
connections

Setting not saved (SPR #72539)

A change to the setting Do not make expression result invalid when a member is invalid was not
saved.

Configuration
Environments

Command on mis-configured variables (SPR #73017)

A fatal error occurred when sending a command on a variable mapped onto the BACnet driver,
but missing configuration of the object-type.

In such a scenario, the command is now rejected.

Data Acquisition >
BACnet Client

Several fixes & enhancements (SPR #73105, 69334)
The list of fixes & enhancements includes:

®  When requesting a trend log buffer from the helper, the request by time was done
without defining the day of the week. The issue caused some devices to reply with the
out of range error code.

®  Fix a bad conversion of the day of the week when using the time synchronization
service.

®  Allvalues received from a trend log for a binary input were archived as value 0.

Data Acquisition >
BACnet Client

Command locked after a switchover (SPR #72932)

Under some circumstances, when sending a command after a data acquisition server
switchover, the command was not sent and it was no longer possible to send it.

The issue only occurred when the time between the switchover and the command was smaller
than the keepalive period.

The command now fails gracefully and can be re-attempted later, as it is not possible to send a
command during this time period.

Data Acquisition >
DNP3 Client

Wrong version description (SPR #73327)

When starting a project with the command line argument -x or -d, the Description column was
filled with product version information instead of the version description.

The issue is fixed, and 2 other columns are now also available to display the version of the
product used to create and to modify the project (or library) version.

General > Version
management

ODBC system variable not refreshed (SPR #72414)

The system variable 'System.DB.<Name>.Status for the database connection was refreshed in
the Application Explorer, but not in a mimic.

Historical data

Fatal error with a mimic in ASCII format (SPR #70967)

Saving a mimic in ASCII format caused a fatal error if it contained an animation Run macro.

HMI

Only one line printer working (SPR #73096)

Since Maintenance Release 15.2.5, only the first configured line printer would start. Other (if
any) would fail to start.

Miscellaneous

Fatal error due to configuration discrepancy (SPR #73024)

Under some circumstances, a fatal error could occur upon modification of the configuration of
any variable on a server station. The issue only occurred if a variable was configured as an
alarm on a client station, and as a bit on the server station.

Real time data

Could not delete events (SPR #67342)

Deleting an event using the SCADA Basic instruction EVENT modes DEL or DELPROG did not
work if the variable name included the @ character.
The issue was a regression introduced in 15.2.0 and 16.0.0

Scripting > SCADA
Basic
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Instruction CGET_BUFFER - SYS MAXARGSTRINGS not taken into Scripting > SCADA

account (SPR #73253, 73149) Basic

The instruction CGET_BUFFER did not take the directive SYS MAXARGSTRINGS into account,
thus limiting its capability to returning a string of 2047 characters max.

2. Enhancements

Temporization of simulated alarms (SPR #73041) Alarms

Following the change related to simulated alarm temporization in 15.2.7, a new setting is
available to control if the temporization should be applied or not for simulated alarms.

COV unsubscriptions (SPR #72830, 68807) Data Acquisition >

On projects with a large amount of COV subscriptions, it could happen that not all BACnet Client
unsubscriptions were done upon stopping a network or shutting down the software, potentially

leading to a fatal error at the next startup.

Unsubscriptions are now done completely, potentially delaying the network stop or software

shutdown.

In addition, a new setting is available to disable COV unsubscription requests in such

circumstances. For a large project, it may be worth keeping the subscriptions for a quicker

restart.
Scroll bar handling when no zoom set (SPR #71214) Web Server Extensions
Scrollbars are now hidden if no zoom is set. > WebVue

3. Security

Vulnerability in the Microsoft Visual Basic for Applications runtime (SPR  Scripting > VBA
#73056) Also in: 12.0.30
The following vulnerability is fixed. It affects the VBA runtime:

® (CVE-2010-0815 & CVE-2021-1854 - Remote Code Execution - Affects all versions since
9.0.
See our Security alert page for more information.

4. Other fixes & enhancements

SPR #71079, 72043, 72727, 73037, 73193, 73214, 73276, 73341, 73362

Reference: PcVue 15 Release Notes Last update: April 2, 2026
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8. Maintenance Release 15.2.7 (15.2.07900)

1. Fixes

Control model override for Step position commands (SPR #72841)
Overriding the control model (Direct execute vs Select Before Operate) at the variable
configuration level was not taken into account for Step position commands. The control model
defined in the IEC 60870-5 settings was always used.

Data Acquisition > IEC
60870-5 Client

Fatal errors (SPR #72796, 72794, 72587, 72123)

Fix of a series of fatal errors occurring at runtime with the KNX Add-on.
In addition, the system variable corresponding to the status a KNX interface did not reflect the
actual status of the interface.

Data Acquisition > KNX

Driver IP-1SO-S7 - Failed to connect to S7-200 (SPR #72842)
Since 15.2.1, the IP-ISO-S7 driver could no longer connect to S7-200 PLC.

Data Acquisition >
Other built-in drivers

Incorrect format for week and month numbers (SPR #73004)

Fixed double digit format for week and month numbers.

1-digit numbers were padded with a space instead of a '0'. For example, September was
resolved as ' 9', it is now resolved as '09'.

Data Export

Fatal error using the library converter (SPR #72825) HMI

A fatal error could occur when using the library converter to convert symbols.

Mimic size adaptation (SPR #72839, 72442) HMI

Mimic size adaptation to screen resolution was not performed when the HMI option to control

mimics open mode was set to Design mode.

More than 1 active server (SPR #72870) Networking

Under some circumstances, 2 servers could be active at the same time despite being in a single
active server association.

The issue occurred in a specific scenario involving changes to servers' availability rates and
connection states.

Invalid variable after changing an attribute (SPR #72967)

If a modification list was active, changing an extended attribute of a variable in SCADA Basic
caused the variable to be set invalid (NS).

The issue was a regression introduced in 15.0.0, it affected all releases of version 15 and 16.

Real time data

2. Enhancements

Upgrade Temporization of simulated alarms (SPR #72946, 72935)

The temporization delay (if any) is no longer applied if an alarm is simulated.

If you use delayed alarm triggering in combination with alarm simulation, note that this change
affects the runtime behavior.

Alarms

Reference: PcVue 15 Release Notes
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3. Security

OPC UA Gateway version 1.5.14 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 12.0.29
section of the DVD.
This version of the OPC UA Gateway addresses the following security vulnerabilities:

®  7DI-CAN-20497 / CVE-2023-32172
®  7DI-CAN-20576 / CVE-2023-32173

®  7DI-CAN-20577 / CVE-2023-32174
Please note that the version 1.5.13 released earlier this year addressed the following security
vulnerabilities:

® (CVE-2022-4304
CVE-2023-0286
ZDI-CAN-20353 / CVE-2023-41185
ZDI-CAN-20494 / CVE-2023-32170
ZDI-CAN-20495 / CVE-2023-32171

®  7DI-CAN-20497 / CVE-2023-32172
See our Security alert page for more information.

4. Other fixes & enhancements

SPR #70440, 72684, 72685, 72686, 72748, 72751, 72752, 712768, 12771,
72816, 72818, 72853, 72931, 72947, 72948, 72949
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9. Maintenance Release 15.2.6 (15.2.06901)

1. Fixes

Memory leaks (SPR #72425)

Fixed memory leaks in the ICCP interface.

Communication
interfaces > ICCP

Fatal error (SPR #72425)

Under some circumstances, a fatal error could occur.

Data Acquisition >
DNP3 Client

Failed to export all data (SPR #72532)

Under some circumstances, when multiple data to export had the same timestamp, the data
export could fail to export all archived data matching the time filter.

Data Export
Also in: 12.0.29

Instruction SELECTOR mode PUTARRAY - Max size of a cell's text (SPR

#72558)

A fatal error occurred when using the mode PUTARRAY with a cell text longer than 512
characters.

The fatal error is fixed and the max length of a cell text is increased to 1000 characters.

Scripting > SCADA
Basic

Instruction SVLOG - Fatal error upon log request (SPR #72570)

Under some circumstances, fatal errors could occur on the archive server. The issues occurred
upon a request for logged events, one due to session handling, the other if the buffer used to
store the returned data was too small.

Scripting > SCADA
Basic

Instruction ALARM mode ACK - Username not logged (SPR #70865)

When using the SCADA Basic instruction ALARM mode ACK in a WebVue context, the username
was not logged.

Web Server Extensions

> WebVue

2. Critical fixes

Failed to log alarm events (SPR #72368)

Under some circumstances, when the archive setting called 'Log on mask to unmask change' is
set, then after alarm masking or unmasking, no alarm event was logged when the alarm
returned to the same value.

Historical data

3. Enhancements

Support for BATT# and SIMU# in animations (SPR #72489)

The syntax VariableName.BATT# can now be used in an animation to display or control the
value of a binary extended attribute as a whole double-word (32 bits).

The syntax VariableName.SIMU# is also added to display and control the Simulation property of
a variable.

HMI > Animations
Also in: 16.1

4. Other fixes & enhancements

SPR #72423, 72516, 72603, 72724, 75655

SPR #70346, 72458

Also in: 12.0.29
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10. Maintenance Release 15.2.5 (15.2.05901)

1. Fixes

Fatal error with alarm synthesis (SPR #72011)

Under some circumstances, a fatal error could occur during a server switch from passive to
active. The issue only occurred if an alarm synthesis was configured with a counter on highest
priority level updated based on an alarm enumeration.

The issue was are a regression introduced in 15.2.4.

Alarms

Commands not forwarded (SPR #72341)

When using PcVue as an ICCP server, a command received from an ICCP client would not be
forwarded to a field device (via Modbus for example).

Communication
interfaces > ICCP

AlarmState property no updated (SPR #72300)

The AlarmState property of OPC items was flagged with the quality Bad and not refreshed.
The issue was a regression introduced in 15.2.2 and 16.0.0.

Communication
interfaces > OPC
Server

SG for TIA Portal (SPR #72364, 72298, 72014, 69407, 68647, 68229)
Several fixes & enhancements in the Smart Generator for TIA Portal:

® |mporting array of UDT could cause the creation of several variables with the same
name,

The value 'Invalid address label' could appear as part of a variable mapping,
Added support for string variables.

Configuration
Environments > Smart
Generators

Fatal error due to EDE file handling (SPR #72393)

Under some circumstances, a fatal error could occur after the startup due to the EDE file
handling.

Data Acquisition >
BACnet Client

Fatal error due to watchdog (SPR #72386)

Under some circumstances, a fatal error could occur due to the device watchdog processing.

Data Acquisition >
BACnet Client

Fatal error upon command (SPR #71953)

Under some circumstances, a fatal error could occur on a client station after sending a driver-
level command that could not be processed by the data acquisition server.

Data Acquisition >
BACnet Client

Several fixes & enhancements related to the DNP3 client driver (SPR
#72074, 71913, 71912, 71908, 70820, 70417)
The list of fixes & enhancements includes:

®  When a device is stopped, the Status system variable is now set with value 8,

®  Fix variable status not set to NS COM in some cases of device disconnection,
®  Fix a fatal error that could occur on disconnection,
[ )

Fix how the Integrity poll audit counter is handled, the value did not reflect the actual
counter,

®  Removal of the group number from the mapping dialog box. It was misleading as it did

not reflect how the mapped data was handled at runtime,

® Interop with non-conformant devices - The time synch request flag (1IN1.4) is now
ignored after 5 rounds if not reset by the slave device.

Data Acquisition >
DNP3 Client

Driver XBUS-IP-SLAVE - Fatal error (SPR #72013)

Under some circumstances, when using the Modbus Ip slave driver with data acquisition
redundancy, a fatal error could occur upon server switch while processing write requests from
a Modbus client.

Data Acquisition >
Other built-in drivers

Wrong value sent with swapped bytes (SPR #71894)

Under some circumstances, when the value sent for a text variable had an odd number of
characters, the last character was not sent if the frame was configured with byte swapping.

Data Acquisition >
Other built-in drivers

Timestamp decoding and formatting (SPR #72378)

Improved decoding and formatting of the value of an OID of type string when it expresses a
timestamp.

Data Acquisition >
SNMP Manager

Automatic logout with AD users (SPR #72212)

When using automatic logout, the system variable called
System.LocalHost.User.AutomaticLogoffRemainingTime was not refreshed for Active Directory
users.

General > User
management
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Operation control (SPR #72516, 72443, 72343)

A fatal error could occur when cancelling the creation of a version once the creation process
was started.

General > Version
management

Time to start an ODBC archive unit (SPR #71709)

Improvement of the requests used at startup to initialize an ODBC archive unit.

Before this improvement, and depending on the exact database schema, the startup could take
a long time. In addition, a fatal error of the RDBMS engine could occur with PostgreSQL if the
database were significantly large.

Historical data

GDI leak (SPR #71917)

A GDI leak occurred when using controls, specifically the Form controls, the tree-view, the chart
and the pie controls.

HMI

Trend removal (SPR #71897, 71812)

Under some circumstances, a fatal error could occur when removing trends from a Grid control
used in historical mode.

HMI > Grid control

Null timestamp for saved variables (SPR #67079)

If a variable was saved while its status was inhibited, it was re-initialized with a null timestamp.

Real time data
Also in: 12.0.28

Deletion by import did not work (SPR #71916, 71915)

When importing a file via SCADA Basic to change configuration, the keywords
DASSOCIATEDACTION and DEXPRESSIONONVAR were not recognized properly.

Scripting > SCADA
Basic

Upgrade Error handling when importing configuration (SPR #71781)

Error handling was not consistent across a number of SCADA Basic instructions designed to
import configuration:

®  Instruction EXPRESSION mode IMPORT_FILE_ONVAR;
®  |Instruction EXPRESSION mode IMPORT_FILE_TEMP

® Instruction ASSOCIATEDACTIONS mode IMPORTBYFILE
[ ]

Instruction EVENT mode IMPORTBYFILE
They now return:
®  (:If the file is not accessible or contains nothing to treat (add/delete/modify)
®  >0: Number of lines processed from the file (add/delete/modify) if the import
succeeds or fails

The error values documented in the online help were no longer in line with the implementation
since version 10.

Scripting > SCADA
Basic
Also in: 12.0.28

Gif rendering in Chrome on i0OS & iPadOS (SPR #72431)

The position of a Gif image in WebVue was wrong if using the Chrome browser on iOS and
iPadOS.

Web Server Extensions

> WebVue

Text color for events in the Log viewer (SPR #71923)

The color configured for some events was not applied correctly in WebVue.
In some case, it, lead to invisible white on white lines in the Log viewer.

Web Server Extensions

> WebVue

2. Critical fixes

Instruction SEQ_BUFFER mode REPLACEFIELD - Could no longer
replace more than 12 characters (SPR #72480)

Fix of a regression. Since Maintenance Release 15.2.4, only the first 12 characters were
considered when using the instruction SEQ_BUFFER mode REPLACEFIELD.
This is a known issue in Maintenance Release 15.2.4

Scripting > SCADA
Basic

Fatal error of the Web back end server (SPR #72287, 72284, 72217,
68557)

Under some circumstances, when navigating in mimics from a WebVue client, a fatal error
could occur on the Web back end due to a race condition in the handling of a viewer's toolbar.

Web Server Extensions

> WebVue
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3. Enhancements

Configuration of event logging (SPR #72368) Historical data
3 new settings are available to tune event logging based on log lists:

®  Store an event when an alarm changes from mask to unmask even if the alarm has not
changed while masked (default Yes)

Store an event on source timestamp change (default No)
®  Store an event when a variable changes from unavailable to available (default No)

Events and trends on alarm system variables (SPR #72220) Real time data

It is now possible to add an event or a trend behavior on alarm counters system variables
(System.NoAckOn.All.domain_8$).

Instruction SYSTEM - New modes GETDISKSIZE_EX and Scripting > SCADA
GETDISKFREESPACE_EX (SPR #72296) Basic

Due to storage devices increased capacity, and for compatibility with existing instructions, 2
new modes are available to retrieve storage device size and free space.

They are like modes GETDISKSIZE and GETDISKFREESPACE but return a result of type longlong in
a specified unit (B, KiB; MiB, GiB or TiB).

SYSTEM("GETDISKFREESPACE_EX", DiskInfo [, Unit]);

SYSTEM("GETDISKSIZE_EX", DiskInfo [, Unit]);

Where the argument Unit can take one of the following values: "B", "KiB" (default), "MiB",
"GiB" or "TiB".

The use of modes GETDISKSIZE and GETDISKFREESPACE is now discouraged. Use these new
modes instead.

Instruction WINDOW mode CHANGE - Optional arguments (SPR #72098, Scripting > SCADA
72077) Basic

The arguments Height and Width are now optional.

Support for variable linking on UserData (SPR #72225) Web Server Extensions

Variable linking on the Index and UserData properties is now supported in WebVue for the > WebVue
Combo-box Form control.

4, Performance

Improved time to perform queries for logged events (SPR #71776) Historical data
The time to requests logged events is vastly reduced thanks to an increase in size of memory

buffers used to deal with the returned data.

In particular, it has the positive effect of reducing the number of actual queries on the data

source for requests covering a large amount of data.

The improvement applies to requests for logged events with all types of archive units (HDS,

proprietary...).

Improved memory resources usage (SPR #72256) Networking

Reduction of the amount of memory necessary to handle variable subscriptions in an
association for real time data in case the association comprises more than 2 servers.

5. Other fixes & enhancements

SPR #68214, 70304, 71280, 71379, 71420, 71658, 71659, 71903, 72001,
72095, 72184, 72200, 72252, 72283, 72401, 72474
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11. Maintenance Release 15.2.4 (15.2.04900)

1. New features

SNMP Agent - Support for trap sending redundancy (SPR #70393,
70147)

The SNMP Agent now supports single active server association for trap sending.

By adding the parameter AssociationName = <MyServerAssociation>, only active servers of the
association will send traps.

The task is then disabled on passive servers. The association must be of type Single active
server.

Communication
interfaces > SNMP
Agent

2. Fixes

EtherNet/IP Add-on - Array of boolean (SPR #71665)

Writing in an array of boolean comprising more than 32 items failed.
Reading and writing failed if the array started at an index other than 0.

Add-ons and Tools

Alarm masking by expression template (SPR #71237) Alarms

Alarm masking by expression template did not work properly if the same expression template

and branch was used on more than one alarm.

The issue was a regression introduced in version 12.

Alarm synthesis timestamp changed on server switchover (SPR #71548)  Alarms

On a server switch from passive to active, an alarm synthesis is recalculated, including its value Also in: 12.0.28

and timestamp. If the alarm synthesis has not changed, the value is not set. But, since a
regression introduced in Maintenance Release 12.0.20 the timestamp was updated, causing
event triggering if any.

This is a known issue in 12.0.20, all subsequent Maintenance Releases of version 12 until
12.0.27 (included) and all releases of version 15 until 15.2.3 (included).

Several fixes & enhancements related to the ICCP interface (SPR
#70980, 70618, 70473, 70408, 69049, 69048, 69044, 69043, 69041, 69040,
68978, 68941, 68218)

The list of fixes & enhancements includes:

®  Fix of a fatal error occurring when a remote reconnected quickly multiple times,
Fix to stop all networks properly before shutdown,
Some dataset parameters were ignored after an initial dataset creation failed,
System variables added to handle stats related to data and command flows,
A message was traced twice on remote client disconnection,

Deny an incoming connection if both the LCC and the corresponding RCC are
configured to initiate the connection (and improved traces),

Fix of the handling of ICCP/TASE.2 version discrepancy,
Under some circumstances, a fatal error could occur upon shutdown,

Disconnections could occur when generating configuration from the Application
Architect. The issue was related to how local SBO variables deletion/creation was
handled.

Communication
interfaces > ICCP

Fatal error if payload contained % (SPR #71860)

Under some circumstances, a fatal error occurred when an MQTT payload contained the %
character.

Communication
interfaces > MQTT
Pub-Sub

OPC Server caused regulation mode to stay active (SPR #71724)

Under some circumstances, since 15.2.3, PcVue flow regulation could be blocked active due to
the data flow generated by the OPC DA server.

Communication
interfaces > OPC
Server

Fatal error with HMI variables (SPR #71673)

A fatal error could occur when generating configuration comprising HMI variables with the
Application Architect.

Configuration
Environments >
Application Architect
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SG CAD - Fatal error on OS in Hebrew (SPR #71135)

A fatal error occurred when opening the expression editor in the Smart Generator for AutoCAD
if the OS was in Hebrew.

Configuration
Environments > Smart
Generators

Online configuration changes (SPR #71440)

A fatal error could occur when changing configuration online.

Data Acquisition > KNX

AdNet driver - Support for unsolicited data (SPR #71768)

An issue affecting unsolicited frame handling prevented unsolicited data from being received.

Data Acquisition >
Other built-in drivers

Omron FINS - Frame size limitations (SPR #71786)
The following frame size limitations are cleared:
® A frame size could not exceed 118 words,
® A writable wordbit frame would not work if the frame size exceeded 15 words

Data Acquisition >
Other built-in drivers

Swap did not work when writing (SPR #71787)

Swapping, as defined as part of the mapping of a text variable (swapped formats), did not work
when writing. It worked properly when reading.

Data Acquisition >
Other built-in drivers

Timeout with unmanaged devices (SPR #71725)

The properties timeout and number of retries were not properly applied for unmanaged device,
leading to devices being flagged not connected where in fact the ping was just taking longer
than the default.

Data Acquisition >
SNMP Manager

Infinite loop at startup with a network license (SPR #71568)

Under some circumstances, an infinite loop could occur at startup when using a network
dongle.

The issue occurred in a scenario when the license owner is not accessible. Clicking the Quit
button caused the renter station to go in an infinite loop.

It was a regression introduced in 15.2.3.

General > Licensing
Also in: 12.0.28

Request to HDS logs with population (SPR #70752)

Requests to events logged on an HDS archive unit did not work properly when a population was
applied.

In particular, requesting logged events was incorrect when the population filter comprised
criteria on multiple variable full names or branches.

Historical data

Trend configuration handling (SPR #71427)

Since version 15, a trend item may not be deleted properly when deleting a branch if it
contained trended register variables (proprietary, ODBC and free archive units).

The fix was available since 15.2.3 for trends stored in an HDS archive unit.

Historical data

Recipe with variables of different sources (SPR #71675)

Under some circumstances, a fatal error could occur when sending a recipe that comprised
variables of different sources (OPC and BACnet for example).

Recipe

Fatal error of the SCADA Basic editor (SPR #71555)

Under some circumstances, a fatal error of the SCADA Basic editor could occur when using the
keyboard shortcut Ctrl+1+V to open the variable selector.

Scripting > SCADA
Basic

Instruction LOGDISPLAY - Wrong order with mode SETDATETIME &

FIRST (SPR #70463)

The modes SETDATETIME and FIRST of the instruction LOGDISPLAY ignored the Log viewer
property Newest records on top, leading to an incorrect event ordering after a call.

Scripting > SCADA
Basic

3.  Critical fixes

Invalid system variable after a switchover (SPR #71646)

The system variable called @System.Eqt.OKEqtCount was set NS (invalid) after a switchover.
Because this variable is often used as a criteria for triggering a switchover, the fact that it could
be invalid could impact redundancy handling.

The issue was a regression introduced in version 12.

Data Acquisition >
Other built-in drivers
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Unexpected value sent to PLC (SPR #71855)

Under some circumstances, commands on bit and register variables did not send the good
value. The issue only affected data acquisition drivers configured behind the Equipment node
of the Application Explorer (Modbus, S7...). Drivers such as BACnet, OPC, IEC ... are not affected.
The issue only occurred in a very specific and unlikely condition. A series of particular values
had to be present in adjacent addresses in the memory area where the frame is stored. But it
brought a significant risk on the physical process if the PLC did not check the received values
(consistency and range) before controlling a process' actuator.

The issue was a regression introduced in 15.2.0, it affects all releases from 15.2.0 to 15.2.3
(included).

We strongly recommend users to update to 15.2.4.

Data Acquisition >
Other built-in drivers

Invalid trend point on shutdown (SPR #71407, 71324, 71311)

When using an HDS archive unit, the invalid point (quality 64) was no longer stored when
shutting down PcVue.

The issue was a regression introduced in Maintenance Releases 12.0.26 and 15.2.1.

Historical data
Also in: 12.0.28

Upgrade Inverted associated labels (SPR #71661, 69959)

Since 15.2.2, labels in the first column for Alarm changes in log lists (Alarm on and Alarm off)
were inverted in the dialog box for configuring associated label.

While this fix is only a change of the product resources and does not affect configured
associated labels themselves, associated labels configured or modified with 15.2.2 or 15.2.3
may have been inverted if one followed the configuration Ul.

Historical data

4. Enhancements

Handling of command retry (SPR #71820)

Command retry is now in place to make sure a command is performed even if it issued during a
switchover. In such a situation, the command will be retried once the switchover is completed.

Data Acquisition >
DNP3 Client

Filtering of logged events (SPR #71557)

On proprietary archive units, it is now possible to filter logged events such as login, logout and
script execution by passing a username as part of the filter.

Such filter already worked properly for user actions on variables and alarms.

Historical data

Trend archiving inhibition (SPR #71356)

As for trends archived using a proprietary archive unit, PcVue now stores value changes as
invalid points (quality 64) when a trend stored on an HDS archive unit is inhibited. It permits the
trend viewer to render a dotted curve (invalid due to no data archived).

Historical data

Instruction SEQ_BUFFER - Support for longer fields (SPR #71474)

Modes NEXTFIELD and PREVFIELD can now extract fields up to 1024 bytes long in submode STR
(was 254).

Scripting > SCADA
Basic

Instruction WINDOWS modes CURRENTBRANCH and CURRENTNAME -

WebVue support (SPR #71659, 71644)

The instruction WINDOW modes CURRENTBRANCH & CURRENTNAME is now supported in a
web context.

Scripting > SCADA
Basic

5. Installation

OPC UA Gateway version 1.5.11 (SPR #70709)

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools
section of the DVD.

Add-ons and Tools
Also in: 12.0.28

6. Security

Vulnerability in the email & SMS account configuration (SPR #69821,
65029)

The following vulnerability is fixed. It affects the configuration of the email and SMS accounts:
®  (CVE-2022-4312 - Cleartext Storage of Sensitive Information vulnerability, allowing a
user able to authenticate locally to access the SMTP account credentials and the SIM
card PIN code - Affects all versions since 8.10.
See our Security alert page for more information.

Miscellaneous
Also in: 16.0.0, 12.0.28
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7. Other fixes & enhancements

SPR #71498, 71584, 71652, 71659, 71731, 71743

SPR #70007 Also in: 16.0.0
SPR #71732, 72461 Also in: 12.0.29
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12. Maintenance Release 15.2.3 (15.2.03900)

1. New features

Support for File Transfer services

Data Acquisition >

The standard File Transfer services are now supported. This new feature includes: DNP3 Client

® The file transfer Helper is now available on DNP3 devices nodes and stand-by devices

in the Application Explorer,
®  The Helper allows browsing files available in devices connected to the network, as well
as file Download, Upload and Deletion,
®  The SCADA Basic instruction named FILETRANSFER can be used for DNP3
communication items.
It permits handling files generated and/or stored in field devices, in particular disturbance
recording, files containing device settings or configuration.
2. Fixes

FrontVue failed to display alarms (SPR #70855) Alarms

Under some circumstances, alarm requests from a FrontVue client were not processed properly
leading to no alarm being displayed in a FrontVue alarm viewer connected to PcVue.
The issue was a regression introduced in 15.2.2.

Sql query execution failed on a client (SPR #71076)

Since Feature Release 15.2.0, executing a Sql query from a client station failed and caused the
disconnection of the client station from the server station producing the Sql connection.

Communication
interfaces

Several fixes in the MQTT Pub/Sub interface (SPR #71375, 70931,
70873)

Several fixes and enhancements of the MQTT pub/sub add-on:

®  Since 15.2.1, the register variable defined in the configuration file to reflect the MQTT
broker status was not taken into account,

Since 15.2.1, a text variable linked to a raw payload was no longer refreshed,

TLS connection to a broker failed with reason 'Unknown' if a client certificate was not
provided.

Communication
interfaces > MQTT
Pub-Sub

Could not delete actions associated to alarms (SPR #71293)

Since 12.0.25, 15.1.5 and 15.2.0 it was no longer possible to delete actions associated to alarms
in the behavior panel of the Application Explorer.

Configuration
Environments >
Application Explorer
Also in: 12.0.28

Fatal error if parameter is used twice (SPR #71002)

Under some circumstances, a fatal error of the Application Explorer could occur when using the
Test task of a Sgl connection.

The issue only occurred if a parameter was used more than once in the query, for example:
SELECT * FROM dbo.tablel WHERE VAL1 = ?Param01 AND VAL2 = ?Param01

Configuration
Environments >
Application Explorer

Memory leak with BACnet objects (SPR #70978)

Under some circumstances, a memory leak occurred on a client station (typically the web back
end) when accessing BACnet Schedule or Calendar objects for the WebScheduler.

The issue only occurred if the server station producing the BACnet objects was not available at
the time of the request from the client station.

Data Acquisition >
BACnet Client
Also in: 12.0.28

Variable refreshed with the wrong property (SPR #71128)

Under some circumstances, variables were refreshed based on the present-value of the BACnet
object it was mapped to, instead of based on the property used in the mapping (that may differ
from the present-value).

The issue only occurred when using offline mapping based on EDE files and if the device was
not started automatically at startup.

Data Acquisition >
BACnet Client
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Several fixes & enhancements related to the DNP3 client driver (SPR
#70966, 70963, 70961, 70960, 70821, 70574, 70573, 70471, 70423, 70340,
69604, 69603, 69594, 69253, 69228)

The list of fixes & enhancements includes:
® |mproved connection handling and how status & system variables are refreshed,
Improved DNP3 device redundancy,
Improved data acquisition server redundancy,
Improved handling of unsolicited data,
Improved KeepAlive implementation,
Improved handling of SBO controls,
Improved refresh of the mapping dialog box.

Data Acquisition >
DNP3 Client

Fatal error when sending multiple write commands (SPR #70802)

Under some circumstances, a fatal error could occur on a data acquisition server when sending
write commands.

The issue only occurred when sending multiple write requests simultaneously, and only in case
of connection issues with the device.

Data Acquisition >
Other built-in drivers
Also in: 12.0.27

OID parsing failure (SPR #70922)

OID parsing failed if the sub-identifier was greater than 1048576.
As a consequence, polling the OID did not work, and the linked variable was not refreshed.

Data Acquisition >
SNMP Manager

Sql variable command sent twice (SPR #70887)

When a variable mapped onto a Sql query was set using a recipe, the query was executed
twice.

Data Acquisition > Sql

Upgrade Added support to merge data on a page (SPR #70829)

For trend and log pages, it is now possible to merge newly exported data if the output already
exists.

If selected, data will be merged at the start column/start row. The behavior is similar to what
was available in version 11.2 when the option ‘Clear if exists’ was unchecked.

Data Export

Could not change aggregated stats options (SPR #71000, 70827)

The Application Explorer failed to validate changes to the advanced properties of aggregated
stats (Export timestamps or Row headers for example). The runtime behavior was correct.

In addition, the exported timestamps (beginning and/or end timestamps) did not follow the
configuration correctly.

Data Export

Cannot start a project if name has a space (SPR #71067)

Since version 12, a project having a space character in its name could no longer be started in an
RDS session.

General

Incorrect time restriction with development licenses (SPR #71147)

If a development license was rented from a network slot, data acquisition was incorrectly
limited to 1 hour instead of 4.

General > Licensing
Also in: 12.0.28

Fatal error when accessing the task scheduler (SPR #70936)

Under some circumstances, a fatal error could occur when opening the task scheduler from a
maintenance plan.

Historical data

Several fixes in trend configuration handling (SPR #71285, 71169, 70229,
70156)
The list of fixes includes:

®  Since version 15, a trend item may not be deleted properly when deleting the register
variable (HDS and proprietary archive units),

The same occurred when deleting a branch if it contained trended register variables,

A fatal error of the HDS could occur on shutdown if the configuration comprised
trends linked to an unknown archive unit.

Historical data

Variable linking did not work with register and bit variables (SPR
#70590)

Since the Initial Release of version 15, variable linking only worked with text variables. Variable
linking with a register or a text variable no longer worked properly.

HMI

Upgrade Compatibility issue with register to bit conversion (SPR #71396)
Since version 11.1, an expression requiring implicit conversion of a register value to a bit
variable no longer worked as it used to be (for example BitVarl = "RegVar & 2").

A compatibility setting named Result variable - Register to bit conversion is added. It shall be
changed from its default value when migrating a project from a version earlier than 11.2 if the
legacy behavior is still needed.

Real time data
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Instruction EVENT mode ADDPROG - Variable with multiple events
(SPR #70979)

Since version 12, when for a given variable, multiple events were created with the SCADA Basic
instruction EVENT mode ADDPROG, only the first and last ones were executed.

Scripting > SCADA
Basic
Also in: 12.0.28

Child mimic position wrong (SPR #70655)

The position of a child mimic could be wrong if open via a SCADA Basic script in web context.
The issue only occurred if there were multiple levels of parent/child mimics, causing the parent
reference to be wrong.

Web Server Extensions
> WebVue

Display not reset with empty filter (SPR #71145, 70681)

The list of alarms displayed in an alarm viewer was not reset when applying an empty filter via a
SCADA Basic script in a web context.

Web Server Extensions
> WebVue

Memory leak when accessing timetables and schedules (SPR #70890,
70816, 70009)

A memory leak occurred on the Web & Mobile back end server when using the WebScheduler
to access timetable and schedule objects.

In addition, under some circumstances, a fatal error could also occur on the producer of a
BACnet schedule object upon login in the WebScheduler.

WebScheduler
Also in: 12.0.27

3.  Critical fixes

Several fixes related to alarm handling with FrontVue and WebVue
clients (SPR #71127, 71126)
The list of fixes includes:

®  PcVue could send duplicated alarms to a FrontVue client,

®  Since version 12, PcVue could freeze and exit due to a watchdog in alarm handling if a
FrontVue client was connected,

®  Since version 12, under some circumstances, a fatal error of the Sv32.exe process
could occur when navigating in an alarm viewer from a FrontVue or WebVue client.

Alarms

New subscriptions not processed (SPR #71056)

Under some circumstances, PcVue failed to process new subscriptions received by the OPC
server.

The issue was a regression introduced in 15.2.2 and only occurred after a subscription including
more than 1000 items was received from an OPC client.

Communication
interfaces > OPC
Server

4. Enhancements

KNX - Several fixes & enhancements (SPR #70419, 65923)
The list of fixes & enhancements includes:
®  Asimulated variable is no longer set by the KNX add-on,
® |tis now possible to enable/disable communication on a KNX interface at runtime.

Add-ons and Tools

Sunair - Support for new controllers

The Sunair driver now supports T-5000A 5 kW, T-10000A 10 kW and T-10000B 10 kW
transmitter systems.

Data Acquisition >
Other built-in drivers
Also in: 12.0.28

Tyco POSM IP - Support for device redundancy (SPR #71218)

The data acquisition driver Tyco POSM over IP now supports a device standby address to
manage the Centinel redundancy system.

Data Acquisition >
Other built-in drivers
Also in: 12.0.28

Support for Context name (SPR #70725)

Added support for the Context name feature when communicating with SNMP v3 devices.

Data Acquisition >
SNMP Manager

Optimized rendering (SPR #71199, 71184, 70750)

An optimized rendering mode is now available for the desktop client.

This new mode improves the user experience on large screens (high resolution) and is useful
when the number of animations in opened mimics is in the range of several thousands.

It can be enabled via the HMI options. If set to Automatic the graphic engine automatically
activates/deactivates the optimized rendering depending on the rendering workload.

HMI
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Support for #@1 to #@12 in the Log viewer (SPR #71349, 71287, 70381) Web Server Extensions

The substitution strings for variables' branch segments #@1,#@2...#@12 are now supported by > \WebVue
the Log viewer in a web context.

5. Performance

Flow control and connection handling (SPR #71421) Communication

New connections to the OPC Server are now refused when the number of pending messages in interfaces > OPC
the queue exceeds 60% of the queue size.

This change is designed to smooth the data flow between the variable manager and the OPC Server

Server interface. Thanks to the retry mechanisms of OPC clients, in most cases, new incoming

connections are only delayed.

Improvement of the variable subscriptions (SPR #71429) Communication
Variable subscriptions and unsubscriptions coming from the OPC server are now processed by interfaces > OPC
packet.

Server

6. Security

OPC UA Gateway version 1.5.10 Add-ons and Tools
Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 12.0.27
section of the DVD.
This version of the OPC UA Gateway addresses the following security vulnerabilities:

® (CVE-2022-29862 — Chained Certificate Loop PoD

®  (CVE-2022-29864 — Reference Counter Decrement DoS
See our Security alert page for more information.

Denial Of Service vulnerability (SPR #71486) Communication

The following vulnerability is fixed. It affects the ICCP/TASE.2 interface Add-on and the IEC interfaces > ICCP
61850 Client driver:

® (CVE-2022-38138 - Access of Uninitialized Pointer vulnerability in the stack used for the
ICCP/TASE.2 interface and the IEC 61850 Client driver.

For the IEC 61850 Client driver, it affects all versions since 10.0.
For the ICCP/TASE.2 interface, it affects all versions since 15.1.

See our Security alert page for more information.

Denial Of Service vulnerability (SPR #71486) Data Acquisition > IEC
The following vulnerability is fixed. It affects the ICCP/TASE.2 interface Add-on and the IEC 61850 Client
61850 Client driver: .

Also in: 12.0.28

® (CVE-2022-38138 - Access of Uninitialized Pointer vulnerability in the stack used for the
ICCP/TASE.2 interface and the IEC 61850 Client driver.

For the IEC 61850 Client driver, it affects all versions since 10.0.
For the ICCP/TASE.2 interface, it affects all versions since 15.1.

See our Security alert page for more information.

Sensitive Information in Log File vulnerability (SPR #71136) General > Logging and
The following vulnerability is fixed: tracing

® (CVE-2022-4311 - An Insertion of Sensitive Information into Log File vulnerability exists,
allowing a user with access to the log files to discover connection strings of the data
sources configured for the DbConnect, including the credentials - Affects all releases of
version 15 up to 15.2.2.
See our Security alert page for more information.

Vulnerability in the OAuth configuration (SPR #71066, 70710) Web Server Extensions

The following vulnerability is fixed. It affects the configuration of the OAuth web service hosted  Also in: 12.0.27
in Microsoft IIS:
® (CVE-2022-2569 - Cleartext Storage of Sensitive Information vulnerability, allowing a
user able to authenticate locally to access session data of legitimate users stored in
the OAuth database - Affects versions 12 & 15.
See our Security alert page for more information.
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7. Other fixes & enhancements

SPR #69046, 69235, 70409, 70464, 70522, 70835, 70874, 71006, 71082,
71117, 71216, 71290, 71390, 71410, 71467, 71475, 71522, 71531

SPR #70713, 71058, 71134, 71235 Also in: 12.0.28
SPR #67079, 70003, 70906, 71074 Also in: 12.0.27
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13. Maintenance Release 15.2.2 (15.2.02900)

1. New features

Support for Windows 11 and Windows Server 2022

Starting with the Maintenance Release 15.2.2, PcVue supports Microsoft® Windows 11 and
Windows Server 2022.

General

2. Fixes

Several fixes and enhancements (SPR #70447, 70407, 70406, 68216)
The list of fixes & enhancements includes:

®  The timestamps of a variable with quality NS was incorrectly updated after each
request instead of remaining with the same VTQ.

®  Some qualities returned by a Remote Control Centre were incorrectly managed. Now,
the quality flag Held is interpreted as NS WD, and the flag Abnormal as NS FMT.

®  Saved variables were not set to NS COM correctly on startup when the remote LCC did
not respond before the timeout expiration.

®  The Variable value is now sent instead of the Alarm value for Alarm type bits.

Communication
interfaces > ICCP

Memory leak (SPR #70284)

A private bytes memory leak occurred when using the expression function JsonGetValue in the
context of the MQTT add-on.

Communication
interfaces > MQTT
Pub-Sub

Memory leak with large project (SPR #70401)

A memory leak occurred with large projects (over 600k variables) due to a subscription
message queue being full in the OPC Server. Additionally, some data changes were not
correctly sent to OPC clients.

Communication
interfaces > OPC
Server

Incorrect server switchover (SPR #70484)

Triggering a switchover from the Application Explorer or via SCADA Basic instruction did not
work. The switchover in case of server loss or disconnection was working correctly.

Data Acquisition >
DNP3 Client

Polling not working with server association (SPR #70422)

The polling did not work for a network configured to be produced by a server list containing an
association.

Data Acquisition >
DNP3 Client

Fatal error on Network stop (SPR #70061)

Under some circumstances, a fatal error could occur when stopping an IEC 60870-5 Network.
The issue occurred when switching a network from active to passive in redundant architectures
having multiple networks.

Data Acquisition > IEC
60870-5 Client

Incorrect traces for IEC 101/104 (SPR #70572, 70571)

Some traces were incorrect or incomplete for the IEC 101/104 Client driver.

Data Acquisition > IEC
60870-5 Client

Connection lost for a data report group (SPR #70606)

Under some circumstances, a BRCB data report group could freeze with status “Disconnected.
Report already in use”. In such case, variables mapped to the report group were no longer
refreshed.

Data Acquisition > IEC
61850 Client

Fatal error on trend export (SPR #70211)

A fatal error occurred when exporting trends with the variable description as the only column
header.

Data Export

Missing end time for aggregated statistics (SPR #70523)

Fix of a regression, since 15.2 the ending timestamp of sub-periods was no longer exported
with aggregated statistics.

Data Export

Editing Alarm On and Alarm Off labels - Follow-up on the fix in 15.2.1
(SPR #69959)

In Maintenance Release 15.2.1, the fix related to the configuration of associated labels for
alarms when the setting Log only alarm On/Off is activated was partial and brought a
regression leading to the inversion of labels. The configuration of this type of associated labels
is now functional.

General
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Fatal error at startup (SPR #70102)

Under some circumstances, a fatal error could occur at startup due a concurrent access to user
rights configuration. The issue only occurred when taking advantage of Active Directory.

General > User
management

File and folder filter of Central Project Management lost (SPR #70490)
Under some circumstances, after opening the Central Project Management dialog while the
central folder was unavailable, the file VersionConf.ini was reinitialized causing the loss of the
files and folders customization.

General > Version
management

Animations with bit rank not working (SPR #70741)

Animations based on a register variable and bit rank did not work properly when the variable
value was negative.
The issue was a regression and affected the following animations:

®  Color on register bit,

®  Text on register bit,

®  Symbol on register bit,
®  Visibility on register bit.

HMI > Animations

Error messages when changing a threshold (SPR #70351, 70185)

Since the Initial Release 15.0.0, updating a threshold on a client station lead to the display of
error messages on the variable producer station, and in some circumstances to a fatal error.

Networking

Expression - Math function not working with decimal values (SPR
#70492)

Under some circumstances, math functions failed when used with text variables due an
incorrect conversion to type double.

Real time data

Browsing level was ignored (SPR #68749)

The browsing level set on the user profile for alarms is now correctly taken into account in the
alarm view and notifications for TouchVue and SnapVue.

TouchVue

Cursor disappeared in Trend viewer (SPR #68784, 68781, 66100, 66048)

Under some circumstances, the cursor displayed in a Trend viewer could disappear. The issue
occurred when updating the zoom level or the scale visibility.

Web Server Extensions
> WebVue

Disconnection with Chrome (SPR #70057)

Under some circumstances, when using the Google Chrome browser, a disconnection could
occur after several minutes if the browser window was minimized. The issue was due to
Chrome throttling mechanisms designed for power saving.

Web Server Extensions
> WebVue

Empty toolbar display for Trend viewer (SPR #70111)
When configured without a toolbar, the Trend viewer displayed an empty toolbar instead of
using the area to display curves.

Web Server Extensions
> WebVue

Events not processed for form controls (SPR #70538)

Events such as user click triggered by a form control were not processed if the control was in a
group or a symbol. The issue only occurred in web context and prevented control animations to
be executed properly (mimic open animation on a Tree-view node for example).

Web Server Extensions
> WebVue

Fatal error when opening a web client (SPR #70146, 69869, 69791)

Under some circumstances, a fatal error of the Web & Mobile back end station could occur
when running a WebVue client. This issue was due a synchronization issue with the server.

Web Server Extensions
> WebVue

Fatal error with alarm synthesis (SPR #70341)

Under some circumstances, a fatal error could occur on the Web & Mobile back end server
upon connection of a web client. The issue occurred if a population was configured with the
property Take the applied population into account activated and the scope of at least one of its
variable set to Session context.

Web Server Extensions
> WebVue
Also in: 12.0.27

Fatal error with the combo-box control (SPR #69880)

Under circumstances, a fatal error of the Web & Mobile back end station could occur when
opening a mimic in a web context. The issue pertained to scripting of a combo-box control that
did not exist in the mimic.

Web Server Extensions
> WebVue

Incorrect handling of the Beep on new alarm property (SPR #70460,
70222)

The property Beep on new alarm on a user profile was incorrectly handled, leading to
unwanted beeps on mimic opening even without active alarms.

Web Server Extensions
> WebVue
Also in: 12.0.27

Incorrect min and max scale in Trend viewer legend (SPR #69779)

Min and max scales were incorrectly displayed in the legend of a Trend viewer for empty
trends. The issue occurred after using the SCADA Basic instruction TREND modes CLERAVAR (or
CLEARALL) and SETVAR.

Web Server Extensions
> WebVue
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Instruction ALARMDISPLAY modes AFTER and BEFORE - No longer

working (SPR #69345)
The instruction ALARMDISPLAY modes AFTER and BEFORE were no longer working in WebVue.

Web Server Extensions
> WebVue

Instruction TREND mode SETVAR - Argument ClearFlag not taken into

account (SPR #70015)

The argument ClearFlag of the SCADA Basic instruction TREND mode SETVAR was not correctly
taken into account in a web context. When executed with the same variable name, the
instruction had no effect.

Web Server Extensions
> WebVue

Instruction TREND mode SETVAR - Historical mode (SPR #69401)
The SCADA Basic instruction TREND mode SETVAR was not working properly in historical mode.

Web Server Extensions
> WebVue

Instruction TREND mode SETVAR - Legend not filled up properly (SPR

#69098)

When adding a trend with the SCADA Basic instruction TREND mode SETVAR in a web context,
the trend label in the legend was not correctly updated with the variable name when its
description was empty.

Web Server Extensions
> WebVue
Also in: 12.0.27

Instruction TREND modes CLEARVAR and SETVAR - Support for branch
(SPR #70112)

The mimic branch was not correctly taken into account when using the instruction TREND
modes CLEARVAR and SETVAR in a web context.

Web Server Extensions
> WebVue

Popup mimic failed to open from the Tree-view control (SPR #70245)
Under some circumstances, mimics failed to open when clicking quickly on Tree-view nodes
configured with link open animations to open popup mimics.

Web Server Extensions
> WebVue

Popup mimic opening position (SPR #70286)
The opening position of a popup mimic was no longer taken into account. They were always
opened at their last saved position.

Web Server Extensions
> WebVue

Position animations (SPR #70458)

Fix of several issues related to the position animations when used in a web context.

Web Server Extensions
> WebVue

Support for #@1 to #@12 in the Alarm viewer (SPR #70381, 69931,

66293)

The substitution strings for variables' branch segments #@1,#@2...#@12 are now supported by
the Alarm viewer in a web context.

Web Server Extensions
> WebVue

Support for @#V in the Trend viewer (SPR #70157)

The Trend viewer now supports the substitution @#V used to refer to the context variable in a
web context.

Web Server Extensions
> WebVue
Also in: 12.0.27

Trend display in future (SPR #69468)

When displaying a time period partly in the future with a Trend viewer (current day for
example), trends were incorrectly displaying a straight line from the last known value to the
end of the displayed period.

Web Server Extensions
> WebVue

Truncated display when switching to full screen (SPR #70168)

Under some circumstances, mimics display could be truncated when switching to full screen
mode. The issue occurred with mimics larger than the window.

Web Server Extensions
> WebVue

3. Enhancements

Time synch type (SPR #70724)

For time synch requests, the type (Serial vs LAN) is now configurable in the Advanced
properties of the DNP3 device configuration item.

Data Acquisition >
DNP3 Client

Configurable request timeout (SPR #70209, 67340)

A new global setting Request timeout is available (default 30 sec). It can also be overridden at
device level.

Prior to this enhancement the time-out was fixed at 30 sec.

Data Acquisition > IEC
61850 Client
Also in: 16.0.0

Omron FINS - Support for EM and HR (SPR #70736)

The data acquisition Omron FINS over IP now supports access to the EM and HR memory areas.

Data Acquisition >
Other built-in drivers
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Improved control of the DEP system configuration (SPR #70359) General

As part of the support for Windows 11 and Windows Server 2022, the control of the system
configuration for DEP is improved (Data Execution Prevention).

The implementation now overrides the system-wide policy by attempting to automatically
disable DEP for sv32.exe and AlExplorer.exe processes. The system DEP policy setting must be
OptlIn (default setting for Windows client versions), OptOut (default setting for Windows Server
versions), or AlwaysOff.

If the system DEP policy is AlwaysOn, the PcVue application returns an error on startup and
then stop.

The same goes for FrontVue.

New HMI option for tabbed mimic (SPR #70453) HMI

A new HMI option called Windows.Tab Mimics.Close container mimic when closing a tab using
link animation or scripting is available.

It enables closing the parent mimic when a link animation or a SCADA Basic program is
triggered from within a tabbed mimic requesting it to be closed.

The option defaults to false for existing project and to true for a new project.

Execution of Scheduled actions (SPR #70355) Miscellaneous
It is now possible to define if a Scheduled action has to be executed:

® At project startup,

®  Upon modification,

®  When the system clock is adjusted.

4, Installation

Installation failure on Windows 7 SP1 and Windows Server 2008 R2 Installation

(SPR #70329, 70199)

The Feature Release 15.2 failed to install on Windows 7 SP1 and Windows Server 2008 R2.
This is a known issue in 15.2.0 and 15.2.1

5.  Security

OPC UA Gateway version 1.5.9 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools
section of the DVD.
This version of the OPC UA Gateway addresses the following security vulnerabilities:

® (CVE-2021-45117

® (CVE-2022-0778
See our Security alert page for more information.

6. Other fixes & enhancements

SPR #68671, 70335, 70336, 70350, 70371, 70466, 70507, 70512, 70595,
70603, 70604, 70631
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14. Maintenance Release 15.2.1 (15.2.01900)

1. Fixes

Local variables set to NS COM LAN after server restart (SPR #70306)

Under some circumstances, the quality of local saved variables could be set to NS COM LAN
after the restart of a passive server. The issue only occurred if the subscription to the active
server was not completed before the timeout period (1 min).

Networking

2. Enhancements

Quality extraction (SPR #70213, 70123)

Quality was not correctly extracted and interpreted when it had a value different from 0.

Communication
interfaces > MQTT
Pub-Sub

SetDataSet enhancements
When updating a variable with the SetDataSet method, it is now possible :
®  To update its value even if the quality remain invalid,

®  To only update its quality and timestamp by using a VT_EMPTY structure as the
current value.

Development kits > SV
Manager Toolkit

3. Installation

Documentation update General >
The product documentation has been updated: Documentation

®  Online help in Russian - Now at the level of version 12. Also in: 12.0.27
Sentinel System driver 7.6.1 General > Licensing
Update of the installation package for the Sentinel System driver. Also in: 12.0.27

4. Security

Dream Report version 2020 R2 SP1

Update of the installation package for Dream Report available in the Add-ons & Tools section of

the DVD.
This version of Dream Report addresses the following security vulnerabilities:

® (CVE-2020-13532
® (CVE-2020-13533
® (CVE-2020-13534

® (CVE-2021-21957
See our Security alert page for more information.

Add-ons and Tools
Also in: 12.0.27
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15. Feature Release 15.2.0 (15.2.00900)

1. New features

Modeling of Sql Variables

It is now possible to model the mapping of variables onto the Sql data acquisition driver in a
template.

Configuration
Environments >
Application Architect

Modeling of IEC 101 & IEC 104 configuration items (SPR #68838, 68829,

68549)

Definition of IEC 101 configuration items - Devices, Sectors and Standby devices - and IEC 104
Standby devices in templates and instances.

Configuration
Environments >
Application Architect

New data acquisition driver - Omron FINS TCP

A data acquisition driver for Omron FINS over TCP is now available.

Data Acquisition >
Other built-in drivers

New data acquisition driver - Modbus RTU over IP

A data acquisition driver is now available to support communication with PLCs requiring the use
of Modbus RTU payload over a TCP connection.

Data Acquisition >
Other built-in drivers

Predefined Sql write queries (SPR #69815)

In addition to Sql read queries, it is now possible to predefine Sql write queries. They are
designed to handle commands for variables mapped onto the Sql driver.

Data Acquisition > Sql

Expression on text variables (SPR #64556)

String-based expressions are now supported throughout the product, including expressions on
variables with a result variable of type Text, expression templates and animations on a text
value.

General

Instruction GETARG - New mode GETREGION (SPR #17611, 17029,

15919, 14982, 13618)

A new mode GETREGION is available for the instruction GETARG. If the script is called from an
animation, it returns the region where the calling mimic is located.

Scripting > SCADA
Basic
Also in: 16.0.0

Instruction GEOLOCATION - New mode GETLASTSCANTIME (SPR

#69573)
The new mode GETLASTSCANTIME returns the last timestamp of a geo-tag.

Scripting > SCADA
Basic

New action Open chat SnapVue
The new action allows opening a chat room with SnapVue according to the geolocation of the

user.

New tile type in SnapVue SnapVue

In SnapVue, the image on a tile can now be dynamically changed according to the value of a
Register variable.

Reference: PcVue 15 Release Notes
Copyright ©2026 - ARC Informatique. All rights reserved — LN {0 I3

Last update: April 2, 2026
Page 38/124



4
PcVue >

2. Fixes
Busbar coloring - Handling of uncertain voltage (SPR #69355) Add-ons and Tools
Uncertain voltages were not correctly propagated to downstream nodes. Also in: 15.1.2
EtherNET-IP - Attributes 3 to 5 ignored (SPR #69250) Add-ons and Tools
It was not possible to use text extended attributes 3 to 5 to configure variables for the Also in: 15.1.1
EtherNET-IP add-on.
Fatal error on alarm apparition (SPR #69996, 69874) Alarms
Under some circumstances, a fatal error could occur when a new alarm was triggered while a Also in: 12.0.25

log request was in progress if the alarm matched the log request filter criteria.

Wrong alarm timestamp set (SPR #69559) Alarms

Fix of regression, since 12.0.20 and 15.0.0, writing the value of an alarm in a SCADA Basic script ~ Also in: 15.1.3. 12.0.24
was causing the timestamp to be changed even if the value was the same. '

Fatal error with OPC Server interface (SPR #68813) Communication

Under some circumstances, a fatal error could occur when using the OPC Server interface, due interfaces > OPC Server
to some resources not being released properly. .
Alsoin: 15.1.1, 15.0.3,

12.0.22,11.2.06099

Fatal error on alarm creation (SPR #69232) Configuration
Under some circumstances, a fatal error occurred when creating an alarm if the text extended Environments
attributes were configured to store the alarm timestamps (Alarm on, Alarm Ack and Alarm Off). .

Also in: 15.1.1
Documentation not saved nor loaded (SPR #69921) Configuration
Since version 15, documentation was no longer loaded nor saved due to a file format change. Environments >

Application Architect
Also in: 15.1.5

Could not set the value of a parameter (SPR #68854) Configuration

It was not possible to set the value of a parameter when it was defined with its Element type set  Environments >
to Associated Label.

Application Architect

Hierarchy not consistent in generated files (SPR #69068) Configuration

Under some circumstances, the instances hierarchy in application files was not correctly applied  Environments >
leading to incorrect generated files.

Application Architect

Naming rule not evaluated (SPR #68550) Configuration

Under some circumstances, the naming rule of an item could not be evaluated when defined by  Environments >
a parameter.

Application Architect

Fatal error on Log report modification (SPR #69558) Configuration

A fatal error occurred when modifying or creating a Log report while the print spooler service Environments >

was unavailable. . .
Application Explorer
Also in: 15.1.4, 12.0.24,
11.2.06101

Could not create an Open mimic geo action (SPR #69006, 68949) Configuration

Under some circumstances, it was not possible to create a geo action of type Open mimicdue to  Environments >
an incorrect syntax checking.

Application Explorer
Also in: 15.1.1

DDE Client - Fatal error (SPR #69385) Data Acquisition

Under some circumstances, a fatal could occur when linking a variable to an Excel file with DDE.  A|so in: 15.1.2
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Fatal error with notification event Data Acquisition >

A fatal error occurred upon reception of an event notification of type change-of-characterstring. BACnet Client
Alsoin: 15.1.3

Write priority not taken into account (SPR #69239, 69171) Data Acquisition >

Since version 15.0.0, the priority of the 1st command sent for a BACnet variable was always set BACnet Client
to 16 (the Write priority property of the variable was ignored). The Write priority property was .

correctly taken into account for subsequent commands. Depending on the BACnet server Also in: 15.1.1
implementation, the issue could occur again after a re-start of the server controller.

Fatal error on Binary input update (SPR #69186) Data Acquisition >

Under some circumstances, a fatal error could occur when trying to update a Binary input value  DNP3 Client
while the device was unavailable.

Alsoin: 15.1.5
Cyclic polling executed only on redundant field device (SPR #69846) Data Acquisition >
In a redundant configuration, only the redundant field device was triggering cyclic polling. DNP3 Client
Alsoin: 15.1.5
Fatal error on device deletion (SPR #69405) Data Acquisition >
Under some circumstances, a fatal error occurred when deleting a DNP3 Device or Standby DNP3 Client
device right after its creation.
Fatal error when sending a command (SPR #68508) Data Acquisition >
Under some circumstances, a fatal error occurred when sending a command to a device that DNP3 Client
had never been successfully connected. .
Alsoin: 15.1.2
Timestamp type configuration (SPR #69324) Data Acquisition >
It is now possible to select how the timestamp of data should be interpreted. It can be either DNP3 Client
Local or UTC (default). .
For compatibility reasons, the new setting is set to Local for already configured devices. Alsoin: 15.1.2

Several fixes in the IEC 61850 client (SPR #69617, 69591, 69028, 65630) Data Acquisition > IEC

The list of fixes includes: 61850 Client

® A connection request was sent twice when a report group was duplicated Alsoin: 15.1.4
configuration, ’ o

®  The Application Explorer froze after starting communication with an IED if the logical
devices could not be browsed (empty descriptors),

It was possible to open multiple dialog for adding redundant RCB,
Syntax control was incorrect for the variable name in the mapping dialog.

Fatal error when opening a destination folder (SPR #69025) Data Acquisition > IEC

A fatal error occurred in the File transfer helper when trying to open the destination folder ofan 61850 Client
invalid file. Now the associated link is disabled when the file/folder is invalid or unavailable.
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Several fixes in the IEC 61850 client (SPR #69562, 69525, 69485, 69479, Data Acquisition > IEC

69473, 69429, 69398, 69397, 69372, 69354, 69220, 69058, 69024, 68989) 61850 Client
The list of fixes includes: Also in: 15.1.3

® Incorrect behavior in the Application Explorer when validating a variable mapping with
only an IEC 61850 network selected,

®  Update of the list of error codes corresponding to the AddCause for the M61850
SCADA Basic instruction. It now matches the AddCause enumeration as defined in the
IEC 61850 ed 2.1 standard,

®  The Application Explorer could freeze when enabling/disabling the Send Rptld property
while the device was still in the connecting state or if the corresponding attribute of
the Report Control Block was not writable for some reasons,

The time quality sent as part of a control was incorrect for BSC Data Objects,

Fix an incorrect behavior when controlling a Data Object with a CtlVal Data Attribute of
type bitstring (typically BSC and BAC Data Objects),

®  |mproved error management while browsing, the mapping dialog could freeze if an
MMS PDU max size error occurred,

®  Update of the Common Data Classes catalog to fit changes and new CDCs in the IEC
61850-7-3 ed2 and ed2.1,

Offline mapping with redundant reports did not work properly,

Improved behavior of the mapping dialog if the connection to an IED is lost while in
online mode,

®  Fix of a fatal error of PcVue when changing the mapping of a variable from a Data
Object to a Data Attribute,

®  Fix of anincorrect behavior related to the handling of the trial mode causing a freeze of
the Application Explorer when starting or stopping an IEC 61850 communication
object,

®  The SCL attribute LDName is now used if it exists when using the offline browsing and
mapping,

®  |mproved automatic naming when mapping to a new variable. '-' are now replaced by
' 'to fit the syntax constraints of a variable name,

®  Under some circumstances, the Application Explorer could freeze when changing the
dataset associated to a report group,

® |fareportgroupisinan error state related to configuration - configured dataset does
not exist in the IED for example - it will no longer try to reconnect automatically.
Automatic reconnection is still in place if the error state is related to typical runtime
errors (loss of connection for example),

®  Under some circumstances, a fatal error of the Application Explorer and repeating
disconnection/reconnection could occur. The issue was related to the handling of the
object-access-denied error when writing a Report Control Block attribute.
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Several fixes in the IEC 61850 client (SPR #69432, 69429, 69398, 69387,
69386, 69374, 69372, 69371, 69365, 69361, 69358, 69353, 69352, 69351,
69350, 69347, 69219, 69174, 69122, 69112, 68976, 68961)

The list of fixes includes:

® Incorrect datatype filter in the variable selector when opened from the mapping
dialog,

®  Under some circumstances, the variable type was changed when mapping on an
existing variable from the mapping dialog,

®  Afatal error could occur upon connection if the configuration included a dataset with a
long name,

® DE, SBO and SBOw commands executed from a SCADA Basic script failed with error -6

(incorrect variable type) for variables mapped on any CDC type other than SPC and DPC

(bit variables),

®  Afatal error occurred when executing a command from a SCADA Basic script for a
variable mapped on a DO of type BSC,

Fix the catalog for the mapping of the BAC CDC,
Fix of a regression, since 11.2.06092 & 15.0.0 writing a variable mapped onto a Data
Attribute no longer worked,

®  PcVue could freeze when sending a command if the command response comprised an
unknown/unsupported data structure,

®  Fix the error handling when receiving the response- object-access-denied upon sending

a Select command,

The max length of a report Id is now 129 characters (was 65),

The timestamp quality was not properly set when sending a command,
Traces added when commands are sent in test mode,

Fix of a memory leak occurring when stopping or deleting a device while connection
was still in progress,

®  Under some circumstances, the Application Explorer could freeze when a report Id was
changed at the device level while configuring a report group,

®  Under some circumstances, the Application Explorer could freeze when starting a
report group missing some required configuration properties.

Data Acquisition > IEC

61850 Client
Also in: 15.1.2

DataGroup variables not refreshed after network
disconnection/reconnection (SPR #68663, 68619)

Since release 15.0.0, status of variables mapped to a DataGroup were not correctly refreshed
and remained NS COM after a network disconnection/reconnection.

Data Acquisition > IEC
61850 Client
Also in: 15.1.1

Several fixes in the IEC 61850 client (SPR #69177, 69151, 69128)
The list of fixes includes:
®  PcVue could freeze when sending a control if the IED did not expose the proper Data
Attributes for a controllable DO,
®  The Application Explorer could freeze when activating traces on an existing report
group, or upon a configuration change of a report (from a non-redundant to a
redundant and vice-versa),
Misleading Error O traced upon creation of a report group,
A fatal error could occur under some circumstances when changing the configuration
of a variable while a read or write request was being executed.

Data Acquisition > IEC
61850 Client
Also in: 15.1.1

Fatal error on disconnection (SPR #69276, 66623)

Under some circumstances, a fatal error could occur when disconnecting from an OPC Server.

Data Acquisition > OPC
Client
Also in: 15.1.2, 12.0.23

Improper NS SPEC status for OPC variables (SPR #69149)

Under some circumstances, OPC variables were displayed with the NS SPEC status instead of NS
on passive servers and client stations.

Data Acquisition > OPC
Client
Also in: 15.1.1

OPC items with bad quality not ignored (SPR #69148)

Since version 11.1, the setting defined in the OPC Server configuration that allows ignoring the
value of an item with quality Bad was not working properly with bit and alarm variables.

Data Acquisition > OPC
Client

Also in: 15.1.1, 15.0.3,
12.0.23,11.2.06099
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IP-ISO-S7 & S7-IP-MASTER drivers - Encoding of string values (SPR
#69415)

String encoding was not correctly handled for Siemens data acquisition drivers. Using the
advanced property Source encoding, the encoding can now be set to Siemens string for text
variables mapped to a source IP-ISO-S7 or S7-IP-MASTER.

Data Acquisition >
Other built-in drivers

Signed float 32-bit not correctly interpreted (SPR #69260)

Variables of type Signed float 32-bit were not correctly interpreted and were set with status NS
FMT when using the Swapped word format.

Data Acquisition >
Other built-in drivers
Also in: 15.1.1

Fatal error on Sql query parameter reset (SPR #69183)

Under some circumstances, a fatal error occurred when resetting the value of a query
parameter.

Data Acquisition > Sql

Export not generated or incomplete (SPR #69907)

Since release 15.1.0, Data Export was no longer working due to an incorrect range calculation
when the property Append after last row was selected.

Data Export
Also in: 16.0.0, 15.1.5

Fatal error with export of aggregated statistic (SPR #69908)

A fatal error occurred when exporting aggregated statistics with only the description header.

Data Export
Also in: 15.1.5

Error message when exporting aggregated statistics (SPR #69284)

An incorrect error message was displayed when running an export with the property Export
aggregated statistics set but without the option Export statistics.

Data Export

Detection of permissions on output folder (SPR #69521)

The verification of permissions on the Export folder could be incorrect if it was a shared folder.

Data Export
Also in: 16.0.0, 15.1.3

Error with text variable in Data export name (SPR #69664, 68837, 68832)

Text variables were not correctly supported when used in the Name property of a Data export
item.

Data Export
Also in: 15.1.5, 12.0.29

Could not export without the variable name (SPR #69560, 69226)

A data export failed to export a trend page if it was not configured to include the variable name
in the header.

Data Export
Also in: 15.1.3

Incomplete statistics log export (SPR #69203)

Under some circumstances, log statistics exports were incomplete due to an incorrect line
calculation.

Data Export
Also in: 15.1.2

Incorrect aggregated value (SPR #69283, 67600)

Under some circumstances, invalid aggregated values were exported. The issue occurred when
no record was found in the exported time period, causing a random value to be exported.

Data Export
Also in: 15.1.2,12.0.23

Additional empty line (SPR #69119)

When exporting logged events, an empty line was inserted between the header and the values.

Data Export
Also in: 15.1.1, 15.0.3

ControlMinValue and ControlMaxValue not refreshed (SPR #69152)

Despite being correctly set, the ControlMinValue and ControlMaxValue properties of a variable
were not correctly refreshed after calling the SetVariableAttributes method.

Development kits > SV
Manager Toolkit

Also in: 15.1.1
Error message on loading of a threshold variable (SPR #67115) General
Due to a tighter control of the configuration, the error message 19412 was traced when the
scope of a threshold variable did not match that of the register variable it was linked to. The
scope of a threshold variable is now automatically set to match that of the register variable it is
linked to. The same goes for the server and client lists.
Reference Project & Library system variables not refreshed (SPR General
#69579, 69113) Also in: 16.0.0

The system variables Version.Reference.ProjectisNotCurrentRef and
Version.Reference.LibrarylsNotCurrentRef were only refreshed on version number change, they
are now also refreshed when the project or library content is updated.
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Binary attributes not correctly loaded (SPR #69871) General

Since version 10.0, the binary attribute 32 was not correctly loaded at startup whenitwassetto Also in: 15.1.5
1. In such a situation, all the binary attributes were set to 1 except the binary attribute 32.

Fatal error on project migration (SPR #66997) General

A fatal error could occur when migrating a project developed with versions 10.0 SP1to 12. The  Also in: 15.1.5
issue was due to a misinterpretation of a legacy field in the networking configuration.

Expression engine - StrToTS returns an incorrect value General

An incorrect value was returned when using the function StrToTS format with the YY year

format.

Fatal error after online help opening (SPR #69346, 69266) General

Since version 15.1.0, a fatal error occurred when opening the online help from the SCADA Basic  Also in: 15.1.2
Editor to display the help associated to an instruction.

Alarm timestamps not saved (SPR #69032) General

When an alarm was configured with the Saved property enabled, not all of its timestamps
(AlaOn, AlaAck, AlaOff) were stored. Only the timestamp of its last state was recorded. These
timestamps can be used in the Alarm viewer.

Also in: 15.1.1, 15.0.3,
12.0.22

AD group names with non-latin characters (SPR #68705)

Active Directory group browsing failed when the name of a group comprised non-latin
characters.

General > User
management

Upgrade Could no longer create a version (SPR #69196)

Since version 15.0.0 and the introduction of the 3-digits scheme for project and lib versioning, it
was no longer possible to create a version having a Major or Minor number greater than 100.

It was still possible to update and load versions, but creating a new version on top of an existing
one was leading to a fatal error when exceeding this limit.

This is a known issue in 15.0.0 to 15.0.2 and 15.1.0 to 15.1.1

General > Version
management
Also in: 15.1.1, 15.0.3

HDS - Batch size setting ignored

The global setting MaxBookmarkinTable defined in the file Bin\HDS.ini was ignored, the batch
size was always set to 15 records.

Historical data

Proprietary archives - Support for comma in log list (SPR #69189)
Extended attributes including comma characters were incorrectly recorded in log lists on
proprietary archive units.

Historical data

Wrong language for the event title (SPR #64121)

The property Archive language was not taken into account for the field Event title in HDS
databases. The language corresponding to the Configuration 1 was always used for this field.

Historical data
Also in: 15.1.3

Fatal error with large .hds temporary file (SPR #73098, 69357, 66782)

Historical data

A fatal error occurred when the size of a temporary file exceeded 2 Gb. Also in: 12.0.30
From now on, these files are limited to 2 Gb and are indexed when reaching this limit.

Improved robustness when loading symbols (SPR #69143) HMI

Improved robustness and tracing when a symbol failed to load due to syntax or configuration

issues.

Mimic not saved upon closure (SPR #68633) HMI

The prompt to save a modified mimic in design failed to open after modifying the size if its Size

parameter was set to Scale mimic to fit window.

Mimic not opened in the correct region (SPR #69412, 69256) HMI

Cached mimic were not opened in the correct region when opened via a VBA script. Also in: 15.1.2
Clipboard paste (SPR #68372) HMI

Better control of the clipboard Paste command to prevent side effects when the type of data
contained in the clipboard is not supported and not supposed to be pasted in a mimic.

Also in: 15.1.2,12.0.23

Aknowledgment, masking and unmasking not disabled (SPR #69787)

It was still possible to acknowledge, mask or unmask alarms even if the alarm viewer was
configured not to permit it via properties in the Execution tab.

HMI > Alarm viewer
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Tooltip truncated (SPR #69339)

Under some circumstances, the tooltip of an animation was truncated.

HMI > Animations
Also in: 15.1.3, 12.0.24,
11.2.06101

Tree-view control - Text and User data deleted on edit (SPR #69470,
68985)

The value of Text and User data of a Tree-view control item where deleted when entering the
edit mode of their respective field.

HMI > Form controls
Also in: 15.1.3

Ctrl+Z not working (SPR #69462)

Undoing mimic modifications was not working properly when graphic elements were moved
using the keyboard arrow keys.

HMI > Graphics

Several fixes related to the Log viewer (SPR #69632, 69629)
The list of fixes includes:
®  When resuming the auto-refresh, the list of events was not correctly refreshed,

®  Auto-refresh was deactivated when the user requested the most recent events (using
line or page navigation buttons).

HMI > Log viewer
Also in: 15.1.4

Fatal error with Map positioning animation (SPR #69541)

A fatal occurred with the Map positioning animation when the selected layer was not displayed.

HMI > Map control

Markers not displayed correctly (SPR #69519)

Under some circumstances, markers were not displayed correctly when changing the zoom level
while having the setting Keep invisible markers in memory enabled.

HMI > Map control
Also in: 15.1.5

Fatal error when adding trends by script (SPR #69477)

A fatal error occurred when removing and adding trends to a Trend viewer via a SCADA Basic
script.

HMI > Trend viewer
Also in: 15.1.3, 12.0.24,
11.2.06101

Expression engine - Access to binary attributes 31 and 32 (SPR #69748)

It was not possible to use Binary Attributes 31 and 32 in the expression engine.

Miscellaneous

Several fixes related to Recipes (SPR #69322)

The list of fixes includes:

® Anincorrect error message was displayed when a recipe file name was over 8
characters,

A fatal error occurred when validating a recipe without a title or recipe number,

Under some circumstances, updating the title or recipe number was not taken into
account or created a duplicated recipe.

Miscellaneous
Also in: 15.1.5, 12.0.24

Variables @DATE & @TIME not updated (SPR #69349)

Under some circumstances, the variables @DATE and @TIME could no longer be updated. The
issue occurred after having applied a population.

Miscellaneous
Alsoin: 15.1.4,12.0.24

Json path not recognized (SPR #69202)

Miscellaneous

Under some circumstances, some Json paths were not correctly interpreted by the Also in: 15.1.1
JsonGetValue function of the expression engine. The issue occurred when the Json path ended

with an array index, for example JsonGetValue(value,'value.temperature.values[0]')

This function is typically used with the MQTT Add-on.

Status of variable NS COM LAN at startup (SPR #69929) Networking
Under some circumstances in an architecture with multiple server associations, variables could  Also in: 15.1.5
remained NS COM LAN after a client startup and until a variable change occurred.

Fatal error after a variable modification (SPR #69898) Networking

Under some circumstances, with an architecture having a single active server association for
data acquisition, a fatal error could occur if a configuration modification of an 1/O variable was
done on the active server. The issue was a regression since 15.0.0 and could only occur if the
server had switched from passive to active at least once.
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System variable AutomaticLogoffRemainingTime not updated (SPR
#69511)

The variable System.Localhost.User.AutomaticLogoffRemainingTime was not correctly updated
when the project contained multiple stations. The equivalent variable in the branch
System.<StationNumber> was correctly updated.

Real time data

Instruction EXCELTOBUF - Memory leak (SPR #70005)

A memory leak occurred when executing the instruction EXCELTOBUF. Its size depended on the
file size.

Scripting > SCADA
Basic
Also in: 16.0.0

Instruction FORMAT - Fatal error with numeric value (SPR #68632)

Under some circumstances, a fatal error could occur when using the instruction FORMAT with a
numeric value and the %s format.

Scripting > SCADA
Basic

Instruction FTP modes DOWNLOAD & UPLOAD - GDI object leak (SPR

#69306)

A GDI object leak occurred when using the SCADA Basic instruction FTP with modes DOWNLOAD
and UPLOAD.

Scripting > SCADA
Basic
Also in: 15.1.4,12.0.24

Instruction MDNP3 - Arguments not recognized (SPR #69348, 69186)

When using the instruction MDNP3, some arguments defined in the syntax 11 (modes related to
CROB) were only recognized if using their numeric value.

MDNP3 (Mode, Variable, OpType, Queue,
TripClose, Count, OnTime, OffTimel[,
This was affecting the arguments OpType, Queue, Clear and TripClose.

Clear,
ResultVar]) ;

Scripting > SCADA
Basic
Also in: 15.1.4

Instruction ANIMATION mode EXECUTE - Incorrect return value (SPR

#69264)

The instruction ANIMATION mode EXECUTE always returned 1 even when the animation to
trigger did not exist.

Scripting > SCADA
Basic

Instruction STATION_FILTER with Log viewer in WebVue

The instruction STATION_FILTER did not apply population filters properly for Log viewers in
WebVue.

Scripting > SCADA
Basic

Instruction WEBVUE mode MULTIMEDIA - Fatal error when in the Main

sub (SPR #69449)

A fatal error occurred when executing the instruction WEBVUE with mode MULTIMEDIA from
the Main sub of a SCADA Basic program.

Scripting > SCADA
Basic
Also in: 15.1.2

Instruction EXPORT - Fatal error with a static export file name (SPR
#69293)

A fatal error occurred when calling the instruction EXPORT if the referenced export had a
statically defined export file name, i.e. a name not defined by an expression.

Scripting > SCADA
Basic
Also in: 15.1.1

Instruction LISTBOX modes GETUSERDATA & GETTEXT - Returned an

empty string (SPR #68787)

Under some circumstances, the instruction LISTBOX modes GETUSERDATA and GETTEXT
returned an empty string when executed from a web client for a newly added item (i.e. added
with mode INSERT or LOAD)

Scripting > SCADA
Basic
Also in: 15.1.1

Upgrade Instruction LOGDISPLAY mode LINESELECT - Inconsistent

result between desktop client and WebVue (SPR #66032)

The instruction LOGDISPLAY mode LINESELECT did not return the same Xml fragment when
executed from a desktop client or from WebVue. The Xml content has been harmonized and
now only returns the variable name.

Scripts written for WebVue using this instruction need to be updated accordingly.

Scripting > SCADA
Basic
Also in: 15.1.1

Instructions CHECKBOX, LISTBOX & OPTIONLIST mode REMOVE -

Incorrect return value (SPR #69155)

Calling the mode REMOVE of instructions CHECKBOX, LISTBOX and OPTIONLIST always returned
0. It now returns 1 when successful and 0 otherwise, as described in the online help.

Scripting > SCADA
Basic
Also in: 15.1.1
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Instruction MAPDISPLAY - Fatal error with modes LOADDEFAULT and
EXPORT (SPR #69019)

Under some circumstances, a fatal error could occur when calling the modes LOADDEFAULT and
EXPORT in sequence.

Scripting > SCADA
Basic
Also in: 15.1.1, 12.0.23

Symbols not displayed on tiles (SPR #69551)

Under some circumstances, symbols were not displayed on tiles when using a Web & Mobile
Back end license.

SnapVue
Also in: 15.1.4

Animation not played correctly (SPR #69983)

Under some circumstances, animations were not played correctly when the mimic contained a
Trend viewer in real-time mode and was opened with a branch.

Web Server Extensions
> WebVue
Also in: 16.0.0

Filtering Log viewer alarms with level 0 only (SPR #70046)

It was not possible to filter alarms in a Log viewer to view only alarms with level 0. When setting
the filter from level O to level 0, the max level was automatically set to 29.

Web Server Extensions
> WebVue
Also in: 16.0.0

Trend viewer scrolling back in time (SPR #69565)

Under some circumstances, when using the trend viewer scrollbar, it was not possible to scroll
back in time up to when the mimic was open (as for the PcVue desktop trend viewer).

Web Server Extensions
> WebVue
Also in: 15.1.5

Cursor and zoom in Trend viewer stopped working (SPR #68784, 68781,
66100, 66048)

Several fixes related to the zoom and cursor features of the Trend viewer. After multiple
actions, the cursor and zoom were no longer working.

Web Server Extensions
> WebVue

Invalid period not correctly rendered in the Trend viewer (SPR #67718)

The line drawn from an archived valid value to the current real time value was not correct if the
current status was NS.

Web Server Extensions
> WebVue

Residual input with Send Text/Register animation (SPR #69698, 69697,
69692, 69691, 69672, 69670)

Under some circumstances, a residual text was visible when entering a new value using the
Send Text or Send Register animations. The issue occurred when the supporting text element
was defined with a transparent background.

Web Server Extensions
> WebVue

Truncated mimic (SPR #69843)

Mimic were incorrectly displayed and truncated when the setting Scale mimic to fit window was
activated and the mimic needed to be up scaled.

Web Server Extensions
> WebVue

Fatal error on client session closing (SPR #69878)
A fatal error occurred when closing a web session while a Sql query was still in progress.

Web Server Extensions
> WebVue
Also in: 15.1.5

Incorrect color for Alarm On and Alarm Off events (SPR #69800)

The configured text color for the events Alarm On and Alarm Off was not correctly taken into
account in the Log viewer and were always displayed with a white color.

Web Server Extensions
> WebVue
Also in: 15.1.5

Several fixes related to the Log viewer (SPR #69746, 69699, 69668, 69666,
69632, 69629, 69535)

The list of fixes includes:
®  When resuming the auto-refresh, the list of events was not correctly refreshed,

®  Auto-refresh was deactivated when the user requested the most recent events (using
line or page navigation buttons),

®  Under some circumstances, the viewer was not emptied after a request that returned
no line,

The active filter and sorting order could be reset when using the auto-refresh option,

The navigation scrollbars were moving atop when the auto-refresh option was
activated,

®  The dialog box title displayed in the calendar selector was undefined.

Web Server Extensions
> WebVue
Also in: 15.1.4
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Rotated text truncated (SPR #68935)

Under some circumstances, rotated texts were incorrectly rendered. They were truncated when
embedded in a symbol.

Web Server Extensions
> WebVue
Also in: 15.1.5

Line selection in List-box form control (SPR #68780)

When a line was not completely visible in a List-box form control (with horizontal scrollbar),
selecting it was not highlighting the whole line.

Web Server Extensions
> WebVue

Log viewer emptied upon scrolling (SPR #69486)

Under some circumstances, a Log viewer could be emptied while scrolling up or down with the
mouse.

Web Server Extensions
> WebVue
Also in: 15.1.3

Inconsistent language for system messages (SPR #68782)
Some system messages were displayed using the server language instead of the client language.

Web Server Extensions
> WebVue

Moving mimics outside of the viewport (SPR #66078)

Mimics can no longer be moved outside of the left and top viewport borders, and a scrollbar
appears when moved out through the bottom or the right border.

Web Server Extensions
> WebVue

Could no longer minimize the toolbar (SPR #69377, 69289)

Under some circumstances, it was no longer possible to minimize the system toolbar.

Web Server Extensions
> WebVue
Also in: 15.1.3

Trend viewer background color not applied (SPR #69375, 69270)

Fix of a regression, the configured background color was no longer applied to the Trend viewer.

Web Server Extensions
> WebVue
Also in: 15.1.3

Associated actions not working (SPR #69329)

Since version 15.0.0, associated actions were no longer working in a web context.

Web Server Extensions
> WebVue
Also in: 15.1.2

Cursor value had incorrect decimal digits (SPR #68786)

The cursor value displayed on the scale ignored the configuration of the max number of digits.

Web Server Extensions
> WebVue
Also in: 15.1.1

Improper cursor value in Trend viewer (SPR #68934)

In a Trend viewer, the cursor column in the legend displayed an improper value after execution
of the SCADA BASIC instruction TREND mode SETVAR or CLEARVAR, or after a request to the
archives.

Web Server Extensions
> WebVue
Also in: 15.1.1

Could not reconnect to the WebScheduler (SPR #70011)

Under some circumstances, it was no longer possible to connect to the WebScheduler due to an
incorrect handling of the token expiration on the server side.

WebScheduler
Also in: 16.0.0

Setting FirstDayOfWeek not correctly taken into account (SPR #69314,
68462)

The setting FirstDayOfWeek was not correctly taken into account in the Standard week display.

WebScheduler
Also in: 15.1.2, 12.0.23

Exception period not reset for BACnet schedules (SPR #67240)

The button to reset exception periods of a BACnet schedule was not effective.

In such a case, most BACnet server devices support setting the length of the Exception-Schedule
array to 0. For interop with devices that only support a fixed-length Exception-Schedule array,
an interop property has been added to the configuration of BACnet devices so that resetting the
exception periods does not change the length of the Exception-Schedule array but fills it with
Null values instead.

WebScheduler
Also in: 15.1.1

Incorrect label for the mode (SPR #69089)

The displayed label corresponding to the mode of a time interval for a BACnet Schedule was
incorrect and not taking into account the corresponding associated label.

WebScheduler
Also in: 15.1.1
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3.  Critical fixes

Variables no longer archived if No permanent scan for mimic property Data Acquisition >
activated (SPR #68853) BACnet Client

When the setting No permanent scan for mimics was activated, the polling frequency was not
correctly set at mimic opening for those variables that are also archived, and polling stopped
when closing the mimic, causing a potential loss of data for those archived variables.

Data overwritten (SPR #69285, 69277) Data Export

Since Release 15.0.0, when using the mode Append after last row for an Excel file, newly Also in: 15.1.1
exported data could overwrite data exported during an earlier export.

The issue was due to an incorrect calculation of the last non-empty cell in the Excel file.

This is a known issue in 15.0.0 to 15.0.3 and 15.1.0

Memory leaks (SPR #69240, 69217) Web Server Extensions

Memory leaks occurred when Web or Mobile clients were connected. Alsoin: 15.1.1, 12.0.24
The issue was a regression since release 15.0.0.
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4. Enhancements

License utility - New tab for Server options

Options related to Server interface options are now displayed in a separated tab. Prior to this

change, they were in the Options tab.

Add-ons and Tools

Dynamic point creation (SPR #69064)

Adding IEC104 Outstation points is now dynamically applied and no longer requires restarting

the project.

Communication
interfaces > IEC 60870-
5-104 Outstation

UTF-8 encoding (SPR #69549)

The payload is now encoded in UTF-8 for a better support of non-latin languages.

Communication
interfaces > MQTT Pub-
Sub

Sql query editor - Support for Undo and Redo (SPR #69585)

The Sqgl query editor now supports the Ctrl+Z (undo) and Ctrl+Y (redo) accelerators.

In addition, decorated text is now pasted as raw text to facilitate copy/paste from rich text
editors.

Configuration
Environments >
Application Explorer

Variable description in DNP3 mapping dialog (SPR #69433)
The variable description can now be displayed in the DNP3 mapping dialog box.

Configuration
Environments >
Application Explorer
Also in: 15.1.4

Access to the project folder

A new task Open project folder is available when the project node is selected. It opens the
project folder with the Windows file explorer.

Configuration
Environments >
Application Explorer

Setting task added (SPR #68856)

The Setting task is now accessible when the Data analysis node is selected

Configuration
Environments >
Application Explorer

Maximum number of serial devices (SPR #69254)

The maximum number of devices declared for a serial protocol is now limited to 5000 (was
limited to 1000).

Data Acquisition
Also in: 15.1.1

Driver Ad-Net - Support for broadcast

The Ad-Net driver now supports broadcast for requesting devices status.

Data Acquisition >
Other built-in drivers

Driver Ad-Net - Configuration dialogs

Configuration dialogs are now available for the Ad-Net data acquisition driver.

Data Acquisition >
Other built-in drivers

Mapping of integer values
The value of a bit variable can now be associated to a column of a Sqgl query result of type

integer. If the integer value is different from 0 or 1, then the status of the bit variable is set to

NS.

Data Acquisition > Sql
Also in: 16.0.0

Improvement to triggers
Upon completion of a query, it is now possible to execute a secondary query.

Data Acquisition > Sql

Parameters size limitation
Some size limitations have been increased for parameters used in queries:
®  Parameter description is now limited to 255 characters (was 20)
®  String parameters' value is now limited to 2048 characters (was 132)

Data Acquisition > Sql

Triggering request on variable value change
It is now possible to trigger a Sql read request on a variable value change.

Data Acquisition > Sql
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New function in the expression engine - IsSDBNull() (SPR #69981) General

A new function IsDBNull() is available for the expression engine. It is particularly useful for Also in: 15.1.5
managing NULL values returned by the Sql data acquisition driver.

New functions in the expression engine General

New functions are available in the expression engine:
®  TSToPosixTime(TS)

PosixTimeToTS(PosixTime)

ToBool()

ToDbl()

TsNow(TSKind)

Partial library version (SPR #69644)

It is now possible to select only a part of a library (e.g. B directory only) to include in a library
version instead of the whole library.

General > Version
management

New button Refresh (SPR #69116)

A new Refresh button is available in the Central Project Management dialog box.

It allows refreshing information in the dialog box, in particular the list of available versions in the
central folder.

General > Version
management

New default for popup windows (SPR #69608)

From now on, the global setting HMI options.Mimics.Popup.Open by program is by default
activated when creating a new project.

HMI

Large toolbar support for Alarm and Log viewer (SPR #69245)

Support for large toolbars to make it easier to use the viewers when using a touch screen. A
large toolbar was already available for the Trend viewer.

HMI

User experience for Send register and Send text animations (SPR
#69029)

A new HMI option is available to define at design time if a command should be performed upon
pressing the Return key or if it should also be performed when the control loses the focus.

HMI > Animations

Tree-view control - Selection of the default node (SPR #68499)

It is now possible to define the default node selection in a tree-view control at mimic opening.
This default selection can be enforced by the variable associated to the Index or User data
properties.

HMI > Form controls

Tree-view control - Send Text animation with default value (SPR
#69214)

It is now possible to execute a Send text animation with a default value in direct mode.

HMI > Form controls

Support for substitution strings (SPR #69363)

When using the Grid control in variable tracking mode, it is now possible to use substitution
strings such as #B in the filter.

HMI > Grid control

Instant Messaging responsiveness

Improvement to the responsiveness, the delay when sending and receiving messages is
reduced.

Instant Messaging

Instruction SQL_COMMAND - Additional error code

An additional error code SQL_COMMAND_CONNECTION_ALREADY _CLOSE_OR_NOT_INIT has
been added to the modes EXECREADER, EXECSCALAR and EXECNONQUERY of the instruction
SQL_COMMAND.

Scripting > SCADA
Basic

Instruction TREEVIEW modes COLLAPSENODE & EXPANDNODE - All
nodes at once (SPR #69359)

It is now possible to collapse and expand all nodes at once by passing the argument Nodeld with
value 0.

Scripting > SCADA
Basic

Instruction TREEVIEW modes SETTEXT and SETUSERDATA - Support

for WebVue (SPR #66636)

The modes SETTEXT and SETUSERDATA of the instruction TREEVIEW are now fully supported in
WebVue.

Scripting > SCADA
Basic
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Instruction TREND - New mode SETSAVERUNTIMEPROPS (SPR #69366) Scripting > SCADA

A new mode SETSAVERUNTIMEPROPS is available for the instruction TREND. It enables setting Basic
the property Save runtime properties of a Trend viewer.

Instruction WINDOW - New mode GETSELECTEDTAB (SPR #68740) Scripting > SCADA

A new mode GETSELECTEDTAB is available for the instruction WINDOW. It returns the index of Basic
the active tab of a mimic (1-based).

Instruction WINDOW - New mode GETTAB (SPR #68740) Scripting > SCADA
A new mode GETTAB is available for the instruction WINDOW. Depending on a sub-mode Basic

(BRANCH, NAME or CAPTION), it returns the branch, name or caption of the tab index passed as

argument.

Instruction TREND - New modes GETCONFIG, GETCONFIG_ASYNC & Scripting > SCADA
SETCONFIG (SPR #69185, 68205) Basic

3 new modes are available for the instruction TREND: Also in: 15.1.1

®  GETCONFIG & GETCONFIG_ASYNC: To retrieve the configuration of a Trend viewer
under the form of an Xml fragment,

®  SETCONFIG: To set the configuration of a Trend viewer by passing it an Xml fragment
containing the desired configuration.
These modes enable getting and setting the configuration of a trend viewer all at-once (list of
trends, graphical rendering properties...).

Trend viewer autofit mode Web Server Extensions
The autofit mode in the Trend viewer is now supported in real time. > WebVue
Filtering HDS log list with Sql-like syntax (SPR #68855, 68823) Web Server Extensions

It is now possible to use Sql-like syntax when filtering Log lists for a Log viewer with the SCADA > WebVue
Basic instruction LOGDISPLAY mode FILTER. .
Also in: 15.1.1, 15.0.3,

12.0.22

Configuring BACnet schedule using an unsigned datatype (SPR #69634) WebScheduler

It is now possible to configure a BACnet schedule linked to a multi-state-value object using the Also in: 16.0.0
unsigned datatype. Until this enhancement, only the enumerated datatype was supported.
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5. Performance

Time to open/close a session (SPR #69199) Real time data
The time to open and close a WebVue session has been significantly improved, in particular Alsoin: 15.1.1, 12.0.23
when the project comprises a large amount of alarm syntheses.

For example on a project with 6000 alarms, 3000 alarm syntheses and 15000 alarm synthesis
counters:

Before performance improvement:
® Time to open a WebVue session: 18.5 sec, including 17 sec to load alarm synthesis,

®  Time to close a WebVue session: 3 min 9 sec, including 3 min 5 sec to unload context
variables.
After performance improvement:

® Time to open a WebVue session: 4.9 sec, including 3.5 sec to load alarm synthesis,
® Time to close a WebVue session: 2.5 sec, including 1 sec to unload context variables.
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6. Audit & diagnostic

New system variables and audit counters (SPR #69320)

New system variables are available for the IEC 104 outstation:
®  Number of active client connections: System.LocalHost.IEC104Server.NbClients
®  List of client names: System.LocalHost.IEC104Server.Clients

Communication
interfaces > IEC 60870-
5-104 Outstation

They are also available in the branch System.<StationName> Also in: 15.1.1
The following audit counters are now also available:

®  Number of outstation

®  Max nb of clients allowed

®  Number of point published

®  Number of clients connected

®  Number of write received from clients
New audit counters for variables with status invalid General

New audits counters are available for variable status, split by variable source:
®  Counter of variables with status NS
®  Counter of variables with status NS COM
®  Counter of variables with status NS SPEC
®  Counter of variables with status NS COM LAN
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7. Installation

OPC UA Gateway version 1.5.7 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools
section of the DVD.

Updated libraries General
Update of the following libraries:

® HVAC,

®  Pipes,

®  Arrows.

Missing component registration Installation

Since Release 15.0.0, the component registration was not executed automatically after installing  Also in: 15.1.4
a patch. On computers with other versions of PcVue or other products installed (such as

FrontVue), fatal errors and other unexpected behaviors could occur due to the fact that the

proper version of a component may not be registered within the operating system.

This is a known issue in all Maintenance Releases of 15.0 and 15.1 up to 15.1.4

Reference: PcVue 15 Release Notes Last update: April 2, 2026
Copyright ©2026 - ARC Informatique. All rights reserved — LN {0 I3 Page 55/124



4
PcVue >

8.  Security

Upgrade Limit access to the file system (SPR #69992, 67953, 65359) HMI
When using the Data Export wizard, the button allowing the selection of the export folder is no

longer accessible to users without desktop access privilege.

OpenSSL library updated Security

The OpenSSL library has been updated to version 1.1.11 (24-Aug-2021).

Memory address in traces

The event traced for session timeout contained a memory address instead of the correct session
id.

Web Server Extensions

Vulnerabilities in the Web back end modules

This is a follow-up to fixes available since 11.2.06097, 12.0.17 and 15.0.0. This fix covers other
ways to exploit similar Remote Code Execution vulnerabilities uncovered after more tests of the
initial fix.

The following vulnerability is fixed. It affects the interface between the Web & Mobile back end
and the web services hosted in Microsoft IIS:

® (CVE-2020-26867 - A Remote Code Execution vulnerability due to the unsafe
deserialization of messages received on the interface - Affects all versions since 8.10.
See our Security alert page for more information.

Web Server Extensions
Alsoin: 15.1.2, 12.0.23,
11.2.06100

TLS support (SPR #69616)
The WebScheduler now supports the use of TLS 1.2.

WebScheduler
Also in: 15.1.4
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9. Other fixes & enhancements

SPR #64106, 66156, 66840, 68520, 68700, 68709, 68791, 68849, 68889,
68996, 69217, 69298, 69334, 69454, 69482, 69578, 69624, 69699, 69856

SPR #70018 Also in: 16.0.0

SPR #69014, 69790, 69913 Also in: 15.1.5

SPR #69894, 69895 Also in: 15.1.5, 12.0.25

SPR #69820 Also in: 15.1.5, 12.0.24

SPR #69529 Also in: 15.1.4

SPR #69566 Also in: 15.1.3

SPR #69218 Also in: 15.1.3, 12.0.24,
11.2.06101

SPR #68847, 69249, 69259, 69278, 69340, 69379 Also in: 15.1.2

SPR #66940, 68964, 69073, 69209, 69213, 69341, 69342 Also in: 15.1.1

SPR #68704, 68881 Also in: 15.1.1, 15.0.3

SPR #69216, 69235 Also in: 15.1.1, 12.0.23

SPR #66177, 66223 Also in: 15.0.0,
11.2.06089
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16. Feature Release 15.1.0 (15.1.00900)

1. New features

ICCP/TASE.2 interface

New interface based on the IEC 60870-6, the standard for data exchange between control
centers.

Communication
interfaces > ICCP

IEC 61870-5-101 client driver

This new driver operates in unbalanced mode over TCP or UDP and is designed to support
legacy IEC 101 devices accessed through serial-to-IP gateways.

Data Acquisition

SCL-based configuration

It is now possible to associate SCL files to IEC 61850 network and take advantage of offline
mapping e.g. the ability to create communication items and map variables based on the content
of your SCL files, even if devices are not connected.

Data Acquisition > IEC
61850 Client

New data acquisition driver - AdNet (SPR #69130)

A data acquisition driver for AdNet controllers is now available.

Data Acquisition >
Other built-in drivers
Also in: 15.0.3

New data acquisition driver - IpFluke
A data acquisition driver for Fluke devices is now available.

Data Acquisition >
Other built-in drivers

Mapping of the Quality property (SPR #68972)

The status (quality) of a variable can now be mapped onto the results of a Sql query by using any
of the following:

® VAR_QUALITY_GOOD - To set the variable status to valid,
® VAR_QUALITY_NS - To set the variable status to invalid,

®  VAR_QUALITY_NSCOM - To set the variable status to invalid due to a communication
error.

Data Acquisition > Sql

Xml file references

In addition to Excel files available since version 12, it is now possible to reference Xml files that
are used throughout the project, in particular in configuration modeling with the Application
Architect.

The support for Xml file references comes with a new expression function Xm/GetValue() and an
Xml file viewer . They help the application designer looking up Xml fragments based on XPath
queries.

General

Upgrade New instruction M60870_5 for IEC101 & IEC 104

In addition to the new IEC 101 driver, a new SCADA Basic instruction M60870_5 is available for
communication control of both IEC 101 and IEC 104 devices.

The existing M104 instruction is deprecated but still supported at runtime for compatibility
purpose.

Scripting > SCADA
Basic

Progressive Web App support

It is now possible to install WebVue as a Progressive Web App (PWA) on web client devices.

Web Server Extensions
> WebVue
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2. Fixes

DBImport - Log suffix not correctly managed (SPR #68868, 68864, 68744)

When using the DBImport for importing logged events, the Log suffix was not correctly
managed, leading to incorrect import.

Add-ons and Tools
Also in: 15.0.3, 12.0.22

MultiTech LoRa - Fatal error due to missing Ack (SPR #68797)

Add-ons and Tools

Under some circumstances, a fatal error occurred when the acknowledgement part of the Also in: 15.0.2
message was missing, i.e. after sending a message with the format Payload|Port where

Payload|Port|[Ack was expected.

Masked alarm reappearing after passive server restart (SPR #68378) Alarms

Under some circumstances, saved alarms were incorrectly reloaded when a passive server was
restarting. Specifically, their saved Masked status could be corrupted and trigger reappearance
or disappearance of such alarms upon a restart.

Also in: 15.0.1, 12.0.20

First message not published (SPR #68835)

The first message of a topic was not published for a variable that was used both for SUB and for
PUB.

Communication
interfaces > MQTT Pub-
Sub

Also in: 15.0.3

Unable to read values (SPR #68811)

It was not possible to parse values with the JsonGetValue() expression function when the Json
path contained parentheses.

Communication
interfaces > MQTT Pub-
Sub

Also in: 15.0.3

Fatal error when extracting an analog value (SPR #68710)
A fatal occurred when a data extraction returned an analog value.

Communication
interfaces > MQTT Pub-
Sub

Also in: 15.0.2

Negative values not correctly managed (SPR #68712)

Negative values were not correctly managed and interpreted with bad quality NS FMT.

Communication
interfaces > MQTT Pub-
Sub

Also in: 15.0.2

Incorrect error code (SPR #68612)

For an out-of-bounds register value, error code 1 was sent as part of the published message
instead of error code 133 or 134.

Communication
interfaces > MQTT Pub-
Sub

Also in: 15.0.1

Fatal error on variable update (SPR #67987)

Under some circumstances, a fatal error could occur upon update of a variable by an OPC client
connected to the OPC Server if the configuration of the type was incorrect.

Communication
interfaces > OPC Server
Also in: 15.0.1,
11.2.06098

SCADA Basic editor frozen (SPR #68683, 68650, 68448)

Under some circumstances, the SCADA Basic editor could freeze, preventing from editing the
opened script. The issue occurred after closing the editor while maximized and with line
numbers displayed.

Configuration
Environments
Also in: 15.0.2

Incorrect list of attributes in Log lists (SPR #68543)

When editing the list of attributes to records in a log list, a comma was added at the beginning
of the value, preventing the property to be interpreted correctly at runtime.

Configuration
Environments

Unable to set the Tile size (SPR #68917)

It was not possible to set the tile size for actions on geographical zones.

Configuration
Environments >
Application Architect
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Fatal error on generation (SPR #68953)

Under some circumstances a fatal error could occur when generating with a large project due to
the dynamic refresh of consumed 10 variables.

Configuration
Environments >
Application Architect
Also in: 15.0.3

Zones incorrectly deleted (SPR #68703)

Deleting a zone was incorrectly deleting all the zones of the template if they had the same
prefix.

Configuration
Environments >
Application Architect
Also in: 15.0.2

Timestamp type for IEC 104 Sectors (SPR #68569)

It was not possible to configure the Timestamp type (UTC or Local) for IEC 104 Sectors modeled
with the Application Architect.

Configuration
Environments >
Application Architect
Alsoin: 15.0.2, 12.0.21

OPC-XML server not correctly created (SPR #68568, 68486)

OPC-XML servers were not correctly created if modeled with the Application Architect. The Url
property was missing.

Configuration
Environments >
Application Architect
Also in: 15.0.2, 12.0.20

Incorrect attribute configuration for log lists

The default list of attributes to record for a log list was set to empty instead of #@A1,#@A2 for
proprietary, ODBC and free archive unit types.

Configuration
Environments >
Application Architect
Also in: 15.0.1

Sql variables mapping lost (SPR #68969)

The mapping of SQL variables was lost when configured on a client station.

Configuration
Environments >
Application Explorer

Unable to set the confirmation message in actions (SPR #68945, 68604)

It was not possible to set a confirmation message for actions in Geographical zones.

Configuration
Environments >
Application Explorer
Also in: 15.0.3

Could not delete HDS database

Since version 15.0.0, it was no longer possible to delete the last configured database of a
project.

This is a known issue in 15.0.0

Configuration
Environments >
Application Explorer
Also in: 15.0.1

SG-TwinCAT - Fatal error when importing .tpy file (SPR #68659)

A fatal error occurred when importing a .tpy file due an infinite loop while parsing an improper
configuration with recursive properties in data type definitions.

Configuration
Environments > Smart
Generators

Also in: 15.0.1

SG-OPC - Incorrect server after synchronization (SPR #68454)

Under some circumstances, an incorrect server was set after an import synchronization. The
issue occurred when multiples servers were configured and the selected server was different
from the first one.

Configuration
Environments > Smart
Generators

Also in: 15.0.1, 12.0.20

ReadPropertyMultiple fallback

The following errors were not managed in case of ReadPropertyMultiple failure, and the fallback
was not correctly triggered :

®  error_code_unknown_object
®  abort_preempted
®  abort_invalid_APDU

Data Acquisition >
BACnet Client
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IEC 104 - Interrogations sent twice on server switchover (SPR #68701)
In a redundant architecture, Interrogation requests were sent twice on server switchover.

Data Acquisition > IEC
60870-5 Client
Also in: 11.2.06099

Several fixes & enhancements related to the IEC 104 client driver (SPR
#68721, 68552, 65778, 65317, 62179, 60533, 58890)
The list of fixes & enhancements includes:

®  Stopping multiple networks is now executed concurrently,

®  Afatal error could occur during project exit,

® |n case of device redundancy, a fatal error could occur if the standby device was
considered as active,

®  Sectors and Devices needed to be restarted to apply configuration modifications, they
are now applied dynamically,

New variables had an unknown status until their first refresh, they are now NS COM,

Under some circumstances, a fatal error could occur upon a device stop due to a
memory leak,

® Anincorrect status was displayed in the Application Explorer when devices were not
reachable or disconnected,

®  Under some circumstances, a fatal error could occur during project exit after multiple
switchover of redundant devices,

®  Pending commands were not correctly cleared upon redundant device switchover.

Data Acquisition > IEC
60870-5 Client
Also in: 11.2.06098

Several fixes & enhancements related to the IEC 104 client driver (SPR
#68490, 68489, 68208, 65317)
The list of fixes & enhancements includes:

®  Variables could be NS COM after a server switchover due to a fatal error of a server,

®  Variables could be NS COM after a redundant device switchover due to a
communication loss while switching,

STOP DT was not sent after a server switched passive, or stopped,

A new general setting is available to set a delay before switching from passive to active
(defaults to 200 ms).

Data Acquisition > IEC
60870-5 Client
Also in: 11.2.06097

Fatal error on server switch (SPR #69173)

Under some circumstances, a fatal error could occur upon data acquisition server switchover, in
a variety of cases when a BRCB could not be connected:

®  Device offline,

®  RCB did not exist in the device,

®  Wrong dataset referenced on the RCB,
°

Data Acquisition > IEC
61850 Client

Useless purge buffer sent (SPR #69164)

Useless purge buffer commands were sent.
The issue was a regression introduced in PcVue 15.0.1.

Data Acquisition > IEC
61850 Client

Incorrect status icon displayed (SPR #68348)

An incorrect icon was displayed in the Application Explorer when configuring a report, with the
Network-dependent configuration option selected for the property Original Report name.

Data Acquisition > IEC
61850 Client

Memory leaks (SPR #69111)

Under some circumstances, memory leaks occurred, in particular:
®  Upon sending a command of type DEW or SBOW,
®  Upon device connection.

Data Acquisition > IEC
61850 Client

Incorrect error message in the event viewer (SPR #68425)

Under some circumstances, incorrect error messages were displayed in the event viewer when
sending a command for an IEC 61850 variable. The issue occurred when extended attributes
were not enabled for the variable.

Data Acquisition > IEC
61850 Client

Fatal error with File Transfer (SPR #68741)

Under some circumstances, a fatal error could occur when using the File Transfer.

Data Acquisition > IEC
61850 Client
Also in: 15.0.2
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Fatal error on passive server (SPR #68426)

A fatal error could occur when stopping a passive server due to pending reports not deleted
correctly.

Data Acquisition > IEC
61850 Client
Also in: 15.0.1, 12.0.20

Report groups disabled (SPR #68460)

Under some circumstances, a report group was disabled after receiving a report that had the
buffer overflow flag set.

Data Acquisition > IEC
61850 Client
Also in: 15.0.1, 12.0.20

Fatal error on device disconnection (SPR #68291)
Under some circumstances, a fatal error could occur upon device disconnection.

Data Acquisition > IEC
61850 Client

Also in: 15.0.1,
11.2.06098

Memory leak with array of strings (SPR #68954)

A memory leak occurred when variables were mapped to an OPC DA item of type array of
strings. The amount of leake memory depended on the size of the array.

Data Acquisition > OPC
Client
Also in: 15.0.3, 12.0.22

Fatal error when writing an SNMP variable (SPR #68479)

Under some circumstances, a fatal error could occur when writing an SNMP variable.

Data Acquisition >
SNMP Manager
Also in: 15.0.1, 12.0.20

Memory leak on errors (SPR #68511)

Under some circumstances, a memory leak could occur when facing connectivity issues with
devices refreshed by polling. Some polled read requests were not correctly freed after errors.

Data Acquisition >
SNMP Manager
Also in: 15.0.1, 12.0.20

Test connection requires Diagnostic permission

The Test connection action in the Application Explorer now requires the user to have the
Diagnostic permission.

Data Acquisition > Sql

Trend export failed with Current period (SPR #68304)

Since version 15.0.0, trend export failed if set to export for the Current period.
This is a known issue in 15.0.0

Data Export
Also in: 15.0.1

Unable to deploy a web site with multiple bindings (SPR #68301)

It was not possible to deploy a web site with a mix of binding on IP address and binding on
hostname.

Deployment tools >
Web Deployment
Console

Also in: 15.0.1

Memory leak on modification of text extended attributes (SPR #68634)

A memory leak occurred when writing text extended text attributes of a variable.

General
Also in: 15.0.2, 12.0.21

Temporary license not recognized (SPR #68563)

An incorrect date was displayed when starting a project with a temporary license that was not
yet active.

General > Licensing
Also in: 15.0.1

Improved handling of the reference files (SPR #69050, 69045, 68982)

Several fixes and enhancements in the handling of the ref.dat and refversion.dat files to prevent
incorrect updates of these files and locking of the Central Project Management user interface.

General > Version
management

Unable to set Reference version (SPR #67963)

No error or warning message was displayed to warn the user when the current Windows user
had insufficient write permission to the central version folder.

General > Version
management

Instant Messaging data wrongly included in project version (SPR
#68401)

The folder MsgData, used for the Instant Messaging persistent data, is now by default excluded
from Central Version Management.

General > Version
management

Progress bar not accurate (SPR #68409)

The progress bar displaying the progression of a version creation (or update) was not accurate.

General > Version
management
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Could not disable central project management (SPR #68456)

Since version 15.0.0, it was no longer possible to disable the central project management from
the dialog box.

General > Version
management
Also in: 15.0.2

Localhost system variables not updated (SPR #68456)

Since version 15.0.0, the Localhost system variables related to the project and libraries versions
were not correctly updated when the central project management was disabled.

General > Version
management
Also in: 15.0.2

Records lost after changing primary unit (SPR #67341)

When changing the primary unit for a trend, the buffered but not yet recorded data were lost.
The issue only affected proprietary archive units and occurred in particular when changing the
primary unit of the trend with the instruction HISTORY.

Historical data

HDS not stopping (SPR #68314)

Under some circumstances, the HDS was not correctly stopped at project exit. The issue
occurred after having added a new trend associated to a long update rate, and the project exit
being triggered before the end of the first update period of the new trend.

Historical data
Also in: 15.0.1, 12.0.20

HDS fatal error upon shutdown (SPR #68338)

Under some circumstances, a fatal error of the HDS could occur upon project shutdown.

Historical data
Also in: 12.0.20

Instance Selector - Fatal error with filter (SPR #68763)

Under some circumstances, a fatal error occurred when using some filters such as Start With,
with special characters.

HMI

Virtual keypad for user animations (SPR #68669)

The virtual keypad could not be used with some user animations (user name, signature ...).

HMI > Animations
Also in: 15.0.2, 12.0.21

Tree-view control - Mimic not closed (SPR #68539)

In a tree-view control, the animation Link.open with the parameter Caller mimic behavior set to
Close was not working correctly, the caller mimic was not closed.

HMI > Form controls
Also in: 15.0.2

Anchor point lost on symbol creation (SPR #68386)

When creating a symbol, the anchor point was reset to (0,0). The anchor point of the group is
now retained as the anchor point of the symbol.

HMI > Graphics
Also in: 15.0.3

#V not resolved (SPR #65319)

The #V substitution string was not resolved in the Trend viewer, preventing from using it in the
legend or Data export wizard.

HMI > Trend viewer
Also in: 15.0.3, 12.0.23,
11.2.06100

Fatal error with the Data export wizard (SPR #68475, 68163)

A fata error occurred when using the Data export wizard from a Trend viewer in case of
insufficient permissions on the export folder.

HMI > Trend viewer

Trends partially displayed (SPR #67819)

Under some circumstances, trends were only partially displayed due to an incorrect behavior of
the compression algorithm with invalid points.

HMI > Trend viewer
Also in: 11.2.06097

Sending SMS with China-Telecom SIM card (SPR #68603)

It was not possible to send SMS when using a China-Telecom SIM card.

Miscellaneous

Unable to send email or SMS to AD users (SPR #68190)

When sending an email or an SMS to all users having a given profile, AD users did not receive
the message even if the profile was associated to an Active Directory group.

Miscellaneous

Multiple server switchovers at startup (SPR #68748) Networking
Under some circumstances, server were switching active/passive multiple times after a server

restart due to a timing-issue on server status detection. The issue only occurred with an

association having 3 or more servers.

Initial value of new variables not loaded (SPR #68578) Networking

When updating a project version on a passive server, newly created variables (in this project
version) were not correctly initialized with their initial value after a server switchover.

Also in: 15.0.1, 12.0.20
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Multiple active servers in a single active server association (SPR
#68379)

In a single active server historical association, multiple servers could be active simultaneously
when started at the same time or after a network failure.

Networking
Also in: 15.0.1, 12.0.20

Fatal error when editing a variable (SPR #68843)

Under some circumstances, a fatal error could occur when modifying a variable produced by
another station.

Real time data
Also in: 15.0.3

Instruction OPTIONLIST - Fatal error on selected item change (SPR
#68981, 68980)

Under some circumstances, a fatal error occurred when changing the selected item if the
previous one had been removed via a SCADA Basic script (mode CLEAR).

Scripting > SCADA
Basic
Also in: 15.0.3

Instruction M61850 modes START and STOP - Incorrect value for
ResultVar (SPR #68422)

An incorrect value was returned in the ResultVar variable by the instruction M61850 with
modes START and STOP.

Scripting > SCADA
Basic

Upgrade Instruction GEOLOACTION modes GETDISTANCE and

GETUSERACCURACY - Incorrect error return value

Instruction GEOLOCATION modes GETDISTANCE and GETUSERACCURACY now return -1 in case
of error (instead of 0).

Scripting > SCADA
Basic

Instruction OPTION mode REMOVE - Fatal error (SPR #68680)

A fatal error occurred when removing an item from an option list control with the SCADA Basic
instruction OPTIONLIST mode REMOVE.

Scripting > SCADA
Basic
Also in: 15.0.2

Instruction FOPEN - Fatal error with unknown access mode (SPR
#68097)

A fatal error could occur when using the instruction FOPEN with an unexpected access mode
argument.

Scripting > SCADA
Basic
Also in: 15.0.1, 12.0.20

BeforeClose script not triggered (SPR #68418)

The SCADA Basic function called upon closing a mimic was not correctly triggered when the
mimic was closed via SCADA Basic.

This fix applies to PcVue desktop only.

Scripting > SCADA
Basic
Also in: 12.0.20

Login script not executed (SPR #66502)

The SCADA Basic login script was not executed for web clients except for WebVue. It is now also
executed when login in from the WebScheduler and when opening a session with the Web
Services Toolkit.

Web Server Extensions

Fatal error on web session opening (SPR #68602)

A fatal error of the Web back end could occur when opening a web session if an alarm synthesis
was defined and the corresponding variable was missing in the configuration.

Web Server Extensions
Also in: 15.0.2, 12.0.21

Scrolling in the Log viewer (SPR #68846)

In WebVue, scrolling in the Log viewer did not work properly.

Web Server Extensions
> WebVue
Also in: 15.0.3

Trends not displayed (SPR #68698, 67972)

Trends were not displayed when the style of invalid points was set to Invisible.

Web Server Extensions
> WebVue
Also in: 15.0.2, 12.0.21

Instruction WINDOW mode CLOSEALL - Mimics close failed (SPR

#68639)

The SCADA Basic instruction WINDOW mode CLOSEALL was not working properly in a web
context. Some mimics could fail to close and remained open.

Web Server Extensions
> WebVue
Also in: 15.0.1, 12.0.20
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WebScheduler not accessible (SPR #69170, 69036) WebScheduler

Since version 15.0.0, it was no longer possible to use the WebScheduler without having a Web Also in: 15.0.3
Service Toolkit option on the license. This regression was due to a tightened control of the web

accesses in version 15.0.0.

The issue also affected access from 3rd party software taking advantage of the Web Services

Toolkit such as Dream Report.

This is a known issue in 15.0.0 to 15.0.2

Schedules not displayed (SPR #68478) WebScheduler

Under some circumstances, schedules were not displayed. The issue only occurred when a
schedule had some special characters such has <, >, -, ( or ) in its title.

Incorrect text encoding (SPR #67999, 61478) WebScheduler

Some cultures relying on non-latin characters were not correctly managed by the Also in: 15.0.2, 12.0.21
WebScheduler, leading to incorrect text display.

Setting FirstDayOfWeek not taken into account (SPR #68462) WebScheduler

The setting FirstDayOfWeek defined in the web.config file was not correctly taken into account.  Alsg in: 15.0.2. 12.0.21
Starting from version 15, this setting can be set with the Web Deployment Console when ’
deploying the WebScheduler.
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3.  Critical fixes

Slow operations due to IEC 61850 (SPR #69165) Data Acquisition > IEC

The handling of persistency for Report Control Block Entryld caused a general periodic slow 61850 Client
down of the computer used as data acquisition server.

Several fixes in the IEC 61850 client driver (SPR #68689, 68649, 68638, Data Acquisition > IEC
68600, 68521, 68519) 61850 Client
The list of fixes includes: Also in: 15.0.1

®  Fatal error upon loss of connection to a device configured with reports,

®  Fatal error upon receiving an error from a device when using the file transfer services
(empty source folder).
In addition, when using redundant data acquisition servers:

®  Variable values were not correctly refreshed when an RCB was configured without Gl,

®  Fatal error when stopping a redundant RCB if the dataset no longer existed in the
configuration (typically occurred upon stopping a device),

®  Fatal error of both passive and active servers when stopping an active server.

Upgrade Polling groups lost (SPR #69086) Data Acquisition >

When upgrading a project from version 12 to version 15, the SNMP polling groups were lost due  SNMP Manager
to an issue in configuration saving with version 12. .
This is a known issue in 15.0.0 to 15.0.2 Also in: 15.0.3
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4. Enhancements

TATT Topic definition

It is now possible to define a topic by using multiple text attributes, which can be used to
overcome their length limitation (100 characters):

TATT13 = BUILDING1/ROOM3/TEMP

TATT14 = MQTT|Generic|Brokerl |SUB|O|TATT13

The same principle is applied with the '@' character to bypass the GenericRootTopic:
TATT14 = MQTT|Generic|Brokerl |SUB|O|W@TATT13

Communication
interfaces > MQTT Pub-
Sub

Population configuration (SPR #68494)

It is now possible to copy, cut and paste population configuration items.

Configuration
Environments >
Application Explorer

Start & Stop commands for Sql connections

It is now possible to start and stop Sql connections directly from within the Application Explorer.

They require the user to have the Diagnostic permission.
In addition, the current state of Sql connections is now displayed.

Configuration
Environments >
Application Explorer

System variables SubscriptionCompleted and

UnsubscriptionCompleted not correctly refreshed

System variables SYSTEM.BACNET.<Network>.SubscriptionCompleted and
SYSTEM.BACNET.<Network>.UnsubscriptionCompleted were not correctly refreshed on COV
subscriptions and unsubscriptions.

Data Acquisition >
BACnet Client

Delaying value refresh after write (SPR #68871)

A new setting is available for IEC 60870-5 devices to disable the local refresh of a variable after

sending a write command. When activated, the value is refreshed upon the next read request or

notification.

Data Acquisition > IEC
60870-5 Client

New BITMASK expression (SPR #68570)

It is now possible to use the custom field BITMASK(x) in the advanced properties of OPC
variables. The variable value is then the result of the logical bit AND operation between the OPC
item value and the mask.

Data Acquisition > OPC
Client
Also in: 15.0.2, 12.0.21

New interop property (SPR #68568, 68486)

A new interop property is available for OPC-XML servers. It enables adding the http basic
authentication header to all requests and is designed for OPC-XML servers that do not send the
HTTP 401 error if the header is required.

Data Acquisition > OPC
Client
Also in: 15.0.2, 12.0.20

Scope support for predefined Sql queries

Support for the concept of scope to control the distribution of Sql query results across user
sessions. It allows shared data to be processed in any user context, and prevents user-specific
data to be accessible to other user sessions.

Data Acquisition > Sql

Override Export folder and Template folder settings

It is now possible to override the default Export folder and Template folder settings in the
advanced properties of a data export item.

Data Export

Improved usability

In the Application Explorer, the list of Users and Profiles are no longer displayed in the tree-
view. Instead, the bottom-right panel is used to display the list of users associated to the
selected profile, or the list of profiles associated to the selected user.

General > User
management

More info in the group/profile association dialog

General > User

In the group/profile association dialog for Active Directory, more details are now displayed : management
®  Group description,
®  Members,
®  Current profile.

Default soft keypads (SPR #68560) HMI

Change of the default HMI option related to soft keypads for touch screen support. Upon
creation of a new project, the HMI option is now by default set to take advantage of the most
recent keypads.

Reference: PcVue 15 Release Notes
Copyright ©2026 - ARC Informatique. All rights reserved — LN {0 I3

Last update: April 2, 2026
Page 67/124



4
PcVue >

Confirmation dialog for saving/loading input files (SPR #68522, 68321)
With form controls, a confirmation message is now displayed before reloading or saving items
into a file (to avoid unintentional loss of the original file), or when leaving the configuration tab
without having saved the modifications.

HMI > Form controls
Also in: 15.0.2

Dynamic export folder (SPR #68582, 67953)

It is now possible to change the destination folder when exporting data from the Trend viewer.
In addition, a warning message is displayed if the destination folder is not accessible (folder
does not exist or insufficient permissions).

HMI > Trend viewer

Dynamic recipients list (SPR #68191)

It is now possible to use a text variable to define a recipients list for sending emails or SMS.

Miscellaneous

Instructions ALARMDISPLAY and LOGDISPLAY - New modes

SETCOLUMNWIDTH and GETCOLUMNWIDTH (SPR #69010)

2 new modes SETCOLUMNWIDTH and GETCOLUMNWIDTH have been added to the instructions
ALARMDISPLAY and LOGDISPLAY to get and set the size of a column.

Scripting > SCADA
Basic

Instruction EMAIL - Support for UNC path for attached files (SPR
#68852)

When using the EMAIL instruction, it is now possible to reference attachment files by using UNC
path (e.g. \\hostname\folder\file.txt).

Scripting > SCADA
Basic

Also in: 15.0.3, 12.0.22,
11.2.06099

Form controls instructions - New mode SAVE (SPR #67755)

A new mode SAVE is now available for the instructions COMBOBOX, LISTBOX, CHECKLIST,
OPTIONLIST, PIE and TREEVIEW. It enables saving the Content tab to a file.

Scripting > SCADA
Basic

User details for Active Directory

It is now possible to retrieve more user details from the Active Directory with the SCADA Basic
instruction SYSTEM mode USER:

®  Phone number,
®  Email address.

Scripting > SCADA
Basic

Counter mode for Send command action on Register variable

A new Counter mode is available for the Send command action for register variables. With this
mode, the register is incremented by 1 until the variable maximum value is reached and then
reset to 0.

SnapVue
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5. Performance

Improved CPU usage for the Application Architect Configuration
Improvement of the threading for configuration management of Templates and Instances. It Environments >

brings a better usage of CPU resources and fixes freezes at generation time with large projects. . . .

In addition, messages have been added to the generation logging to indicate the name of the Application Architect
instance being processed.

New audit time counters are also available.

Save/Load management of unselected instances Configuration

From now on, when unselecting instances, only the top-level instance unselected status is Environments >
recorded in the Tpl_Instances.xml file. Proceeding this way fasten the saving and loading of . . .
instances while reducing the file size. Application Architect
Storage of pending records during an overflow Historical data

During an overflow on an HDS archive unit, the Write period of pending records is set to its
minimal value to fasten the recording of the pending records and minimize the duration of the
overflow. When the pending records are cleared, the Write period is restored to its initial value.
This optimization does not prevent the occurrence of an overflow.
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6. Audit & diagnostic

New system variables for the Sql driver
New system variables are available for Sql queries and Sql variables:

®  System.SqlVariables.XOn
System.SqlVariables.LostTrans
System.Localhost.SqlVariables.Requests.FlowRegulation
System.Localhost.SqlVariables.Requests.SkippedByFlowRegulation
System.Localhost.SqlVariables.Requests.SkippedByOverlapping

Data Acquisition > Sql

New system variables for user details (SPR #16006)

New system variables are available to get the mobile phone number and email address of a
user:

System.<StationName>.User1l.MobilePhoneNumber
System.<StationName>.Userl.EmailAddress
System.<StationName>.User2.MobilePhoneNumber
System.<StationName>.User2.EmailAddress

General > User
management

New system variable for emergency purge

A new system variable is available for HDS databases to indicate that an emergency purge is in
progress:

®  System.Hds.<DatabaseName>.EmergencyPurge

Historical data
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7. Installation

Add-on for Commend ICX Add-ons and Tools
New Add-on to interface with Commend ICX intercom systems. Also in: 15.0.1
Reference: PcVue 15 Release Notes Last update: April 2, 2026

Copyright ©2026 - ARC Informatique. All rights reserved — LN {0 I3 Page 71/124



4
PcVue >

8.  Security

Password displayed with virtual keypad (SPR #68668) HMI

When unlocking a user with the virtual keypad, the password was displayed in the input dialog Also in: 15.0.2. 12.0.21
instead of '*' characters. '

Double Signature accepted with expired password HMI > Animations
The Security animation Double Signature accepted a signature even if the confirming user had
an expired password.

OpenSSL library updated Security
The OpenSSL library has been updated to version 1.1.1j (8-Dec-2020). Also in: 15.0.3
Reference: PcVue 15 Release Notes Last update: April 2, 2026
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9. Other fixes & enhancements

SPR #17376, 62504, 66523, 66764, 68014, 68180, 68324, 68348, 68408,
68648, 68687, 68723, 68729, 68752, 68805, 69075, 69076, 69104

SPR #68465, 68651 Also in: 15.0.2

SPR #68534 Also in: 15.0.1

SPR #68450 Also in: 15.0.1, 12.0.20
SPR #68423, 68424 Also in: 12.0.23
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17. Initial Release 15.0.0 (15.0.00902)

1. New features

MQTT pub/sub driver (SPR #66294)

A new Add-on that implements the MQTT standard and can be used as an MQTT subscriber and
as an MQTT publisher:
®  The MQTT subscriber facet allows you to collect data from MQTT-enabled devices and
take advantage of PcVue for alarming, trending, logging and HMI,

®  The MQTT publisher facet offers you the possibility to distribute information with the
many additional metadata and qualifiers not readily available at the sensor level.

Communication

interfaces > MQTT Pub-

Sub

Modeling of Geolocation configuration items

Definition of Geolocation-related configuration items - Zones, Actions and Geo-tags - in
templates and instances.

Configuration
Environments >
Application Architect

Modeling of File Reference objects
Definition of File Reference configuration items in templates and instances.

Configuration
Environments >
Application Architect

Display of Equipment data acquisition driver status (SPR #66944)

Display of status and error codes of networks, nodes and frames.

Configuration
Environments >
Application Explorer

Display of Networking status

Display of networking connection status and license-related information.

New commands are also available on stations and nodes to control connections when advanced
diagnostics are necessary. These commands are equivalent to some of the modes of the LAN
instruction in SCADA Basic scripting.

Configuration
Environments >
Application Explorer

Ping command dialog box

A new dialog box is available for the Ping command. It replaces the command prompt and is
available for communication objects based on an IP interface (DNP3, SNMP, IEC 61850 ...).

Configuration
Environments >
Application Explorer

New BACnet Helper for Commands
A new BACnet Helper is available for Command objects.

Data Acquisition >
BACnet Client

Support for static binding (SPR #65825)

It is now possible to configure static binding for BACnet devices by configuring their IP address
instead of the BACnet MAC address in the configuration.

This new feature makes it easier to address network segmentation requirements without the
need to set-up the BBMD feature or a 3rd party BBMD component.

Data Acquisition >
BACnet Client

New Panasonic Mewtocol-7 driver

A data acquisition driver for Panasonic Mewtocol-7 devices is now available.
It supports FP7-Series PLCs equipped with an Ethernet port.

Data Acquisition >
Other built-in drivers

New configuration import feature

It is now possible to import a previously exported configuration, which facilitates upgrading a
deployment made with an earlier version as soon as the deployment configuration was backed-
up using the Export feature of the WDC.

Deployment tools >
Web Deployment
Console

Client-side settings (SPR #66696)

Client-side settings for Web & Mobile apps can now be pre-defined at deployment time and
enforced by the server, including the Remember me setting.

Deployment tools >
Web Deployment
Console
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Instant Messaging General
A built-in Instant Messaging system you can deploy on your segmented industrial network - No
dependency to any third-party service requiring Internet access. It offers users of the desktop
application, FrontVue and the SnapVue mobile app the ability to chat together. Users keep
themselves in the loop for better effectiveness and team performances.
Main features:
® Chat,
®  Exchange text and voice messages,

®  Send and receive images and videos.

Expressions - New functions General
New functions are available in the expression engine. Depending on their usage, they can be
used with several features such as expression on variables, MQTT variable mapping, Sql variable
mapping, Application Architect...
The list of added functions includes:
®  Json fragment parsing,
®  Base64 string and hexadecimal value conversions,
®  Timestamp value conversions,
[ ]
Please refer to the online help for more information.

Geolocation & Micro-Geolocation General
Based on the configuration of zones, actions and geo-tags, this new module provides users with

patented location-based and proximity-aware services, both indoor and outdoor. Depending on

the type of system you monitor & control, zones can be a geographical or logical breakdown of

your installations, a real-world location such as a remote site, or a piece of equipment in a

factory.

The following types of geo-tags are supported:

®  Geolocation - GPS® for location-based services,

®  Micro-Geolocation - NFC tags, QR codes®, Bluetooth® beacons and Wi-Fi® access
points for proximity-aware services.
Patent number: US9819509B2

Sql data acquisition driver General
Built on top of the Sql connection management introduced with version 12, the Sql data

acquisition driver allows you to map variables onto results of predefined Sql queries. It is

designed to make it easy to interface with Enterprise systems. Use cases include retrieving data

from an ERP, CMMS, MES, Metering systems...

Variables can be updated cyclically or on event, and no scripting is required.

Preview for testing - Smart Bot General

Designed as a plug-in on the Instant Messaging infrastructure, the Smart Bot helps users follow
operational and maintenance procedures.

This feature is in Preview for testing. You must run the installation package in mode Custom to
install it. Please contact us if interested.

Preview for testing - Notification publisher General
A module designed to support the Push Notification technology.

This feature is in Preview for testing. You must run the installation package in mode Custom to

install it. Please contact us if interested.

SnapVue Mobile App General

SnapVue is designed for context-based monitoring & control of nearby assets. It takes
advantage of the Geolocation and Instant Messaging services provided by your server to present
relevant information to mobile users:

®  Connect to and access data from multiple servers,

® |nformation, alarms, commands and set-points are displayed according to the user
context: Location, proximity and permissions

Logged events and trends,

Access to external resources such as documents and web pages,
Data filtering based on user profile,

Built-in Instant Messaging,

User tracking.

License protection based on software protection key General > Licensing

In addition to USB hardware dongles, license protection based on a software key is now
available.
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General > Version
management

New status PREREF (SPR #65597)

A new status PREREF is available. It takes place between DEV and REF phases in the lifecycle of a
project or libraries. It is designed to identify a version under validation tests before being
deployed in production.

In addition, the new command line argument -preref can be used to start the PREREF version.

General > Version
management

Version numbering scheme with 3 digits (SPR #64869)

Project & Lib versions are now defined with 3 figures to accommodate a lifecycle policy
including 3 stages: Major versions, minor versions and patch.

Custom context menu for Alarm and Log viewers HMI

A new context menu is available. It is highly configurable at design-time, and as the toolbar, it
offers run time users most of the useful commands in a single place:

®  Generic commands: Print...,

®  Commands on alarms: Acknowledgment, Masking...,

®  Filter changes,

®  Commands useful in the context such as actions associated to the selected alarm.

Instance selector HMI

New selector to insert symbols in mimics by selecting instances designed with the Application
Architect rather than searching through libraries of symbols and setting the branch manually.

Selection of active Tab at mimic opening (SPR #63066, 48273) HMI

It is now possible to select with the animation Link.Open which tab is to be active when opening
a mimic configured with multiple tabs.

Selection of mimic template at mimic opening (SPR #63360) HMI

It is now possible to select the mimic template when opening a mimic with the animation
Link.Open.
When a mimic template is specified, the default template is ignored.

Tree view-control - Support for icon customization HMI > Form controls

To support this feature, a selector is also available so that you can pre-define the list of useful
icons to be used in the project, as you do with the color palette.

Alongside with the new Icon selector, new modes for the TREEVIEW instruction have been
added:

® SETNODEICON,
®  SETCHILDICON,
®  SETROOTICON.

Pie control - Support for real time data HMI > Pie control

The Pie control can now be used to display the real time value of variables with no scripting
required.

The evolution comes with several new SCADA Basic modes for instruction PIE, and new VBA
methods to dynamically configure these new options.

Trend viewer - Support for 100 curves
The trend viewer now supports up to 100 curves simultaneously.

HMI > Trend viewer

Instruction INSTANTMESSAGING

The new instruction INSTANTMESSAGING is available to support scripting of the Instant
Messaging feature. Refer to the online help for further details.

Scripting > SCADA
Basic

Instruction SYSTEM - New mode LOADCOLORS (SPR #68119)

A new mode LOADCOLORS is available for the instruction SYSTEM. It enables loading a color
palette from a file, which can be used for day/night color management or mitigate a user's
color-blindness.
Syntax: System("LoadColors", FileName);
Where FileName corresponds to the path of the file to load:

®  An absolute path,

® A path relative to the TP directory,

® Apath to ashared library starting with /LibName/.

Scripting > SCADA
Basic
Also in: 11.2.06097

Instruction GEOLOCATION

The new instruction GEOLOCATION is available to support scripting of the Geolocation & Micro-

Geolocation features. Please refer to the online help for further details.

Scripting > SCADA
Basic
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Logging & Tracing - Syslog support

For activity monitoring purpose, this interface allows you to send selected events to IT log
aggregators. Designed to fulfill the most challenging security requirements, it supports the RFC
5424 and RFC 3164, in addition to RFC 5426 (UDP), RFC 6587 (TCP) and RFC 5425 (TLS).
Improvements of logged events, in particular to better trace user account administration and
project/lib version central management.

Security

Support for Security animations (SPR #67095, 67094)

WebVue now supports the security animations Signature Confirmation and Double Signature.

Web Server Extensions
> WebVue

Support for mimic tabs (SPR #66445)

Mimic tabs are now supported.

Web Server Extensions
> WebVue

Upgrade Re-designed WebVue client

The web client, which was originally designed as a Java applet introduced to the market in the
late 90’s, now takes full advantage of the latest web technologies. WebVue provides a graphic
interface to monitor and control your process from a web browser on any device. WebVue
combines user experience, security and ease of deployment.

New features and enhancements include:

No installation required on the web client side,

Cross-browser support, including desktop and mobile web browsers,
Secured communication over HTTPS,

Support for network segmentation,

Multi-tab support with a single license.

The technology stack includes HTML5, SVG and REST/JSON web services over web sockets and
OAuth.

The SCADA Basic instruction named WEBVUE have been reworked to fit the new web client
design.

WebVue deployment now requires the configuration of a Web & Mobile back end (using the
Application Explorer), and the use of the Web Deployment Console on the Web Server.
Some configuration settings are deprecated and no longer used. As part of the migration
process, we recommend you to check settings related to the Web Server Extensions to make
sure they fit your needs.

Web Server Extensions
> WebVue
Also in: 12.0.7

Support for included mimics and popups (SPR #66242, 66024)

Included mimics and popups are now supported in WebVue.
It was a known issue since 12.0.7 (Initial Release).

Web Server Extensions
> WebVue
Also in: 12.0.11

Support of iPad OS 13
WebVue now supports the Safari web browser shipped with iPad OS 13.

Web Server Extensions
> WebVue
Also in: 12.0.11

Support for Sofrel timetables

The WebScheduler now supports Sofrel timetables.

WebScheduler
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2. Fixes

Ethernet/IP Add-on - Handling of large arrays (SPR #68352) Add-ons and Tools

The Ethernet/IP add-on did not handle large arrays of DWord correctly. If the array was larger Also in: 12.0.19
than 50 items, variables were always set to status NS (invalid).

BACnet Server - Several fixes and enhancements (SPR #66981, 66980, Add-ons and Tools
66132)

The list of fixes & enhancements includes:

®  The setting DeviceCommunicationControl was not correctly taken into account (was
always considered as Disabled),

®  Some server properties were not correctly exposed (Object Name, Vendor Name,
Model Name, Vendor Id, Firmware Revision),

®  Support for non-latin characters in variables names.

Library converter - Fatal error when converting a large library (SPR Add-ons and Tools
#66988)

A fatal error could occur when converting a library to binary or ASCIl format due to a GDI object

leak.

DBImport - Fatal error when DBImport.log locked (SPR #67177) Add-ons and Tools

A fatal error of the DBImport tool occurred when closing it if the log file DBImport.log wasused  Alsg in: 11.2.06092
and locked by another process. '

11.1.06124
EtherNet/IP - Fatal error at startup (SPR #66902) Add-ons and Tools
Under some circumstances, a fatal error could occur at startup when the add-on traces and
logging were activated while a variable had an incorrect format declaration (i.e.: UINT instead of
REAL).
MultiTech LoRa Gateway - Saved variable value lost (SPR #66778) Add-ons and Tools
The value of a variable configured as Saved was not correctly stored at project shutdown, thus it
was not correctly reloaded at project startup.
Incorrect threshold alarms at startup (SPR #67429) Alarms
Under some circumstances, alarms based on a threshold were incorrectly set with a good
quality at project startup even if the underlying 1/0 variable was invalid if they were configured
as Saved .
Error messages 15838 and 15810 at project startup (SPR #66927) Alarms
Messages 15838 and 15810 were incorrectly displayed in the event viewer at project startup
when the variable associated to an alarm synthesis was neither produced nor consumed by the
station.
Unable to mask an alarm (SPR #66235) Alarms
In a single-active association of servers, it was not possible to mask an alarm from the passive Also in: 11.2.06088,
server when the alarm was the result of an expression. 11.1.06123

Incorrect value and boundaries for System.Localhost.Session.Type (SPR  Audit
#67957) Also in: 12.0.16

The variable System.Localhost.Session.Type had an incorrect low boundary, 0 instead of -1, and
was wrongly set to -1 where the value should have been 104 when a client was connected using
the Web Services Toolkit.

The same fix applies to the values returned by the SCADA Basic instruction SESSION mode
GETTYPE.

System variables related to the user not refreshed (SPR #65879) Audit

Some system variables associated to User authentication were not correctly refreshed with
networking configuration:

®  SYSTEM.LOCALHOST.USER.NumLocked,
®  SYSTEM.LOCALHOST.USER.Rejected,

®  SYSTEM.LOCALHOST.USER.TryLogin.
The corresponding variables in the branch SYSTEM.<STATION_NAME> were properly refreshed.
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Incorrect OPC values returned (SPR #66161) Communication

Under some circumstances, OPC items could not be read correctly by OPC clients, in particular interfaces > OPC Server
when requesting a group containing invalid or unknown items.

Also in: 12.0.8,
11.2.06083
SNMP trap not sent (SPR #67679) Communication
When configuring multiple traps with the same generic format, only the last trap was sent. interfaces > SNMIP
Agent
Also in: 12.0.16
Support for OID and Value in Generic Trap (SPR #67126) Communication
Generic traps were not supporting OID and Value parameters properly. They now behaves as interfaces > SNMIP
described in the online help.
Agent
Also in: 12.0.16,
11.2.06092
HMI variables not deleted after synchronization (SPR #68085) Configuration

HM I variables were not correctly deleted when synchronizing an import from a Smart Generator Environments
or the Application Architect.

Incorrect behavior of the auto-completion (SPR #68178) Configuration
Under some circumstances, the auto-completion did not work properly in the expressions Environments
editor.

Expressions - Syntax highlighting and auto-completion (SPR #67795) Configuration

Fixes & improvements to syntax highlighting and auto-completion in the Expression Editor for Environments
the following operators and functions:

®  Operator POW,

®  Function POWER,

®  Function LOG,

®  Function ROUND,

®  Function MIN/MAX,

®  Function EXCELVTEXTJOIN,

®  Function EXCELHTEXTJOIN.
Import failed due to expressions (SPR #67558, 67545, 67276, 66885) Configuration
When importing expressions via a Smart Generator or the Application Architect, expressions Environments
configured with a result variable that was not produced locally were only partly loaded and did .
not behave as expected at runtime. Also in: 12.0.16

Fatal error when importing description with line breaks (SPR #66670) Configuration

A fatal error occurred when importing a configuration item if its description contained a line Environments
break (\n).

Fatal error when displaying libraries of mimics or symbols thumbnails Configuration
(SPR #66499, 66480) Environments
A fatal error of the Library Explorer, the Application Explorer or the Application Architect Also in: 12.0.11,
occurred when changing the displayed library of mimics and/or symbols if in thumbnails display

mode. 11.2.06088
Missing warning if PcVue is not running (SPR #66092) Configuration
No warning was displayed when launching a configuration tool (including the Application Environments
Explorer, Application Architect and Smart Generators) while the PcVue main process (Sv32.exe) -

was not running. Also in: 12.0.10
It was a regression affecting version 12.0 Initial and Maintenance Releases.

Primary trends not correctly generated (SPR #66527) Configuration
The property Primary of Trend items was not correctly managed by the Application Architect Environments >

and could lead to generation errors.

Application Architect
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Expressions generated without a server list (SPR #68086, 66435)

Expressions were created without their server list set when the result variable did not belong to
a producer list of the station where the import was done.

Configuration
Environments >
Application Architect

Error when loading instances (SPR #67956)

An error could occur when loading the Application Architect files after having deselected an
embedded template from an instance if the embedded template contained variables with ".".

Configuration
Environments >
Application Architect

Error message on Event filter definition (SPR #67626)

Error messages were displayed when the property Event filter of a Log list was defined at the
time of instantiation.

Configuration
Environments >
Application Architect

Fatal error when generating instances with File items (SPR #67162)

Under some circumstances, a fatal error could occur at generation time when an instance
contained multiple File items of type Predefined format.

Configuration
Environments >
Application Architect

Incorrect property values for IEC104 Sectors (SPR #67750)

The default value for the properties Group Interrogation and Counter Interrogation of IEC 104
sectors were incorrect and not generated.

Configuration
Environments >
Application Architect

Symbol position not correctly reset (SPR #67393)

The reset of a symbol's position in a template was not correctly managed and ignored by the
synchronization.

Configuration
Environments >
Application Architect

Fatal error when editing a property defined by expression (SPR #67450)
Under some circumstances, a fatal error could occur when opening the expression editor for
defining a property. The issue occurred when the operating system was set for the Hebrew
character set. Other non-English languages were potentially impacted also (reproduced with
French charset).

Configuration
Environments >
Application Architect
Also in: 12.0.16

Empty items in Validation rules properties of Parameters (SPR #67627)

Some empty items were not properly displayed in the list of properties in the configuration of
Validation rule for Parameters.

Configuration
Environments >
Application Architect
Also in: 11.2.06094

OPC Group creation incorrectly prompted (SPR #67097)

Changing a variable source from OPC to another source prompted the dialog box for OPC group
creation.

Configuration
Environments >
Application Architect

Could not customize instances with additional behavior items (SPR
#66945)

Under some circumstances, trying to add additional behaviors on variables directly within an
instance could fail and return an Unknown error. Affected behavior items were:

Alarm Acknowledgment transmission,
Alarm Window/Program action,
Alarm Masking,

Thresholds,

Chrono,

Counter.

Configuration
Environments >
Application Architect

Fatal error when generating BACnet variables

Under some circumstances, a fatal error could occur when generating variables mapped to a
device that was already active and monitored.

Configuration
Environments >
Application Architect

Global parameters on Threshold bit variable (SPR #65360)

Global parameters were not correctly managed on Threshold bit variable items

Configuration
Environments >
Application Architect
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Unable to create expression on HMI variable (SPR #66181)

It was not possible to create an Expression on variable item on an HMI variable.

Configuration
Environments >
Application Architect

Unable to load shared and local libraries having the same name (SPR
#65960)

The Application Architect could not load correctly when a shared and a local library had the
same name. They are now correctly managed and loaded.

Configuration
Environments >
Application Architect

Unable to paste multiple File Iltems (SPR #65967)

It was not possible use the multi-paste feature with File Items. The error "The input value is too
long. The maximum length is -3 characters." was raised.

Configuration
Environments >
Application Architect

Mimic design screen resolution no longer forced to 1440*900 (SPR
#66529)

Mimic generated with the Application Architect were always configured with the resolution
1440*900 for the property Design screen resolution. They are now using the active resolution at
the time of the generation.

Configuration
Environments >
Application Architect
Also in: 12.0.19

Upgrade Alarm synthesis default property value (SPR #67799, 66701)

The default value of the property Take the applied population into account of Alarm Syntheses
items is False since version 11.2 Release.

This new default value was mistakenly not applied to Alarm syntheses created with the
Application Architect. It is now applied.

This change may introduce a behavior change in the way alarm syntheses are calculated in some
projects. Please refer to the Known issues section for more information.

Configuration
Environments >
Application Architect
Also in: 12.0.16,
11.2.06094

Fatal error in the Population query designer (SPR #68278)

A fatal error occurred when canceling the addition of a new filter if the Operator field was
empty.

Configuration
Environments >
Application Explorer

Event name not displayed after creation (SPR #67343)

Under some circumstances, when creating an Event from the Variable pane, its name was not
correctly displayed and/or its icon was incorrect in the associated behavior pane.

Configuration
Environments >
Application Explorer

Long time for opening association configuration dialog box (SPR #67019)

Under some circumstances, with a large networking configuration, the association dialog box
could take several minutes to open.

Configuration
Environments >
Application Explorer
Also in: 11.2.06097

Application Explorer frozen after IEC 61850 communication restart (SPR
#67961)

Under some circumstances, the Application Explorer could freeze after restarting an IEC 61850
network when the trial period was expired.

Configuration
Environments >
Application Explorer

Fatal error when configuring a license renter station (SPR #67689,
67090)

A fatal error of the Application Explorer occurred when modifying the configuration of a station
to make it a license renter. The issue occurred if no license owner station was configured, or if
the owner station had been previously deleted.

Configuration
Environments >
Application Explorer
Also in: 12.0.19

HMI variables not deleted (SPR #67432)

HMI variables under a branch were not correctly deleted when the branch was deleted.

Configuration
Environments >
Application Explorer

Tree-views blinking (SPR #66643)

General display of the Application Explorer slowed down and blinked when the project
contained over a hundred communication items such as IEC 104, IEC 61850, DNP3 or OPC
configuration.

Configuration
Environments >
Application Explorer
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Unable to create thresholds (SPR #66804)

Under some circumstances, it was not possible to create thresholds on a register variable if its
minimum value was different from 0.

Configuration
Environments >
Application Explorer

Fatal error upon copy of a variable or trend (SPR #66986)

Under some circumstances, a fatal error could occur when copying a variable or a trend.

Configuration
Environments >
Application Explorer
Also in: 12.0.16,
11.2.06094

No frame address displayed (SPR #67049)

Under some circumstances, no address was displayed in the Source tab of a variable when it
was linked to an Equipment driver and if the frame type did not match the variable type. For
instance, a bit variable linked to Word frame.

Configuration
Environments >
Application Explorer

BACnet Helper - Start and stop time inverted for Logs

Start and Stop times were inverted in the BACnet Helper for Logs.

Configuration
Environments >
Application Explorer

Could not configure Servers items (SPR #66109)

The Communication.Servers entry was not available when the product was installed without the
Web back end feature.

Configuration
Environments >
Application Explorer

Dialog boxes not visible (SPR #63006, 17193)

The position of configuration dialog boxes is now reset automatically when they are outside of
the screen area.

Such a situation can occur when changing operating system display settings, for example when
switching from 2 screens to 1.

Configuration
Environments >
Application Explorer

Fatal error on IEC 104 variable modification (SPR #66372)

A fatal error occurred when modifying a variable linked to a previously deleted IEC 104 device.

Configuration
Environments >
Application Explorer

Inconsistent thresholds configuration (SPR #65279)
Several fixes to the handling of thresholds configuration:

®  Values not always refreshed,

®  First threshold randomly deleted,

®  Value sequencing not checked.

Configuration
Environments >
Application Explorer

BACnet helpers frozen

Under some circumstances, BACnet helpers and the Application Explorer could freeze after
having selected a BACnet variable which object-type is defined by its numeric Id.

Configuration
Environments >
Application Explorer
Also in: 12.0.9,
11.2.06078

Fatal error when creating a variable (SPR #66630)
Under some circumstances, a fatal error could occur when creating a variable. The issue

occurred when a branch segment of the variable was used in another branch previously deleted
(e.g. B1.B2 and B2.B3).

Configuration
Environments >
Application Explorer
Also in: 12.0.11

SG-SAIA - Fatal error at file opening (SPR #66058)

A fatal error occurred when opening a file comprising an array with relative indexes.

Configuration
Environments > Smart
Generators

Reference: PcVue 15 Release Notes
Copyright ©2026 - ARC Informatique. All rights reserved — LN {0 I3

Last update: April 2, 2026
Page 82/124



4
PcVue >

Smart Generator for Wago - Incorrect mapping (SPR #66348, 65717)

The last variable of a frame was incorrectly mapped if the last available index in the frame did
not fit the size of the data point to map.

Configuration

Environments > Smart

The issue occurred in particular when the last data point to map was of type REAL. Generators
Also in: 12.0.10,
11.2.06087

SG-Unity - Fatal error when opening the synchronization Ul (SPR Configuration

#66610)

A fatal error occurred when opening the synchronization Ul of a SG Unity import.

Environments > Smart

Generators
Also in: 11.2.06089

Unable to execute SET/SENDLIST

Under some circumstances, write commands could not be correctly acknowledged when sent
before a server switchover. The issue occurred in particular when using the SCADA Basic
SET/SENDLIST instructions with protocols managing asynchronous writings such as OPC or
BACnet. The result variable associated to the SENDLIST instruction remained locked after the
switchover, preventing the execution other SET/SENDLIST calls with the same result variable.

Data Acquisition
Also in: 11.2.06091

Inconsistent variables mapping after a change of the device identifier

The mapping of variables was not updated when the identifier of their associated device was
changed at the device configuration level.

Data Acquisition >
BACnet Client

Fatal error at startup (SPR #68005)

Under some circumstances, a fatal error could occur at network startup on projects with a large
number of BACnet devices among which some are disconnected.

Data Acquisition >
BACnet Client
Also in: 12.0.17

Several fixes & enhancements related to BBMD configuration (SPR
#67042, 66921, 65407, 65355)
The list of fixes and enhancements includes:

® |tis now possible to select a network interface when multiple interfaces are
configured,

It is now possible to select a single station when no server association is configured,
It is now possible to edit an existing BBMD list,

Some missing tooltips added,

The name of a BBMD list was wrongly accepting the space character.

Data Acquisition >
BACnet Client

Fatal error after communication frozen

Under some circumstances, when an on-demand read request for the property "all" of an
unknown object failed, the BACnet communication could freeze and lead to a fatal error.

Data Acquisition >
BACnet Client

Incorrect COV lifetime

The configured COV lifetime was not correctly applied and appeared to be 1.5 time smaller than
defined.

Data Acquisition >
BACnet Client

Number of items in BitString and OctetString values

It is now possible to get the number of items in a BitString or OctetString by using the advanced
property Fields with syntax BitString(index) or OctetString(index) with the index 0. Indexes
larger than 0 are used to extract the value at the corresponding index in the BitString or
OctetString.

Data Acquisition >
BACnet Client

Trend Log and Trend Log Multiple not working

Trend Log and Trend Log Multiple objects were not working properly when they were mapped
to more than one variable.

Data Acquisition >
BACnet Client

Unable to read fault-high-limit property (SPR #66865)
It was not possible to read a property of type fault-high-limit.

Data Acquisition >
BACnet Client

Unavailable properties displayed in mapping configuration (SPR #62790,
62280)

When doing online configuration and mapping, some unavailable or not-supported properties

were incorrectly displayed, in particular those related to event-enrolment objects and properties

associated to notification-class objects.

Data Acquisition >
BACnet Client
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Memory leak with Trend Logs (SPR #66205)

A significant memory leak occurred when retrieving Trend Logs.

Data Acquisition >
BACnet Client
Also in: 12.0.9,
11.2.06084

Code page displayed in string values (SPR #66842)

When the code page was different from UTF-8, string values were prefixed with the applied
code page (UCS-2, DBCS...).

Data Acquisition >
BACnet Client
Also in: 12.0.12

Variable not correctly refreshed after Priority reset (SPR #66618)

When resetting the Priority property with the SCADA Basic instruction BACNET, mode
RESET_PRIORITY, the properties present-value and priority-array were not refreshed even if the
option synchronization by read after writing was activated at the device level.

Data Acquisition >
BACnet Client
Also in: 11.2.06090

Writing instruction sent multiple times

Under some circumstances, a single writing instruction could be sent multiple times due to an
incorrect buffer processing.

Data Acquisition >
BACnet Client
Also in: 11.2.06090

Variable properties overridden after EDE mapping (SPR #65426)

When variable mapping was done at the network level with an EDE file, some previously defined
variable's properties such as Description were overridden. This issue did not occur when the
mapping was done directly at the variable level.

Data Acquisition >
BACnet Client
Also in: 11.2.06076

Buffered Al and AO values not recorded (SPR #66941, 66834, 66297)

The buffered values for Al and AO objects of a DNP3 device were not correctly recorded in the
archives when they were associated to trends. These values are read when connecting to the
device at startup or upon reconnection.

Data Acquisition >
DNP3 Client
Also in: 12.0.16

Time-out on variable initialization (SPR #66803)
Under some circumstances, a time-out could occur when initializing DNP3 variables.

Data Acquisition >
DNP3 Client
Also in: 12.0.12

Command not sent

Under some circumstances, DNP3 commands requests were not send due to the absence of an
ACK message associated to a previous CROB or AOB command request.

Data Acquisition >
DNP3 Client
Also in: 11.2.06091

DNP3 redundancy - Communication frozen (SPR #67034)

In an architecture with a single active server for DNP3 acquisition, devices remained
disconnected on the passive server after a disconnection from the active server.

As a consequence, the data acquisition appeared to be frozen and variables were no longer
refreshed.

Data Acquisition >
DNP3 Client
Also in: 11.2.06091

Timestamp on requests

The Timestamp property of the sector (UTC or local) was not taken into account when sending
Clock synch, Test and Time-tagged commands.

Data Acquisition > IEC

60870-5 Client

Several fixes in connection handling

The sequence of commands upon connection has been improved to limit network traffic and
initialization burden (Clock synch, Global Interrogation, Counter Interrogation...).

Data Acquisition > IEC

60870-5 Client
Also in: 11.2.06081

Error message display on Clock synch (SPR #65772, 65754)

An error message was repetitively displayed after a Clock synch of a remote device.

Data Acquisition > IEC

60870-5 Client
Also in: 11.2.06080

Fatal error on exit

Under some circumstances, a fatal error could occur when closing the application with an active
IEC 104 configuration.

Data Acquisition > IEC

60870-5 Client
Also in: 11.2.06080
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PcVue >

Unable to start BRCB on a newly active server after switchover (SPR
#68309)

In a configuration containing several IEC 61850 networks managed by the same server
association, the server switchover was not correctly processed for all produced networks. Some
networks remained active on the passive server, meaning that URCB/BRCB were not stopped,
and thus forbade the newly active server to start them.

Data Acquisition > IEC
61850 Client
Also in: 12.0.19

Fatal error when browsing (SPR #67970)

A fatal error could occur when browsing a directory containing a large number of files and
folders.

Data Acquisition > IEC
61850 Client

Device never reconnected (SPR #67394)

Under some circumstances, a connection to a device could be lost and never reconnected. The
issue occurred when the connection ended with error code Connection_Closed. The code
Connection_Lost was correctly handled.

Data Acquisition > IEC
61850 Client

Fatal error with rejected File transfer (SPR #66755)

A fatal error occurred when a device returned the response Error_Reject.

Data Acquisition > IEC
61850 Client

Timestamp of Select and Operate commands (SPR #59139)

Timestamps sent in Select and Operate commands were different and corresponding to the
exact time when the message was sent, while they had to be identical and corresponding to the
time of the initial message.

Data Acquisition > IEC
61850 Client

Unable to send command
It was not possible to send a command to objects having an operTm defined.

Data Acquisition > IEC
61850 Client

Variables remained NS COM after communication restart

Under some circumstances, after stopping and restarting the communication, some variables
linked to a data group could remained in status NS COM.

Data Acquisition > IEC
61850 Client

Reports not processed in case of large datasets (SPR #66118)

Reports were not handled properly when associated to a dataset with more than 150 members.
The fix is validated with up to 1000 dataset members associated to a Report Control Block.

Data Acquisition > IEC
61850 Client
Also in: 12.0.8

Reconnection issues after a server switchover (SPR #66170)

Under some circumstances, after a data acquisition server switchover, some devices were not
correctly reconnected. The issue only occurred when the newly active server belonged to
multiple associations.

Data Acquisition > IEC
61850 Client
Also in: 11.2.06083

Data acquisition frozen after writing a Data Attribute (SPR #66114)

Under some circumstances, the IEC 61850 driver could freeze after writing on an IEC 61850 Data
Attribute.

Data Acquisition > IEC
61850 Client
Also in: 11.2.06082

Write commands on LonWorks variables (SPR #66373)

Sending a write command on a LonWorks variable that was in status Not connected caused a
fatal error.

Data Acquisition > LNS
Also in: 11.2.06088

OPC-XML - Data types handling caused a fatal error (SPR #67622)

Under some circumstances, a fatal error could occur when processing data received from an
OPC-XML server. The issue only occurred for data of type long, uint, ushort, ulong, if they were
not already converted on the OPC server side.

Data Acquisition > OPC
Client
Also in: 12.0.19

OPC-XML - Fatal error with a disconnected server (SPR #65755)

A fatal error occurred when a GetStatus() request was sent to a disconnected server.

Data Acquisition > OPC
Client
Also in: 12.0.19

Incorrect quality if range dependent on other variables (SPR #67969)
Under some circumstance, the quality of register variables could be incorrect. The issue only
occurred with OPC variables, when the variable range was defined by dependency to other
variables.

Data Acquisition > OPC
Client
Also in: 12.0.19
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PcVue >

Invalid OPC variables after switchover (SPR #66837, 66655)

Under some circumstances, variables mapped to OPC items could remain invalid after a data
acquisition server switchover if errors occurred during the switchover.
The issue affected:

®  Versions 11.2.06781 to 11.2.06793,
® Allreleases of 12.0 up to 12.0.14.

Data Acquisition > OPC
Client

Also in: 12.0.14,
11.2.06092

Fatal error with multiple OPC write command timeouts (SPR #66992)
Under some circumstances, a fatal error could occur when sending too many OPC write
commands completing in time-out. Now the server is considered as offline and the
communication interrupted when 1000 or more time-out errors occur within 500 ms.

Data Acquisition > OPC
Client
Also in: 11.2.06092

Impossible to restore communication despite time-out errors (SPR
#673881)

Under some circumstances, the communication with some TCP/IP devices could not be restored

despite multiple time-out errors. The issue was due to the PLC not responding to requests while

the underlying socket was still in an Ok state.

From now on, after a period of 180 sec in time-out error, it is possible to force a close of the
socket, which is then re-opened at the next retry.

To activate this behavior, the following keys must be added in the file C\EqtConf.ini:
[TCPIP]

EnableCloseOnConsecutiveTimeOut = 1

MaxConsecutiveTimeOutInSec = 180

Data Acquisition >
Other built-in drivers
Also in: 12.0.17,
11.2.06097

Driver IpOpenWebNet - Support for extension modules (SPR #67702)
The SCS extension modules were incorrectly updated when a new measurement was received
for a single Lighting Point.

Data Acquisition >
Other built-in drivers
Also in: 12.0.16

Fatal error on frame modification (SPR #66627)

A fatal error could occur when modifying a frame while the communication was starting.

Data Acquisition >
Other built-in drivers
Also in: 12.0.15

Driver SAIA - Equipment not correctly initialized (SPR #67443)

At startup, some devices were not correctly initialized and connection could not be established.
Startup of devices is now serialized to enforce a proper initialization.

Data Acquisition >
Other built-in drivers
Also in: 12.0.15,
11.2.06093

Fatal error on exit (SPR #66105)

A fatal error occurred upon exit when using frames of type Info or Command not set to the
maximum size.

Data Acquisition >
Other built-in drivers
Also in: 12.0.19,
11.2.06088

Fatal error with redundant servers (SPR #67440)

Under some circumstances, a fatal error could occur due to trap handling in redundant server
set-up.

Data Acquisition >
SNMP Manager
Also in: 12.0.15,
11.2.06093

Host name resolved even when communication not started (SPR
#66228)

Resolution of the hostname of an SNMP device was executed even when the device was not
started. Hostname resolution is now executed only when data acquisition is started for the
device.

Data Acquisition >
SNMP Manager
Also in: 12.0.19,
11.2.06084

Empty line in exported files (SPR #67469)

An empty line was inserted in exported files when the option Display columns header was
activated.

Data Export

Data in the future incorrectly populated (SPR #66731, 66303)

When exporting sampled data with a future end date, the data in the future were populated
with the last known value instead of being left empty.

Data Export
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PcVue >

Inconsistent sampled data exported on DST (SPR #64859)

Sampled data were not correctly exported when the export period contained a Daylight Saving
Time.

Data Export

Data export copy/paste did not work (SPR #66027)
An exported file was empty when generated for a data export item that was the result of a
copy/paste.

Data Export

Fatal error when exporting data with missing dates boundary (SPR
#66747)

A fatal error occurred when an export was triggered and either the starting or ending date was
not set in the configuration or the SCADA Basic instruction call.

Data Export

Newly created web site not visible (SPR #67258)

Under some circumstances, newly created web sites were not displayed in the WDC.

Deployment tools >
Web Deployment
Console

Web site name syntax control (SPR #64740)

A syntax control has been added to the WDC when entering a web site name to avoid illegal
characters.

Deployment tools >
Web Deployment
Console

Web component not correctly deployed on older operating systems (SPR
#67994)

The Web components were not correctly deployed by the WDC on operating systems using 1S
7.5 or lower, which include Windows 7, Windows Server 2008 and Windows Server 2008 R2.
This was due to the use of the applicationinitialization element in the IIS configuration (only
supported from IIS 8.0 onward).

Deployment tools >
Web Deployment
Console

Also in: 12.0.17

Binding with IP address (SPR #67292)

It was not possible to create a binding using an IP address as the hostname.

Deployment tools >
Web Deployment
Console

Expired certificate (SPR #67259)

When checking certificate validity, an incorrect message was displayed when it was expired.

Deployment tools >
Web Deployment
Console

Back end endpoint still active (SPR #66220)

When a back end endpoint was removed from the configuration, it was still active for a web site
until a new one was re-assigned.

Deployment tools >
Web Deployment
Console

Configured web site title not taken into account (SPR #66547)

The title configured for the web site in the WDC was not taken into account. It was always
deployed with the title 'SV Website' in IIS.

Deployment tools >
Web Deployment
Console

Fatal error at startup (SPR #66066, 66017)

A fatal error occurred at startup of the Web Deployment Console if the computer name had
been changed at the operating system level.

This was a known issue since 12.0.7 (Initial Release).

Deployment tools >
Web Deployment
Console

IIS prerequisites verifications (SPR #64742)

The WDC now checks if all the IIS prerequisites are installed before allowing the user to deploy
components.

Deployment tools >
Web Deployment
Console

Issue when changing the binding (SPR #65998, 65964)

When changing the binding of a web site, the Registry service endpoint was not properly re-
configured, preventing the web site from being operational.

The workaround was to delete and recreate the web site or to modify the WDC configuration
file manually.

It was a known issue since 12.0.7 (Initial Release).

Deployment tools >
Web Deployment
Console

Also in: 12.0.10
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PcVue >

Incorrect value for symgrVarSource (SPR #66531)
The _svmgrVarSource enum was shifted by one, leading to incorrect value definition.

Development kits > SV
Manager Toolkit

Status never set back to Valid after NS FMT (SPR #65569)

The variable status was never set back to Valid after being set to NS FMT with the function
SetDataSet.

Development kits > SV
Manager Toolkit

Failed to import multiple events (SPR #66361, 66158)

Importing multiple events on variable at once failed if the last part of their name was identical.
The issue could be reproduced when generating multiple instances of a template comprising an
event with the Application Architect.

Development kits >
XML Generic Import
Toolkit

Also in: 12.0.10,
11.2.06086
Upgrade Fatal error with expressions in varexp.dat (SPR #67839) General
Under some circumstances, a fatal error could occur when migrating a project due to
Expressions included in Varexp.dat file. The issue occurred when the bit 8 of the
VARINCLUDEDFILES field was set to 1 (0x100) in the file Param.dat, with an expression
exceeding 512 characters.
To solve this issue, it is recommended to set this bit to 0.
Loss of branches with description (SPR #65390) General
Branches without variables but having a description were not loaded at project startup and lost
at the next project shutdown.
Fatal error on exit (SPR #66398) General

Under some circumstances, a fatal error could occur during the exit phase of PcVue.
The issue occurred during the exit in a scenario when a variable property dialog box had been
open via the variable selector while configuring animations in the graphic editor.

Also in: 11.2.06087

Network license token not retrieved (SPR #66654, 66652)

Under some circumstances, client stations did not retrieve their license token when the station
owning the network license was declared after the client station in the networking
configuration.

General > Licensing

AD user login failure (SPR #68106)

Active Directory users could not login after a restart of the computer and until it had reached
the Domain controller at least once. From now on, group SIDs are managed in addition to user
names and their associated groups.

General > User
management
Also in: 12.0.20

Script executed twice on logout (SPR #67695)

The Logout script configured in the user profile was executed twice at logout for the
DEFPROFILE profile.

General > User
management

Could not load project version (SPR #66692)

No error message was displayed when it was not possible to load a project due to insufficient
folder or file permission. Now an error message is displayed in the Event viewer.

General > Version
management

File & Folder filter for Project version not correctly saved (SPR #68848,
66794)

Under some circumstances, the file selection configured in the central project management was
not correctly saved. The issue could occur in particular when selecting the All files in project
directory checkbox at the project root level.

General > Version
management

Also in: 12.0.14,
11.2.06099

Fatal error upon HDS shutdown (SPR #66900)

A fatal error could occur during shutdown when the HDS tried to record the exit invalid trend
points. It only occurred when one of the trend had no previous record available in the database.

Historical data
Also in: 12.0.20,
11.2.06095

HDS failed to shutdown (SPR #67837, 67552, 67269, 16966, 16117)

Under some circumstances the HDS did not shutdown properly when shutting down PcVue.

Historical data

Other fixes & enhancements (SPR #67725)

[FIX][#67725]
HDS : UpgradeDatabase.sql : remove reference to steps in output. Step 3 now correctly
indented on the left

Historical data
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PcVue >

Fatal error at project startup (SPR #67652)

Under some circumstances, a fatal error could occur at project startup due a conflict in
accessing pending event logs (event logs waiting to be recorded).

Historical data
Also in: 12.0.16,
11.2.06094

Populations not correctly applied to HDS log lists (SPR #66699)

Under some circumstances, populations were not correctly applied to HDS log lists in Log
Viewer, leading to an empty display. The issue occurred when multiple criteria were applied to
the same attribute.

Historical data
Also in: 12.0.15

Fatal error at startup with HDS records (SPR #67471)

A fatal error occurred at project startup when the HDS invalid record file (*.hds) was not
accessible, for instance due to a file lock by another process. Now an error messages is logged.

Historical data
Also in: 11.2.06094

Incorrect user recorded in log lists with Watchdog alarm variables (SPR

#62426)

Variables set by a Watchdog alarm equipment (VARTREAT) were recorded in log lists as having
been set by the logged user. As it is a background operation that is not initiated by any user, the
corresponding field is now recorded empty.

Historical data
Also in: 11.2.06092

Fatal error on project shutdown (SPR #66363)

Under some circumstances, a fatal error occurred at project shutdown after having deleted an
archive unit containing trends.

Historical data

#x substitution with free archive units

The substitution #x (timestamp quality) did not work properly when used to record logged
events on free archive units.

Historical data
Also in: 12.0.11,
11.2.06087

Could not load or generate log reports (SPR #66341, 62750)

It was not possible to load or generate log reports from a station using a server license. This
change also fixes an issue related to user rights for log reports (as defined in the Window tab of
a user profile).

Historical data
Also in: 12.0.10,
11.2.06086

Message filling rate variable out of range (SPR #66733)

On client stations, the variable linked to the filling rate of a proprietary archive was incorrectly
initialized, leading to erroneous messages at startup.

Historical data
Also in: 11.2.06091

Fatal error when reading ODBC trends points (SPR #66564)

A fatal error occurred when accessing trend points recorded with extended attributes in an
ODBC archive unit.

Historical data
Also in: 11.2.06090

Fatal error when requesting HDS archives (SPR #66579)

Under some circumstances, a fatal error could occur when a read request to the HDS was
cancelled due to an Out of Memory error, in particular with queries returning a large amount of
points or logs.

Historical data
Also in: 11.2.06089

Associated labels not correctly recorded with HDS (SPR #65384)

Associated labels stored in the EventTitle field of Logs and Trends table were incorrect for
records corresponding to user commands.

Historical data
Also in: 11.2.06086

Fatal error when exiting the VCR mode (SPR #66773)

Historical data > VCR

Under some circumstances, a fatal error could occur when exiting PcVue if running in VCR mode  Also in: 12.0.12
and while playing records.

Fatal error with .ico file in B directory (SPR #67904) HMI

A fatal error could occur when opening the Image selector on a library containing a .ico file. It Also in: 12.0.19
was due to an improper handling of the thumbnails for this type of files.

Fatal error on symbol edition (SPR #67832) HMI

Under some circumstances, a fatal error could occur when modifying symbol sub-objects viathe  Also in: 12.0.17
Graphic Explorer.

Fatal error when closing a mimic (SPR #67571) HMI

Under some circumstances, a fatal could occur when closing a mimic. The issue occurred when Also in: 12.0.20,
trying to close a mimic while it is already being closed. For example, it could happen when 11.2.06094

mimic closure required the execution of a with VBA or SCADA Basic script taking some time to
execute.
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PcVue >

Associated actions and context mimic not accessible (SPR #67797) HMI

Under some circumstances, associated actions and context mimic were not accessible from a Also in: 12.0.17

log or alarm viewer. The issue only occurred when the mimic was opened via a SCADA Basic '

script executed at startup. 11.2.06094

Context mimic with variables attributes (SPR #67261) HMI

Since version 12.0, it was possible to open a context mimic from a graphic object animated with  A|so in: 12.0.15

a variable attribute such as #_Q, #_T or TATTx#. Such mimics only support a context based on a

variable value.

Fatal error when opening mimics in binary format (SPR #66783) HMI

Under some circumstances, a fatal error could occur when opening a mimic due to some objects  Al|sg in: 12.0.15

being loaded twice.

Graphical interface frozen (SPR #67045) HMI

Under some circumstances, the graphical interface could freeze due to the use of AVl or GIF Also in: 12.0.15

objects in mimics. The loading and display of these objects is now optimized to avoid an

overconsumption of CPU resources.

Residual objects displayed with large preview (SPR #67062) HMI

Some residual objects were displayed in images and symbols selectors when using large Also in: 12.0.15

preview.

Context window not disabled (SPR #66323) HMI

The advanced property No context window of variables was not correctly taken into account in

the Alarm and Log viewers.

Layer toolbar not hidden after pressing F8 (SPR #15590) HMI

The layer toolbar was not hidden as other toolbars and menus after pressing the F8 key.

Layer toolbar not refreshed after SCADA Basic call (SPR #65119) HMI

The layer toolbar was not refreshed after calls to the SCADA Basic instruction WINDOW mode

LAYER.

Missing items added in the Animation toolbar (SPR #66888) HMI

Some items were missing in the Animation toolbar, in particular, Image animations.

Fatal error with image and symbol selectors (SPR #66005) HMI

It was possible to try to insert an image or a symbol using the corresponding selector evenifno  Alsg in: 12.0.9

mimic was open, causing a fatal error.

Mimic incorrectly resized and positioned when switching to Design HMI

mode (SPR #66196) Also in: 12.0.9

Under some circumstances, when switching a mimic from runtime to design mode, its size and

position were incorrectly recalculated due to screen resolution adaptation.

Fatal error when browsing through mimics (SPR #66838) HMI

Under some circumstances, a fatal occurred when browsing through mimics while a mimicwas  Also in: 12.0.25

being closed. ’
g 11.2.06091

ActiveX controls based on .Net loaded twice (SPR #66858) HMI

ActiveX controls based on .Net components were loaded twice. Also in: 12.0.13

Fatal error with symbol containing a Trend viewer (SPR #66968) HMI

A fatal error occurred when manipulating a symbol containing a Trend viewer with the option Also in: 12.0.13

Save runtime properties activated.

Unable to edit symbol from the Graphic Explorer (SPR #66665) HMI

Under some circumstances, it was not possible to edit a symbol directly from the Graphic Also in: 12.0.13

Explorer. The issue occurred when the anchor point of a symbol was invalid.

Incorrect display if Print format includes tabs (SPR #67841)

Alarm viewer columns were incorrectly filled when the Print format was empty or set with
tabulation characters.

HMI > Alarm viewer

Also in: 12.0.19
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Incorrect filtered list of alarms in Alarm viewer (SPR #67009)

Under some circumstances, the alarms displayed in an Alarm viewer did not match the expected
filter. It could occur if a filter was applied using VBA while quickly opening and closing mimics.

HMI > Alarm viewer
Also in: 12.0.14,
11.2.06091

Virtual keypad - Validate text input with key Enter (SPR #66378, 65503)

Text input could not be validated by pressing the hardware keyboard key Enter (if any). The
input could only be validated with the OK button of the Virtual keypad.

HMI > Animations
Also in: 12.0.19

Marker zoom levels not retrieved (SPR #68089)

The zoom level limits of markers were not correctly retrieved in the Map positioning animation.

HMI > Animations

Fatal error with a variable name used in a tooltip (SPR #67020)

A fatal error occurred when a variable with a name longer than 80 characters was used in a
tooltip.

HMI > Animations
Also in: 12.0.14

Associated labels not correctly displayed with mismatching label type
(SPR #66371)

Under some circumstances, the displayed associated label was incorrect. The issue occurred
when the compatibility setting Allow use of mismatched associated label type was enabled, with
a variable of type alarm configured with a Bit Associated Label.

HMI > Animations
Alsoin: 12.0.11

Background image position (SPR #66458)
Background image settings were not correctly interpreted in the Chart Control, leading to an
incorrect positioning of the image.

HMI > Chart control
Alsoin: 12.0.11

Fatal error when adding a Security animation to a tree-view control (SPR
#68238)

Under some circumstances, a fatal error could occur when adding one of the following security
animation to a tree-view control:

®  Double signature,
®  Userinformation,
®  User manager.

HMI > Form controls

Tree-view control external file not saved after changes (SPR #67489)

Rearranging or deleting nodes in a Tree view control did not trigger the save prompt when the
content of the tree-view was defined in an external file.

HMI > Form controls

Event OnSelectionChanged improperly triggered in Combo-box (SPR
#68123)

The event OnSelectionChanged was improperly triggered in the Combo-box control when
navigating in the dropdown list using the keypad. It is now only triggered upon validation of the
new item selection.

HMI > Form controls
Also in: 12.0.18

Fatal error when loading the content file of a tree view (SPR #66779)

A fatal error occurred when updating the content of a tree-view control by loading a content file
defined by a variable link. The initial loading worked properly, the issue occurred when loading
another file including items with animations.

HMI > Form controls
Also in: 12.0.12,
11.2.06091

Incorrect position and size in the status bar (SPR #66176)

The size and the position displayed in the status bar for the selected item was not correct unless
the item had been moved or resized.

HMI > Graphics

Text characters overlapping (SPR #66350)

Text characters were overlapping when using a non-fixed-pitch font such as Arial with a small
size (2 or 3) when a zoom was applied to a mimic.

HMI > Graphics

Font not properly initialized (SPR #66411)

Under some circumstances, when using the ASCII format, text fonts were not properly
initialized. Consequently, the text graphic item failed to load and display.

HMI > Graphics
Also in: 12.0.11,
11.2.06087

VBA event KeyPressed not triggered (SPR #68045)

The VBA event KeyPressed of the Grid Control was not triggered when pressing an arrow key if
the key was associated to a Function Key action.

HMI > Grid control
Also in: 12.0.17
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Opening a mimic containing the Grid Control (SPR #67930)

When using the Grid Control with the Variable Tracking mode activated, the height of each row
was unnecessarily stored in the mimic (or symbol) file. It was leading to an unusual long time to
open the mimic, and could lead to a fatal error in some cases (due to timeout errors).

HMI > Grid control
Also in: 12.0.17,
11.2.06095

Enumerated labels not displayed with ODBC source (SPR #67335)

Enumerated labels were not correctly displayed in the Log viewer when the archive unit was of
type ODBC.

HMI > Log viewer

Event labels Alarm On and Alarm Off incorrectly displayed (SPR #65440)

When the setting Log only alarm on/off changes in log lists was enabled, the events Alarm On
and Alarm Off were not displayed with the correct label.

HMI > Log viewer

Zooming with SCADA Basic (SPR #67410)

It was not possible to modify the zoom level via SCADA Basic when the zoom was not activated
in the control.

HMI > Map control

Blinking effect (SPR #65506)

Fix of a blinking effect on the map control when a marker position was updated.

HMI > Map control
Also in: 12.0.19

Fatal error on text color modification (SPR #67988)
A fatal error could occur when editing the text color of a Text marker.

HMI > Map control
Also in: 12.0.19

Persistent properties not loaded (SPR #67420)

Persistent properties Zoom and Position were not correctly loaded at mimic opening when it
was saved in the ASCII format.

HMI > Map control

Incorrect position of a symbol in design mode (SPR #67570)
In design mode, a symbol at an absolute position was incorrectly anchored in the Map Control.

HMI > Map control
Also in: 12.0.15

Markers not refreshed after a VBA call (SPR #67222)

Under some circumstances, position of markers were not correctly refreshed after changing the
zoom level or the position via a VBA script.

HMI > Map control

Error message displayed when opening a map (SPR #66956)

Under some circumstances, an error message could be raised when displaying a map at project
startup, due to execution synchronization issues.

HMI > Map control
Also in: 12.0.15,
11.2.06093

VBA form issue with the map control (SPR #65854)

Under some circumstances, when a VBA form was open on top of a map control, it could
happen that mouse events were trapped by the map control, thus preventing correct user
interaction in the VBA form.

HMI > Map control
Also in: 12.0.8,
11.2.06082

Upgrade Relative path not based on folder TP (SPR #66559)

In the Pie control configuration, the path of the file containing the item list was based on the
BIN folder instead of the TP folder of the project if using a relative path.

HMI > Pie control

Textbox control not initialized with variable content (SPR #67452)

The Textbox control was not correctly initialized with the value of a variable when used in a
mimic with a branch.

HMI > Textbox control

Also in: 12.0.19

Incorrect cursor value (SPR #68428)
The cursor value displayed in the Trend viewer was incorrect for curves whose rank was over 8.

HMI > Trend viewer
Also in: 12.0.20

Trends not displayed correctly on large screens (SPR #68081)

Curves were not rendered properly if the Trend Viewer was larger than 3200 pixels.

HMI > Trend viewer
Also in: 12.0.19,
11.2.06095

Trends not displayed upon request to the archives (SPR #66731)

Under some circumstances, trends could disappear and no longer be displayed when requesting
historical data. The issue occurred when a real time value (for one of the displayed variables)
was received while processing the historical data.

HMI > Trend viewer
Also in: 12.0.17,
11.2.06095
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Trend data export wizard did not consider the buffer size (SPR #67401)

The Trend data export wizard did not consider the Buffer size property and thus could export
more data than expected.

HMI > Trend viewer

Empty button in the legend (SPR #66812)
Under some circumstances, icons were not displayed on buttons of the legend (scale, visibility

)

HMI > Trend viewer

Thresholds not found (SPR #66329)

If the mimic had a branch, threshold values were not found when configuring thresholds for a
new trace with the auto-mode.

HMI > Trend viewer

Trend viewer runtime configuration lost (SPR #66736)
The runtime configuration of Trend viewer was not correctly saved with branched mimics.

HMI > Trend viewer
Also in: 12.0.12

Trend viewer runtime properties lost (SPR #66648)

The runtime properties of Trend viewer was lost when a curve's label contained a comma.

HMI > Trend viewer
Also in: 12.0.12,
11.2.06090

Change Period dialog not opening (SPR #66188)

Some tools of the Trend viewer such as the Change Period dialog box were inactive if the parent
mimic did not have the focus. It was occurring in particular cases when the mimic was opened in
a Tab.

HMI > Trend viewer
Also in: 11.2.06084

Fatal error sending an SMS (SPR #67406)

A fatal error could occur when sending an SMS completed with a time-out.

Miscellaneous
Also in: 11.2.06093

Fatal error when broadcasting Schedules and Cron.dat (SPR #67412)

A fatal error occurred when broadcasting schedule modifications while the access to the file
CTEMP\Cron.dat was locked (opened by another application).

Miscellaneous
Also in: 11.2.06093

Cyclic action not correctly removed (SPR #66128)

Under some circumstances, cyclic actions were not correctly deleted after being created with
the SCADA Basic instruction CYCLIC, mode ADDPROGBYID. It was causing the following message
to be displayed in the event viewer: 'Cyclic action not found in share configuration'.

Miscellaneous
Also in: 11.2.06083

Fatal error on fast connection/disconnection (SPR #67249)

Under some circumstances, a fatal error could occur when a station disconnected quickly after
its connection (within a few milliseconds).

Networking
Also in: 11.2.06095

Fatal error with misconfigured server association (SPR #67100)

Under some circumstances, a fatal error could occur with a single active server association
comprising 3 or more servers with some missing node links between servers. For instance a 3-
server association where the link between server 2 and server 3 is deactivated.

Networking
Also in: 11.2.06092

Incorrect value for system variable

The system variable System.AssocNumber.StationNumber.Switch.Passive_completed was not
correctly initialized at project startup on passive servers. It was set to 0 instead of 1.

Networking
Also in: 11.2.06091

Population - VarType not correctly applied to alarms (SPR #68200)

Populations were not correctly applied when using the filter VarType in ('Alarm’) as alarms were
first considered as bits if combined with another filter criteria.

Real time data

Supervisor life indicator updated too frequently (SPR #67846)

The treatment of type Supervisor life indicator was not correctly handling the producer list of
the item itself and that of its result variable, leading to the update of the variable by multiple
stations.

Real time data

Unit and Format properties of HMI variable (SPR #68195)

The Unit property of HMI variables did not support special characters (i.e.: °C, °F ...), and the
Format property was not correctly checked and interpreted.

Real time data

Could not write simulated variables (SPR #67500, 67499, 67498, 67455)
It was not possible to write to a variable if it was not configured to be commandable. As one
purpose of the Simulated property is to simulate user operations, such variables need to be
writable when simulated.

Real time data
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Simulated property lost after restart (SPR #67318) Real time data

The Simulated property of a variable was lost after project restart if the variable was also
configured as Saved.

Invalid initial values (SPR #62921) Real time data
In an architecture with an association of type multiple active servers, the initial values of

variables were correctly loaded only on the first server that started. On all other servers in the

association, variables remained invalid.

Upgrade #B filter not working for treatment WATCHDOG (SPR #65765) Real time data

Since version 10.0, the #B filter was no longer working when used in a Variable Life Indicator
(treatment WATCHDOG).

Upgrade Could not load Event on Text variables (SPR #66244) Real time data
Under some circumstances, events configured with an expression on Text variable were not

correctly loaded when upgrading a project from an older version, due to the presence of

multiple simple-quotes and lower-case characters.

Fatal error with Chrono variables Real time data

A fatal error occurred when a Chrono variable was configured with a Triggering or Initialization
bit having a name which length was greater than 132 characters.

Population with an incorrect filter (SPR #66918, 65995) Real time data

No error message was displayed when creating or loading a population having an incorrect
Filter. The control of these filters has been enforced and error messages are now displayed.

Treatment WATCHDOG did not invalidate variables (SPR #65764,59121) Real time data

Variable Life Indicator (treatment item of type WATCHDOG) did not invalidate variables
correctly when the field 19 was set to 0.

OPC watchdog treatment not fully executed (SPR #66922) Real time data
Under some circumstances, watchdog treatment on OPC variables was not working properly Also in: 12.0.19
and only part of the variables were set to NS WD on watchdog failure. '
yp g 11.2.06091
Fatal error with a large number of recipes (SPR #68267) Recipe
A fatal error could occur when opening the Select recipe dialog from an animation if having
more than 5120 recipes configured in the project. Up to 15360 recipes can now be displayed.
Additional recipes are not displayed.
Page number when selecting a recipe (SPR #68277) Recipe
The page number was not correctly displayed when the recipe selection dialog was opened from
an animation.
Several fixes & enhancements to recipes (SPR #66666, 65990) Recipe
The list of fixes & enhancements includes:
®  Variable titles are now displayed with their index,
®  Selection issue if a recipe had special characters in its title,
®  Recipe number not retrieved when selected by title.
Loading recipes with the same label or number (SPR #65803) Recipe
No error message was shown when trying to load multiple recipes having the same label or
number. An error message in now raised in the Event viewer to inform the user about the
misconfiguration.
SV Manager Toolkit - Some variables not accessible (SPR #66727) Scripting
Since version 12, it was no longer possible to access variable having a scope Session context or
Client context.
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Syntax highlighting and auto-completion (SPR #67416, 66404, 66403,
66004)

Fixes & improvements to syntax highlighting and auto-completion in the SCADA Basic editor for
the following instructions:

®  instruction EVENT mode TRACE,

instruction EVENT mode ADDEMAIL,

instruction EVENT mode ADDSMS,

instruction OPC all modes (use of . as communication object separator instead of /),
instruction POWER,

instruction WEBVUE mode HYPERLINK,

instruction WINDOW mode CHANGE,

instruction XMLPATH mode COUNT.

Scripting > SCADA
Basic

Instruction WINDOW mode CURRENTNAME - Did not work with Tree-

view animation (SPR #67017)

The instruction WINDOW mode CURRENTNAME returned an empty string when the mimic was
opened with a Link.Open animation from a Tree-view control.

Scripting > SCADA
Basic

Instruction VARIABLE mode ASSOCIATEDLABEL - Incorrect return
value (SPR #67675)

The label name was returned instead of the label current value when the instruction VARIABLE
mode ASSOCIATEDLABEL was called for a variable of type Bit.

Scripting > SCADA
Basic
Also in: 12.0.19

Instruction KEY mode ADDPROG - Call to a script in a local library failed

(SPR #67804)

When using the instruction KEY mode ADDPROG, it was not possible to add a function key
calling a script stored in a local library.

Scripting > SCADA
Basic

Instruction POPULATION mode ADDLINE - Filter not added (SPR
#68199)

A population was not correctly updated when new lines/filter were added with the SCADA Basic
instruction POPULATION mode ADDLINE.

Scripting > SCADA
Basic

Instruction SEQ_BUFFER mode PUT_LINE - Fatal error (SPR #67813)

Under some circumstances, a fatal error could occur when using the instruction SEQ_BUFFER
mode PUT_LINE with a string having the same size as the buffer.

Scripting > SCADA
Basic

Instruction VARIABLE modes GET _DOUBLE IN_DB and

GET_LONG_IN_DB - Always returned 0 (SPR #68187)

The instruction VARIABLE modes GET_DOUBLE_IN_DB and GET_LONG_IN_DB always returned 0
when used with a variable of type Bit or Alarm.

Scripting > SCADA
Basic

Instruction VARIABLE mode GET_TYPE - Did not work with HMI

variables (SPR #69337)
The instruction VARIABLE mode GET_TYPE returned an error when used with HMI variables.

Scripting > SCADA
Basic
Also in: 12.0.24

Instruction SVLOG - Last line missing in buffer (SPR #68234)

When exporting data with the SCADA Basic instruction SVLOG, the last line was missing in the
exported buffer.

Scripting > SCADA
Basic

Also in: 12.0.20,
11.2.06097

Instruction EXPORT_LOG mode GETSTATISTIC - Sort order argument
ignored (SPR #68221, 68211)

The argument StatSortOrder was not correctly taken into account when using the instruction
EXPORT_LOG mode GETSTATISTIC.

No error was returned when passing an inappropriate value, and with a correct value, it was not
taken into account and sorting was not effective.

Scripting > SCADA
Basic
Also in: 12.0.19
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Upgrade Instruction PIE modes COLLECTED_LABEL,
COLLECTED _COLOR and CUSTOM_PROPERTY - Incorrect return value

(SPR #67687)

The instruction PIE with the modes COLLECTED_LABEL, COLLECTED_COLOR and
CUSTOM_PROPERTY always returned 0 even when correctly executed. It now returns 1 in such
conditions.

Scripting > SCADA
Basic

Instruction KEY mode ADDPROG and ADDPROGS - Failure with key

code greater than 26

The SCADA Basic instruction KEY with modes ADDPROG and ADDPROGS failed when the key
code was greater than 26.

Scripting > SCADA
Basic
Also in: 12.0.17

Memory leak when changing a threshold on a passive server (SPR
#68034)

Under some circumstances, a memory leak could occur when executing the instruction
VARIABLE mode THRESHOLD_SETVALUE on a passive server.

Scripting > SCADA
Basic

Also in: 12.0.17,
11.2.06095

Instruction KEY modes ADDPROG, ADDCLK and ADDSTD - Existing key
not replaced (SPR #67955)

When creating a new function key action with the SCADA Basic instruction KEY modes
ADDPROG, ADDCLK or ADDSTD, an existing definition of the key combination was not replaced
by the new one, leading to the execution of both actions when triggered.

As described in the help, any existing definition of a temporary key is now replaced, and the
instruction returns an error if the existing key is permanent (configured) and cannot be replaced
by script at runtime.

Scripting > SCADA
Basic
Also in: 12.0.16

Instruction CONVERT mode ATOBCD - Inconsistent result (SPR #66897)

The instruction returned an inconsistent result if the argument did not correspond to a numeric
value. Now, it returns 0.

Scripting > SCADA
Basic

Instruction EVENT modes DEL & DELPROG - Support of the @ character

(SPR #67342)

The instruction EVENT modes DEL and DELPROG did not support the use of a variable name
starting with the @ character.

Scripting > SCADA
Basic

Upgrade Instruction FILETRANSFER - Relative path not based on folder

TP (SPR #66864)

When downloading files with the instruction FILETRANSFER, the destination folder was based on
the BIN folder instead of the TP folder of the project if using a relative path.

Scripting > SCADA
Basic

Instruction HISTORY mode GETTREND - Fatal error when requesting
values (SPR #67698)

Under some circumstances, a fatal error could occur when requesting historical values with the
instruction HISTORY mode GETTREND, and a large format generating records with more than
120 characters each.

Scripting > SCADA
Basic

Instruction HISTORY mode UNIT - No error returned if unit did not exist
(SPR #66772)

No error was returned by the instruction HISTORY mode UNIT if the archive unit did not exist.

Scripting > SCADA
Basic

Upgrade Instruction M61850 - Rework of return and error codes (SPR
#66916)

Returned values and error codes of all modes of the instruction M61850 have been reworked.
Please refer to the online help for further details.

Scripting > SCADA
Basic

Text variable truncated after a copy (SPR #66784)

When copying a working variable of type string to a Text variable, the working variable was
truncated to the maximum length of the target variable.

Dim sText As Str;
sText = 'azerty';
@VAR.TEXT = sText;
length of @VAR.TEXT

'sText 1s truncated to the

Scripting > SCADA
Basic
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Instruction SQL_COMMAND mode READBUFFERCELL - Empty cells
were ignored (SPR #67266)

String cells having a NULL value were ignored and skipped when using the instruction
SQL_COMMAND with the mode READBUFFERCELL. They are now interpreted as empty strings.

Scripting > SCADA
Basic
Also in: 12.0.15

Instruction CHART mode SERIES_SETVAR - Did not work with branch

(SPR #66122)

The SCADA Basic instruction CHART mode SERIES_SETVAR did not work properly with branched
mimics.

Scripting > SCADA
Basic

Instruction CRONTAB mode NETWORKBROADCAST - Unknown list or

variable (SPR #11737)

The instruction CRONTAB mode NETWORKBROADCAST did not return an error when the
modification list or the status variable passed as argument did not exist.

Scripting > SCADA
Basic

Instruction FORMAT - Fatal error with incorrect format (SPR #66446)

Under some circumstances, a fatal error could occur when the format of the input string was
incorrect.

Scripting > SCADA
Basic

Instruction GETARG mode WBRANCH - Returned mimic name instead of
branch (SPR #66174)

The name of the mimic was incorrectly returned instead of its branch when using the instruction
GETARG mode WBRANCH after a call to the instruction ALARMDISPLAY mode ONLINESELECT.

Scripting > SCADA
Basic

Instruction MI104 mode DEVICESETIPADD - Application Explorer not
refreshed (SPR #66382, 65416)

The information displayed in the Application Explorer was not refreshed after updating an IEC
104 device IP address with the instruction M104 mode DEVICESETIPADD. The runtime was
correctly updated and connection properly done with the newly set IP address.

Scripting > SCADA
Basic

Instruction POPULATION mode DUMP - No result displayed after

creation (SPR #65988)

When executing the instruction POPULATION mode DUMP right after having created or
modified a population, the result displayed was the previous content of the population (empty
after a creation).

Scripting > SCADA
Basic

Upgrade Instruction RECIPE mode NETWORKBROADCASTALL -

Incorrect status values (SPR #65430)

The status values returned by the instruction RECIPE mode NETWORKBROADCASTALL were
incorrect. It was returning -1 instead of 1 (as stated in the documentation) for the stations that
did receive the broadcast successfully.

Scripting > SCADA
Basic

Instruction RECIPE mode NETWORKBROADCASTALL - Unknown list or

variable (SPR #11737)

The instruction RECIPE mode NETWORKBROADCASTALL did not return an error code when the
modification list or the status variable passed as argument did not exist.

Scripting > SCADA
Basic

Instruction TREND modes GETYMIN and GETYMAX - Real time values

with auto fit (SPR #66364)

The instruction TREND modes GETYMIN and GETYMAX returned the configured values instead
of the current runtime values when the Auto fit option was active.

Scripting > SCADA
Basic

Instruction LOGDISPLAY mode FILTER - Fatal error with multiple INC
clauses (SPR #66217)

A fatal error occurred when using a filter having multiple INC clauses and using the % wildcard.
e.g.: =(#A1 INC %Domain%) && (#A2 INC %Nature%)

Scripting > SCADA
Basic
Also in: 12.0.9

Fatal error when importing variables (SPR #64677)
Under some circumstances, when the auto-number internal identifiers (variable tagname)

setting was not activated, a fatal error could occur when importing variables with the SCADA
Basic instruction VARIABLE modes IMPORTFILE or IMPORTBUFFER.

Scripting > SCADA
Basic

Also in: 12.0.8,
11.2.06081
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Instruction SVLOG mode EXTRACT - Lines enclosed with double-quote

(SPR #68234, 66631)

Since version 11.2.06066, every lines returned by the instruction SVLOG mode EXTRACT were
enclosed with double-quotes. This could cause compatibility issues with 3rd party software or
scripts used to parse the exported files.

Scripting > SCADA
Basic

Also in: 12.0.20,
11.2.06091

Instruction CIMWAY mode READFRAME - Fatal error when read request

failed (SPR #66607)

A fatal error could occur when a read request triggered by the instruction CIMWAY mode
READFRAME failed.

Scripting > SCADA
Basic
Also in: 12.0.12

Instruction WINDOW mode IS_OPEN - Handling of the '*' (SPR #66337)

Using the value '*' for the branch argument when calling the instruction WINDOW mode
IS_OPEN no longer worked.
This issue was a regression introduced in version 11.2.06048.

Scripting > SCADA
Basic

Also in: 12.0.10,
11.2.06086

Issue with long string literals (SPR #66255)

Using a string literal with a size longer than 80 characters generated a memory overrun that
could lead to a PcVue fatal error.

Scripting > SCADA
Basic

Also in: 12.0.10,
11.2.06086

Instruction TREND modes SETVAR and SETVARLIST - Empty labels

(SPR #66237)

When using the TREND instruction with modes SETVAR and SETVARLIST, the Label argument
was ignored when the Label was initially left empty in the Trend Viewer.

Scripting > SCADA
Basic
Also in: 11.2.06088

Upgrade Instruction ALARM - Population filter not taken into account

(SPR #65557)

When using the instruction ALARM modes ACKALL, ACKDOMNAT, ACKPRIO, ACKLAST or
ACKOLDEST, the currently applied population filter is now taken into account.

Population filter taken into account is the one corresponding to functions 8 and 9 (alarms
acknowledgement using the Run macro animation and using scripting).

Scripting > SCADA
Basic
Also in: 11.2.06086

Several fixes & enhancements to TouchVue (SPR #67297, 66946, 66697,
66640, 65853, 65370)

The list of fixes & enhancements includes:
®  Under some circumstances, mimics could freeze,
®  Under some circumstances, users could not logout nor login,

®  Some variable commands were not correctly triggered when embedded in object
groups, symbols or mimic tab,

® Incorrect error messages were displayed after unsubscribing a variable.

TouchVue
Also in: 12.0.15

No error message on unauthorized user action (SPR #66568)

A friendly user message is now displayed when a user tried to execute an unauthorized action
(interlock condition, profile level ...).

TouchVue

Session closed after displaying a Mimic or a Symbol

User session was forcibly closed after having displayed a Mimic or a Symbol. The issue only
occurred when the advanced back end setting Immediate release of WebVue authentication
subscription whas enabled.

TouchVue

Empty Alarm and Log viewers (SPR #68670)

Alarm and Log viewers displayed in a mimic in TouchVue remained empty even when there
were alarms and/or events to display.

Displaying the same mimic in WebVue worked properly.

TouchVue
Also in: 12.0.22

Fatal error when closing a web session

Under some circumstances, a fatal error could occur when closing a web client session. The
issue could be reproduced if an Alarm Syntheses was configured with the option Take the
applied Population into account, and if the value of an extended attribute was changed while
closing the web session.

Web Server Extensions

Also in: 12.0.17
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Could not filter alarms with level 0 only (SPR #67821)

It was not possible to filter real time alarms with level 0 only (minLevel=0 and maxLevel=0). With
such requests, the maxLevel parameter was automatically set to 29.

This issue only affected web components with alarm filtering capabilities (WebVue, Web
Services Toolkit and TouchVue).

Web Server Extensions
Also in: 12.0.17

Fatal error on browse request by a web client (SPR #67983)

Under some circumstances, a fatal error could occur when the configuration of a variable was
modified while a browse request was being processed for a web client.

Web Server Extensions
Also in: 12.0.17

Incorrect event codes for Command to 0 and Command to 1

The event codes Command To 0 and Command To 1 were incorrectly returned when requesting
logged events. The Web Services Toolkit as well as the Log viewer in WebVue were affected.

Web Server Extensions

Login/logout of web users not archived (SPR #66104)

The login and logout actions of web users were not archived when the Web back end server did
not had a license with the archiving option.

Web Server Extensions

Web session immediately closed (SPR #65837)

Sessions were closed immediately when the Automatic Logoff Timeout setting was greater than
32767 sec. The automatic logoff timeout can now be up to 10 hours.

Web Server Extensions

Misleading message displayed (SPR #66068)

When a web back end endpoint was configured but the corresponding feature was not installed,
a misleading message was displayed at startup: "No configuration found for the backend. Use
web deployment console to deploy" instead of indicating that the feature was not installed.

Web Server Extensions
Also in: 12.0.9

Trend viewer average value updated in historical mode (SPR #67633)

In the Trend viewer legend, the average value of a paused/historical trend was incorrectly
updated based on real-time values.

Web Server Extensions
> WebVue
Also in: 12.0.20

Position of the Close button (SPR #68073)

The Close button of popup mimics was not correctly positioned.

Web Server Extensions
> WebVue

Alarm viewer sorting not working with checkbox selection (SPR #68143)

In WebVue, sorting was incorrectly done on the adjacent column when the Line selection mode
was set to By checkbox.

Web Server Extensions
> WebVue
Also in: 12.0.19

Tooltip displayed for hidden buttons (SPR #68024, 67993)

The tooltip was displayed on graphic objects, even if it was hidden due to a Visibility animation.

Web Server Extensions
> WebVue
Also in: 12.0.19

Web client no longer refreshed (SPR #68066, 67305)

Under some circumstances, when using popup mimics, WebVue was no longer refreshed and
was disconnected after a while.

Web Server Extensions
> WebVue
Also in: 12.0.19

Control animation played twice
Under some circumstances, control animation could be executed twice on Safari for iPadOS.

Web Server Extensions
> WebVue

Printing the Trend viewer in Firefox (SPR #67926)

When using the Firefox browser, printing a Trend viewer did not work properly. A new setting
Keep WebGL Buffer for printing is available in the WebVue client settings. It must be activated
for the trend viewer printing to work in Firefox, but may have a significant impact on the
performances.

This issue only affected Firefox browser. WebKit based browsers are able to print even if the
option is disabled.

Web Server Extensions
> WebVue

Alarm viewer filter #t not applied (SPR #67287)
Filtering by SCADA Basic using #t did not work properly with the Alarm viewer in WebVue.

Web Server Extensions
> WebVue

Domain and Nature filters duplicated in GPConf.dat (SPR #65621)

Under some circumstances, duplicated filter lines were written in the C\GPConf.dat file when
Domains and Natures were containing space characters.

Web Server Extensions
> WebVue
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Incorrect Trend viewer display (SPR #66149)

Under some circumstances, a Trend viewer in a WebVue context could be blinking or having an
erroneous display after calling consecutively multiple set modes (SETVAR, SETYMIN, SETYMAX,
SETTYPE, SETCOLOR) of the TREND instruction.

Web Server Extensions
> WebVue

Support for Sql-like filter for LOGDISPLAY instruction (SPR #67282,

66722)

Sql-like filtering is now supported by the SCADA Basic LOGDISPLAY instruction when used in the
context of a WebVue session.

Web Server Extensions
> WebVue

Trend viewer legend Min, Max and Average not refreshed (SPR #67633)

In a WebVue context, the Min, Max and Average legend columns of the Trend viewer were not
correctly refreshed when switching from Real time to Pause mode.

Web Server Extensions
> WebVue

Trend viewer not displaying curves (SPR #67633)

Under some circumstances, real time trends were not displayed in Trend viewers in a WebVue
context. The issue occurred when there was no previous point recorded in the primary archive
unit or when the variables were dynamically set with SCADA Basic instruction TREND mode
SETVAR.

Web Server Extensions
> WebVue

Web client frozen when displaying Trends (SPR #67816)

WebVue could freeze when displaying a Trend viewer configured with an interval between grid
lines set to 0. Now with such setting, the Trend viewer uses the automatic mode to adjust grid
lines.

Web Server Extensions
> WebVue

Animation not triggered (SPR #67697)

When a symbol was part of a group, its animations were not correctly triggered on mouse-click.

Web Server Extensions
> WebVue
Also in: 12.0.18

Trend viewer toggle button show/hide (SPR #67701)

The toggle button to show/hide curves (in the legend) was not working properly when trends
were dynamically set via SCADA Basic instruction TREND mode SETVAR.

Web Server Extensions
> WebVue
Also in: 12.0.18

Instruction TREND mode SETVAR - Variable description not updated
(SPR #66637)

In a WebVue context, the variable description was not updated in the legend when the curve
was modified with the SCADA Basic instruction TREND mode SETVAR.

Web Server Extensions
> WebVue
Also in: 12.0.15

Auto-size property not taken into account (SPR #65574)

The Auto-Size property of Text elements was not taken into account in WebVue context. It could
cause truncated display of register or text values when associated with Text.Register or
Text.Text animations.

Web Server Extensions
> WebVue

Calling mimic not closed (SPR #66911)

In a WebVue context, the calling mimic was not closed when a Link.Open animation was
triggered from a tree-view control.

Web Server Extensions
> WebVue

Error message with the Timetable animation (SPR #66889, 65971)

A user-friendly message is now displayed when opening the not supported Timetable Animation
in a WebVue session.

Web Server Extensions
> WebVue

Fatal error when hiding a Trend viewer scale

Under some circumstances, a fatal error could occur when hiding a scale in a Trend viewer while
a cursor was active.

Web Server Extensions
> WebVue

Filter lost in Log viewer (SPR #66360)

A filter set by SCADA Basic was lost when scrolling from one page to another one within the Log
viewer itself.

Web Server Extensions
> WebVue

Incorrect mouse icon with slider animation (SPR #65819)

With the Firefox web browser, a move mouse icon was displayed when triggering a slider
animation (Translation.Single Axis Positioning).

Web Server Extensions
> WebVue
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Incorrect text color in MS Edge (SPR #66036)

Under some circumstances, an incorrect color was displayed when multiple overlapping text
elements had the same content but different colors. Only the first color was rendered while it
should have been the last.

The issue only occurred with the Edge web browser.

Web Server Extensions
> WebVue

Incorrect values in Trend viewer legend
Some values were not correctly disabled and refreshed in the Trend viewer legend when used in
a WebVue context. In particular :
®  For Scale Min and Scale Max, the configured number of digits was not taken into
account and they were not refreshed when zooming;

®  The Timestamp at the cursor was not correctly refreshed in real time mode, and not
cleared when unselecting all curves.

Web Server Extensions
> WebVue

Infinite loop when opening mimic with Trend viewer (SPR #66145)

Under some circumstances, an infinite loop error could be triggered when opening a mimic with
a Trend viewer. The issue occurred when the SCADA Basic instruction TREND mode SETVAR was
executed within the script called at mimic opening.

Web Server Extensions
> WebVue

Instruction TREND mode SETVAR - Trend viewer frozen

Under some circumstances, the Trend viewer could freeze after using the SCADA Basic
instruction TREND mode SETVAR. The issue only occurred if the requested variable did not exist
or if the requested variable was identical to the one already displayed.

Web Server Extensions
> WebVue

Modal mimics not disabling all background clickable commands (SPR
#66147)

Under some circumstances, some commands located in a mimic in background could be
triggered even when a modal mimic was opened in foreground. The issue only occurred when
the web browser had been resized.

Web Server Extensions
> WebVue

Sizeable comment column in the Log viewer (SPR #66034)

The Comment column was always sizeable even when columns were defined as locked in the
Log viewer properties.

Web Server Extensions
> WebVue

System menu hidden (SPR #66033)

Under some circumstances, the system menu was moved outside of the visible bounds after
having used the web browser built-in zoom features.

Web Server Extensions
> WebVue

Trend viewer cursor value not rounded (SPR #66430)
The cursor value in a Trend viewer is now rounded according to the configuration.

Web Server Extensions
> WebVue

Useless scrollbar removed from the Trend viewer (SPR #66455)
A useless horizontal scrollbar was always displayed in the Trend viewer.

Web Server Extensions
> WebVue

Incorrect blinking color on alarms (SPR #66111)

Under some circumstances, the blinking color of graphical items remained even after a status
change of the alarm, typically after its acknowledgment.

Web Server Extensions
> WebVue
Also in: 12.0.9

Web client frozen after closing foreground mimic (SPR #66179)

Under some circumstances, the web client could freeze after closing a foreground mimic when
another foreground or modal mimic was opened.

Web Server Extensions
> WebVue
Also in: 12.0.9

Web client frozen with modal mimic in background (SPR #66037)

Under some circumstances, after opening a mimic from a modal mimic, the web client could
freeze due to the modal mimic being moved to background and no longer being accessible.

Web Server Extensions
> WebVue
Also in: 12.0.9

Zoom actions not working in the Trend Viewer (SPR #66048)

Under some circumstances, the zoom actions of the Trend Viewer were not working properly.

Web Server Extensions
> WebVue
Also in: 12.0.9

Multiple animations executed at once (SPR #69124)

All the Send or Run animations configured on a graphic item were triggered at once, without
considering their order. Now they are performed one after the other when successful and not
cancelled (if a Send Register animation is cancelled for example)

Web Server Extensions
> WebVue
Also in: 12.0.24
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Fatal error when opening a web client (SPR #67012) Web Server Extensions

Under some circumstances, a fatal error of the web back end station could occur when running >~ WebVue
a WebVue client. This issue was due a synchronization issue with the server.

Also in: 12.0.14
Images not stretched (SPR #66947, 65941) Web Server Extensions
The option Stretch image was not taken into account when rendering images used in Images > WebVue
animations (e.g.: Image on Bit). .

Also in: 12.0.13
Incorrect colors in Trend viewer (SPR #66754) Web Server Extensions

Under some circumstances, color of traces were incorrect in a Trend viewer. The issue occurred >~ \WebVue
when a trend historical request was executed while another one was still in progress. .
Also in: 12.0.13

Alarm viewer with first column empty (SPR #66855, 59115) Web Server Extensions

A fatal error of the web back end occurred when displaying a mimic in WebVue if it contained > WebVue
an alarm viewer with the first column configured to be empty.

Also in: 12.0.12
Blinking colors not working in animation (SPR #66679) Web Server Extensions
Blinking colors were not correctly supported in an animation when changing from blinking to > WebVue
fixed color. .

Also in: 12.0.12
Blinking colors with indexed colors (SPR #66091) Web Server Extensions
Blinking colors were not properly displayed on text objects when using indexed colors. > WebVue

Also in: 12.0.12
Fatal error with included mimics (SPR #66854) Web Server Extensions
A fatal error occurred when an included mimic was opened with a Link open animation when > WebVue
the parent mimic was named explicitly (instead of using the * character). .

Also in: 12.0.12
Object flickering with translation animation (SPR #66725) Web Server Extensions
In WebVue, graphic objects were flickering when configured with a translation animation and > WebVue
rendered partly outside of the visible window. Also in- 12.0.12

SCADA Basic script not executed on mimic opening (SPR #66785, 66340) Web Server Extensions

SCADA Basic script on mimic opening were not executed in WebVue when the mimic was > WebVue
containing an empty Trend viewer. .
Also in: 12.0.12

Send and Link animations not available on transparent graphic objects = Web Server Extensions
(SPR #66577, 66327) > WebVue

Send and Link animations were not executed when configured on an object with invisible border  Also in: 12.0.12
and background. The control zone was not active nor displayed.

Translation animation with improper control zone (SPR #66230) Web Server Extensions

Graphic objects configured with a translation animation were always highlighted with a control > WebVue
zone even if the cursor mode was not activated on the animation.

Also in: 12.0.12
Trends not set with SCADA Basic instruction (SPR #66340) Web Server Extensions
Opening a mimic and defining trends with the SCADA Basic instruction SETVAR in the same > WebVue
script was not working properly. .

Also in: 12.0.12
Send Bit animation - Mode Handled and Pulse reworked (SPR #66459, Web Server Extensions
66439, 66334) > WebVue
The Send Bit animation has been reworked, in particular the modes Handled and Pulse: Also in: 12.0.11

®  With Handled mode, the bit value was not reverted when the mimic lost focus,

®  Ppulse mode was executed only when the HMI option Mimic.Animations.Send
bit.Handled & Pulse execution was set to Standard.
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Time filter wrongly disabled in the Log viewer (SPR #66606)

The Time filter in the Log viewer was incorrectly disabled if the access to filtering options was
disabled.

Web Server Extensions
> WebVue
Also in: 12.0.11

Calendar dialog box not modal (SPR #66099)

The calendar dialog box of the Trend viewer could be improperly hidden behind the mimic. It is
now managed correctly as a modal dialog.

Web Server Extensions
> WebVue
Also in: 12.0.10

Incorrect behavior of the send register animation (SPR #66236)

If a user double-clicked on a send register animation (instead of a single click), WebVue
improperly opened an empty confirmation dialog box that the user could not close.

Web Server Extensions
> WebVue
Also in: 12.0.10

Lost control zones (SPR #66209)

Control zones were lost on polygons after executing them once.

Web Server Extensions
> WebVue
Also in: 12.0.10

Home page opened after logon instead of specific schedule (SPR
#65886)

Users were always redirected to the WebScheduler home page after logon even when they tried
to access a specific schedule.

WebScheduler

Access to previous user session (SPR #66317)
Under some circumstances, a session reuse could occur.

WebScheduler
Also in: 12.0.20

Improper disconnection

Without a user action causing a request to the web server, the user was forcibly disconnected
after the session time-out (default 1 mn). It could happen when configuring multiple schedules
before saving them at once. A keep-alive request is now sent every 10 sec to make sure the
connection is maintained.

WebScheduler
Also in: 12.0.16
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3.  Critical fixes

Loss of variables configuration after synchronization (SPR #65228,
63244, 63130)

Under some circumstances, part of the variable configuration was lost after an import
synchronization. It was due to the deletion of branches created by the initial import that were
enriched by additional variables from other imports or added via the Application Explorer.

Configuration
Environments > Smart
Generators

Several fixes & enhancements to the IEC 104 client driver (SPR #67233,
67208, 67190, 65778)

The list of fixes & enhancements includes:

®  SCADA Basic instruction M104, modes NETWORK_STOP and DEVICE_SET_IPADD were
leading to a fatal error when used with an empty string for the communication object
parameter,

®  After a server switchover, some devices were not correctly reconnected and a fatal
error could occur,

®  Devices could remain disconnected or with an unstable connection state after
connection was initiated (upon startup, switchover, communication failure and
reconnection...).
As part of these fixes, the device connection and handshaking sequence was heavily reworked
for both active and standby devices.

Data Acquisition > IEC
60870-5 Client
Also in: 11.2.06092

Several fixes in the IEC 61850 client driver (SPR #67463)
Fixes are related to the handling of communication object stop/start and includes:

®  Fix of a fatal error that occurred when changing the configuration of several variables
linked to IEC 61850 report or dataset. The issue could be reproduced when doing an
Application Architect synchronization with IEC 61850 devices connected and
communicating actively.

®  Variable updates could be frozen for 1 minute upon redundant data acquisition server
switch from active to passive.

®  Failure to reconnect to URCB or BRCB upon redundant data acquisition server switch
from active to passive.

Data Acquisition > IEC
61850 Client

Also in: 12.0.16,
11.2.06094

Several fixes & enhancements to the IEC 61850 driver (SPR #66682)
The list of fixes & enhancements includes:
®  Afatal error occurred when starting a Report already used by another client,
®  Enhanced management of requests callbacks to avoid the communication to be frozen,

®  Starting and stopping network and devices are now asynchronous to avoid the process
to freeze.

Data Acquisition > IEC
61850 Client
Also in: 11.2.06092

Polling stopped after 25 days (SPR #66766)

The cyclic polling mechanisms used by the IEC 61850 data acquisition driver stopped working
properly after a period of 25 days. It was necessary to restart the application to recover a
correct behavior.

The affected mechanisms were the following:

®  Polling of Datagroup (all versions affected),

Polling of DataSet (all versions affected),

Polling of watchdog (all versions affected),

Cyclic attempt to reconnect a disconnected device (all versions affected),
Cyclic re-synch Gl for reports (affected since version 11.2),

Cyclic attempt to reconnect disconnected reports (affected since version 11.2).

Data Acquisition > IEC
61850 Client

Also in: 12.0.12,
11.2.06090

Unable to restart serial communication (SPR #67037)

Since version 12, it was no longer possible to restart a serial communication after stopping it.
The application had to be restarted to correctly reinitialize the COM port.

Data Acquisition >
Other built-in drivers
Also in: 12.0.15

Emergency purge not executed (SPR #67005)

Since version 12.0, the emergency purge was no longer executed properly. In addition, if no
scheduled purge was configured, the issue could lead to potential storage issues and changes no
longer recorded.

Historical data
Also in: 12.0.13

Fatal error at startup with HDS archive unit (SPR #66718)

Under some circumstances, a fatal error occurred at startup when using HDS archive unit. This
issue was a regression introduced in version 11.2.06089.

Historical data
Also in: 11.2.06090
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Event lost or incorrectly archived in downgraded mode (SPR #65921)
Under some circumstances, some events were not correctly archived (for some specific types of
logged events). The issue occurred only with HDS archive units, when records had been
temporarily stored in the .hds file (due to DB connection loss).

Historical data
Also in: 11.2.06081

Modification of the Send bit animation behavior (SPR #66449)

It is no longer possible to configure a Send.Bit animation to send the Reverse value with the
modes Pulse or Maintained.

Existing animations will still be executed as configured, even if such a combination is not
recommend because depending on the protocol in use, it may lead to an undefined behavior.

HMI > Animations

Inconsistent values between clients and servers (SPR #67293)

Under some circumstances, with a large amount of variables and high-end architectures (multi-
level, long-distance WAN...), values on client stations could be wrong due to abnormal long
delay in handling subscription after a disconnection (network issue, server switchover ...).
Restarting the client was the only method to restore consistent values.

As a consequence, third-party applications connected to these stations via server interfaces
such as the OPC server might have been notified with incorrect values in the meantime.

Networking
Also in: 11.2.06093

Session context not taken into account in RealTimeData service (SPR
#66609, 66410)

Session context was not correctly managed in the RealTimeData service of the WST. As an
example, the USER variable was returning the name of the user logged on the back end hosting
the services (if any) instead of the name of the user authenticated as part of the WST session.

Web Server Extensions
> Web Services Toolkit
Also in: 12.0.11

Loss of variables (SPR #68541, 66899)

Under some circumstances, session context and client context variables were lost when a Web
user logged in.

The issue only occurred if the compatibility setting Auto-number internal identifiers was
disabled.

Web Server Extensions
> WebVue
Also in: 12.0.20
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4. Enhancements

BACnet Server - Support for the device Restart procedure (SPR #67065)

The BACnet Server Add-on now support the device Restart procedure.

Add-ons and Tools

License Utility - Display of activation date (SPR #67528)

The activation date is now displayed in the License Utility.

Add-ons and Tools

Replication Manager - Purging previous steps before a new replication
(SPR #65618)

When an earlier replication failed to complete, remaining steps were still pending and stored in
a dedicated table so that they can be processed later on. This feature had side effects in case
one did not want the pending steps to be executed. It is now possible to purge this table of
pending steps before executing a new replication, by using the Database Manager tool or by
using the /P command line argument:

® /P=1to purge the table,
® /P=0to keep previous steps (default).

Add-ons and Tools
Also in: 12.0.18,
11.2.06093, 11.1.06120

MultiTech LoRa Gateway - Redundancy support

The Add-on now supports data acquisition server redundancy.

Add-ons and Tools

EtherNet/IP Add-on - Dynamic variable mapping (SPR #65583)

Variable mapping is now dynamically updated when adding, modifying or deleting a variable. It
is no longer required to restart the application to have such configuration changes taken into
account by the add-on.

Add-ons and Tools

New return codes for the DBImport (SPR #65829)

Return codes have been added to the DBImport tool to facilitate usage in console mode. It now
returns:

®  (if successful,
® 1 if the import was successful but contained duplicated lines,
® 2 ifthe import failed or was cancelled.

Add-ons and Tools
Also in: 11.2.06083,
11.1.06121

Timestamp type configuration (SPR #63247)

It is now possible to select the timestamp type of data published by the IEC 104 Outstation. It
can be either Local or UTC (default).

Communication
interfaces > IEC 60870-
5-104 Outstation

Also in: 11.2.06097

Support for double spontaneous transmissions (SPR #68078)

Support for double transmission of information objects with cause of transmission spontaneous.

It can be configured in the advanced properties of IEC 104 points.

Communication
interfaces > IEC 60870-
5-104 Outstation

Also in: 12.0.17

Time period edit field (SPR #59490)

In configuration tools, all properties and settings corresponding to a time period are now
displayed and edited using a human-readable format such hh:mm, hh:mm:ss or hh:mm:ss.llI,
where a numeric value in a given unit of time had to be entered until now.

Example of such fields are:

Time period for cyclic actions,

Timeout and watchdog periods (IEC 104, IEC 61850, DNP3, OPC, SNMP, BACnet...),
Polling period (IEC 104, IEC 61850, DNP3, OPC, SNMP, BACnet...),

Execution period (IEC 104...),

Clock Synchronization period (IEC 104...),

Archive units and Polling groups,

Duration of Chrono behavior,

Time before automatic logout,

Audit counters,

Configuration
Environments
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Empty BACnet properties

When configuring BACnet items, some property lists remained empty while network or device
parent items were not previously configured. Now these lists are automatically filled with the
whole set of possible properties, and filtered according to their parent network or device once
configured.

Configuration
Environments >
Application Architect

Input parameters at instantiation time

The need to set a value for an input parameter at instantiation time can now be defined as
optional, recommended or mandatory by the template designer.

Configuration
Environments >
Application Architect

Modeling of SCADA Basic scripts on mimic open and mimic close

It is now possible to configure the SCADA Basic scripts executed on mimic open and mimic close
for mimics modeled with templates and instances.

Configuration
Environments >
Application Architect

Property reset by category

It is now possible to reset all properties of a given category at once.

Configuration
Environments >
Application Architect

Column selection

The context menu to select the columns to display is now accessible from a right-click on
columns headers.

In addition for variables, extended attributes can now be displayed.

Configuration
Environments >
Application Explorer

Modification of archive database connection string (SPR #61370)

In the Archives configuration, it is now possible to edit the database connection string. It
requires a restart to be taken into account.

Configuration
Environments >
Application Explorer

Number of configured elements (SPR #14252)

The number of configured items is now displayed at the bottom of the Application Explorer.

Configuration
Environments >
Application Explorer

HDS archives items sorted alphabetically (SPR #63242)

All the HDS archive items - trends, log lists, archive units, trend groups, tables and databases -
are now sorted alphabetically in the Application Explorer.

Configuration
Environments >
Application Explorer
Also in: 11.2.06083

SG-OPC - Support for multiple groups (SPR #66202, 65877)

The Smart Generator OPC is now able to import variables in different groups of an OPC Server.
Until this change, all variables had to be mapped on the same group.

Configuration
Environments > Smart
Generators

SG-SAIA & SG-TwinCAT - File location selection upon synchronization
(SPR #67028)

It is now possible to select a new file location when synchronizing an SG SAIA or SG TwinCAT
import.

Configuration
Environments > Smart
Generators

Also in: 11.2.06091

New SYSTEM variables for COV subscription (SPR #66352)
Two additional SYSTEM variables are available for each BACnet network:
®  System.BACnet.<Network>.SubscriptionCompleted
° 0: COV subscription in progress
. 1: COV subscription completed or no COV subscription to perform
®  System.BACnet.<Network>.UnsubscriptionCompleted
° 0: COV unsubscription in progress

. 1: COV unsubscription completed or no COV unsubscription to perform
In addition, the pending subscriptions and unsubscriptions are displayed in a column of the
Application Explorer.

Data Acquisition >
BACnet Client
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Support for new objects and properties Data Acquisition >
Additional BACnet objects and properties defined in the ASHRAE 2016 standard are now BACnet Client
supported:

Binary-Lighting-Output,

®  Network-Port,

®  Elevator-Group,

®  Escalator,

o |jft.
Could not change exception-schedule with ISMA devices Data Acquisition >
Using the WebScheduler, changing exceptions on a BACnet schedule failed with devices from BACnet Client

the manufacturer ISMA. i

The displayed exceptions did not match the actual value of the exception-schedule property in Also in: 11.2.06082
the WebScheduler.

The issue related to the handling of the ReadProperty service when applied to properties of type

Array in the particular case when the array is empty.

Improved fallback for interop with iSMA devices Data Acquisition >

Changing BACnet Schedules could fail with iISMA devices. The fallback mechanism for writing BACnet Client
variable-size arrays have been improved. i
/ ’ Also in: 11.2.06080

Rework of the IEC 61850 mapping dialog box Data Acquisition > IEC

The IEC 61850 mapping dialog box has been changed to improve the user experience. The listof  §1850 Client
fixes & enhancements includes:

® |mproved responsiveness and display of values to avoid freezing of the mapping dialog
box,

Browsing of dataset members for DataSet and DataReport was incorrectly displayed,
Possibility to create new variables from all Data Attributes of any Data Object,
Support for mapping on Arrays.

Watchdog polling period (SPR #65433) Data Acquisition > IEC
The polling period of Data Report watchdog is now 10 min (was 5 sec). 61850 Client
Support for 1zoT Net Server 4.5 Data Acquisition > LNS

Starting with version 15, the LNS data acquisition driver is validated with IzoT Net Server 4.5
(also known as OpenLNS) and supports recent operating systems: Windows 8.1, Windows 10,
Windows Server 2012, Windows Server 2016 and Windows Server 2019 at the time of writing.

OPC-XML - Support for Http Basic Authentication (SPR #67279, 67278, Data Acquisition > OPC

65932) Client

The OPC-XML driver now supports Http Basic Authentication. Also in: 12.0.19

Mapping of indexed array (SPR #65350) Data Acquisition > OPC
It is now possible to link variables to indexed arrays. It can be configured in the advanced Client

properties of the variable.
This feature is available since version 8.10 SP4, but no configuration interface was available until

now.
OPC-XML - Support for arrays (SPR #66898) Data Acquisition > OPC
When using OPC-XML, it was not possible to map a variable on a specific index of an array of Client
items (string, boolean, 14, Ul4...). This feature was already available with the OPC-DA client. .
Also in: 12.0.12
Support of signed float 32 bits format (SPR #68105) Data Acquisition >
New format Signed float 32 bits (swapped word) is now available for built-in drivers. Other built-in drivers
Also in: 12.0.17

Driver XBUS-IP-MASTER - Support for host names (SPR #66635, 66616) Data Acquisition >

The XBUS-IP-MASTER driver now supports addressing devices by using host names instead of IP OQther built-in drivers
addresses.

Such configuration can only be done by manually editing the file C/Comm.dat and typing the

host name in the IP1 field.
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Driver XBUS-IP-MASTER - Handling of connection termination (SPR Data Acquisition >
#66310) Other built-in drivers
In order to improve interop with some devices, it is now possible to select if a connection shall Also in: 12.0.19
be terminated using the TCP RST_ACK or FIN_ACK flag. '

¢ - S 11.2.06085
Allow write commands when equipment is in error (SPR #66436) Data Acquisition >
Prior to this modification, write commands were not sent when the equipment was seen in Other built-in drivers
error. In particular, they were not executed on valid write-only frames when another frame had .
a status error. Also in: 12.0.11
Now, writes commands are sent based on the frame status instead of the device status.
Non-printable character (SPR #66914, 66913) Data Acquisition >
A new property is available for text variables mapped to the SNMP driver to discard non- SNMP Manager
printable characters that may be retrieved via the SNMP Manager acquisition driver.
Sampling period greater than the export period (SPR #67469) Data Export

It is now possible to have a sampling period equal or greater than the export period. This change Also in: 12.0.16
allows using the export feature to generate a single sampled value snapshot.

Configuration of folders (SPR #65978, 64630) Data Export

In the general settings of Data export, it is now possible to define an absolute path for both
Template Export folders. In addition, a folder selector is available.

Ability to disable file opening after data export (SPR #65359) Data Export
From now on, when the user does not have the desktop rights, the Data Export Wizard of the Also in: 12.0.11
Trend Viewer and the Grid Control no longer asks the user if he/she wants to open the

generated file, a simple information is displayed, thus preventing the access to the file system.

Checks before running Component Registration Tool (SPR #65708) Deployment tools >

The Component Registration Tool now checks whether an affected process is still running before Component Registration
proceeding. In addition, a warning message is displayed to warn the user about the potential

overwrite of system configuration settings such as services accounts. tool

Also in: 12.0.23
Certificates storage for IIS (SPR #67780, 65939) Deployment tools >
The Webhosting store is now used by default by the WDC when generating or importing a Web Deployment
certificate (instead of the Personal store).

Console
Configuring a Web Server with different private and public ports Deployment tools >
A new advanced setting UseClientHostForRedirect is now available in the WDC. It enables the Web Deployment
configuration and deployment of a Web Server that uses different IP addresses and ports on
public and private networks. Console
Multi-binding support Deployment tools >
A web site can now be configured with multiple bindings to support deployment scenarios Web Deployment
requiring a web or mobile app to access the web server with a different Url/certificate
depending on the network it connects from. Console

New setting MachineName for the GraphicalData service (SPR #65876)  Deployment tools >
To better support infrastructure where the Web back end has multiple network interfaces, it is Web Dep|0yment
now possible to configure the MachineName setting, typically with the IP address of the

network interface to be used by the Web back end to call back the GraphicalData service hosted CoOnsole

in1IS.

New functions to get Timestamp status Development kits > SV
Two new methods are available on svmgrVarStatus enabling to get the quality of the Manager Toolkit
timestamp:

®  |sTimeStampPLC_OK
®  |sTimeStampPLC_NOK

New standard action for central project management (SPR #65584) General

A new standard action to open the central project management on a function key is available.
The SCADA Basic function KEY has been updated accordingly with the action code 124.
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Support for extended function keys General

The list of fixes & enhancements includes: Also in: 12.0.17
®  Support of F13 to F16 function keys, Back Space and Tab keys,
®  Support of the Alt key as a modifier,
®  Error and Log messages reworked.

Expressions - New functions for angle conversions (SPR #66296) General

New functions are now available for expressions:
®  ToDegrees(angle): To convert an angle from radians to degrees,
®  ToRadians(angle): To convert an angle from degrees to radians,
®  Pi(): Returns a rounded value of the constant m.

Similar conversion functions are now also available with the SCADA Basic instruction CONVERT.

Also in: 11.2.06086

User title

When using Active Directory integration, the user title is now retrieved from AD.

General > User
management

Instruction SYSTEM mode CHANGEPASSWORD - Support for Active
Directory user accounts (SPR #16223)

It is now possible to change the password of an Active Directory user with the instruction
SYSTEM mode CHANGEPASSWORD.

General > User
management
Also in: 11.2.06085

Support for more user account syntaxes with Active Directory (SPR
#66112, 59301)

It is now possible to log in by specifying the domain of the user with the following user name
formats:

® Down-Level Logon Name: DomainName\UserName

®  User Principal Name: UserName@Domain.local
It enables logging in to a different Active Directory domain.

General > User
management
Also in: 11.2.06085

Canceling central project and library loading (SPR #68251, 68250)

It is now possible to cancel the loading of a project or library version from the Central folder.
When canceled, the local version is used.

General > Version
management

SYSTEM variables (SPR #65220, 61233, 60708, 16723)

New system variables to monitor if a new version of the project or libraries are available. This
makes it easy to generate an alarm to the operator if a restart is required:

System.Version.Reference.Project,
System.Version.Reference.ProjectLastChange,
System.Version.Reference.Library,
System.Version.Reference.LibraryLastChange,
System.LocalHost.Version.Reference.ProjectIsNotCurrentRef,
System.LocalHost.Version.Reference.LibrarylsNotCurrentRef.

General > Version
management

More information about project and libraries versions (SPR #67349)

Additional information is now stored and displayed in the version management view for each
version:

®  Product version used to create the project/lib version,
®  Product version used at the time of the last update of the project/lib version.

General > Version
management

New command line argument (SPR #65596)
A new command line argument is available to enable starting with a specific version of the
project or libraries:

-d proj=x.y.z lib=t.u.v
where x.y.z (resp t.u.v) corresponds to the version of the project to start (resp version of the
libraries).

General > Version
management

Update of the Comment property

It is now possible to update the comment associated to a version of a project or libraries.

General > Version
management

Database max size only set at creation time (SPR #67484)
The database maximum size is now only set at the time of creation (was set at each project

startup). This change also avoids a systematic error message at startup if the database user does

not have the SQL dbcreator role.

Historical data
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Enhancements of the replay module
The list of enhancements includes:
Automatic synchronization of historical data when opening the player,

®  Ability to move backward in time,
®  Tuning of the playback speed,
]

Timeline to make it easy to figure out which time slot is being replayed. The cursor
allows jumping from a time slot to another one in a single click.

Historical data > VCR

Default position of anchor point (SPR #67711) HMI
The default position of the anchor point for symbols is now the top-left corner (0,0) (was the
bottom-left corner).
New substitution characters for timestamp formatting - 12-hour clock HMI
(SPR #67015) Also in: 12.0.14
New substitution characters are available in the Alarm viewer, the Log viewer and the Trend
viewer for timestamp formatting based on 12-hour clock representation:

®  #H: Hours from 1 through 12 (as opposed to #h for 00 through 23),

®  #p: AM/PM designator.
In additional, only for the Alarm viewer, #H and #p support the suffix AlaOn, AlaAck and AlaOff.
Open multiple mimics at once (SPR #63142) HMI
It is now possible to open multiple mimics at once from the File.Open dialog.
New option to close both a popup and its calling mimic (SPR #66810, HMI

66694)

A new option enabling to close both a popup mimic and its parent is now available. It can be
activated in HMI Options.Mimics.Popup.Close container mimic on link close animation using "*".
This option is useful if mimic navigation is designed to open a secondary popup mimic from a
primary popup. In such a situation, if this new option is enabled, both popups will be closed at
once.

Also in: 11.2.06090

Built-in filter and Sql-like syntax support

A new property SQL filter is now available for the Alarm viewer, which enables defining an
advanced Sql-like filter for the displayed alarms.

HMI > Alarm viewer

Current branch displayed in the variable selector status bar (SPR
#16333)

When selecting a variable for an animation, the current branch is now displayed in the status
bar of the variable selector.

HMI > Animations

Default mode of On text animations (SPR #66983)

On text animations now use the Variable mode by default (was using Value mode).

HMI > Animations
Also in: 12.0.13

Layer selection (SPR #64844)

Two new buttons All and None are now available in the advanced properties of all graphic items
to select or unselect all layers at once.

HMI > Graphics

Warning displayed with multiple trends in mode raw data (SPR #68049)

A warning is now displayed in the Historical mode of the Grid Control when selecting several
trends if in raw data mode. This mode allows displaying data of only one variable.

HMI > Grid control

Support for ODBC archive units in Historical mode (SPR #67300)

The Grid control in Historical mode can now be used with ODBC archive units.

HMI > Grid control

Positioning of markers (SPR #67820, 67757, 67756)

It is now possible to select at design time how markers of type Symbol shall be anchored on the
map:

Centered,

Anchor point,

Top-left corner,

Top-right corner,

Bottom-left corner,

Bottom-right corner.

HMI > Map control
Also in: 12.0.16
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Cut/Copy/Paste/Delete actions in the Map marker editor (SPR #61498)

The Cut/Copy/Paste/Delete actions are now available in a context menu accessible on right click

for markers and layers.

HMI > Map control

Ruler tool (SPR #64495)

A Ruler tool is now available in the Map control to allow the user measuring the distance
between two points.

HMI > Map control

Setting the maximum number of markers (SPR #64010)

When configuring a dynamic layer in the Map markers editor, it now possible to set the
maximum number of marker to be loaded.

HMI > Map control

Writing the same value (SPR #68416)

Until this change, writing the same value to an internal variable was not triggering notifications
in components such as the SV Manager Toolkit even if the global variable setting Send write
request even if the value to write is the same as the current value was enabled. In such
circumstances, it is now possible to send multiple times the same value and be notified
accordingly, which is required by some on add-ons such as the KNX driver.

It was working properly with |/O variables.

Real time data
Also in: 12.0.20

Broadcast of deadband value and type

A change of the deadband value or type properties of a register variable are now broadcasted to

all stations in case of networking configuration.

Additionally, the SCADA Basic instruction VARIABLE mode SET_DEADBAND has a new argument
to indicate the name of a register variable which will contain the result of the asynchronous
broadcast:

®  0O:Inprogress,
® 1:Failed,
®  2:Succeeded.

Real time data

Improved language switch for the SCADA Basic editor (SPR #68128,
68109, 63114)

The SCADA Basic editor now correctly follows the currently active language of the project.

Scripting > SCADA
Basic

Instruction TRACE mode FILE - Message max length (SPR #67950)

The instruction TRACE mode FILE can now handle a message of up to 2047 characters (was 80).

Scripting > SCADA
Basic
Also in: 12.0.17

Instruction LOGDISPLAY - New mode UNSELECTALL (SPR #66358)

A new mode UNSELECTALL is now available for the instruction LOGDISPLAY. It can be used to
unselect all currently selected lines of a Log viewer.

Scripting > SCADA
Basic

Instruction M61850 - Custom orCat, orldent and interlock-check for

SBO, SBOw DE, and DEw commands (SPR #66932)

The SCADA Basic instruction M61850 modes SBO_SELECT, SBOw_SELECT, SBO_OPERATE,
SBOw_OPERATE, SBO_CANCEL, SBOw_CANCEL, DE_OPERATE and DEw_OPERATE now support
optional arguments:

Scripting > SCADA
Basic

test,
®  SynchroCheck,
® |nterlockCheck,
® orCat,
®  orldent.
Instruction SYSTEM mode USER - New sub-modes to get details (SPR Scripting > SCADA
#67737) Basic

New sub-modes have been added to the instruction SYSTEM mode USER to get additional
details regarding the connected user:

LASTNAME,
FIRSTNAME,
DISPLAYNAME,
TITLE,

EMAIL,
PHONE.
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Instruction TREEVIEW - New mode ADDCHILD (SPR #67559)

A new mode ADDCHILD is available for the instruction TREEVIEW. It enables inserting a new
child node in a tree-view control.

Scripting > SCADA
Basic

Instruction SYSTEM mode MKDIR - Support of UNC paths (SPR #66218)
The instruction SYSTEM mode MKDIR now supports UNC paths (i.e.: \\host-name\folder-name).

Scripting > SCADA
Basic

Instruction TREND - New mode SETCURSORMODE (SPR #66634)

A new mode SETCURSORMODE is available for the instruction TREND. It allows changing the
cursor of a Trend viewer:

TREND ("SETCURSORMODE",
Mode) ;

With Mode having the following possible values:

®  0:no cursor (default),
1:line cursor,
®  2:crosscursor mode.

Window, Branch, Identity,

Scripting > SCADA
Basic

Instruction VARIABLE - New mode SETINVALID

The new mode SETINVALID is available for the instruction VARIABLE. It allows setting the quality
of a variable to NS.

Scripting > SCADA
Basic

SCADA Basic Editor font size (SPR #66440)

For a better display, the default font size has been increased to 10 (was 8).

Scripting > SCADA
Basic

Support for structured names when referencing graphic items (SPR
#66420)

Instructions referencing graphic items in mimics (i.e.: TREND, LOGDISPLAY ...) now support
structured names to allow the handling of items contained in symbols or groups.

For instance, to identify the item Trend1 contained in the symbol Symbol1, it is possible to
address it as Symbol1.Trend1.

Short names are still supported and address the first matching item in the mimic.

Scripting > SCADA
Basic

Instruction CONVERT - New modes for angle conversions
2 new modes are now available for the instruction CONVERT:
L4 Mode RADTODEG: To convert an angle from radians to degrees,

o Mode DEGTORAD: To convert an angle from degrees to radians.
Similar conversion functions are now also available in expressions.

Scripting > SCADA
Basic
Also in: 11.2.06086

New method to log messages (SPR #67826)

Scripting > VBA

A new method Loginformation is available in VBA on the Project object. It can be used to send Also in: 12.0.16
log messages to the Event Viewer.
ThisProject.LogInformation LogLevel, LogMsg
Where LoglLevel can take value 1, 2 or 3, and LogMsg is the message to be logged (string)
® 1 =|nformation,
® 2 =Warning,
® 3 =Error.
Enhancements to the TouchVue mobile app TouchVue

Improvements of the user interface, support for iOS and iPadOS.
This version also includes enhancements related to the handling of alarm updates and behavior
when running in background.

Ability to limit a user to one active web session

It is now possible to limit a user to have only one active web session at a time. It is defined at
the profile level.

Web Server Extensions

Support for popup and included mimics (SPR #68359, 66924, 66887,
66146)

Improved support for all types of modal, popup and included mimics.

Web Server Extensions

> WebVue

Instruction LOGDISPLAY mode SETDATETIME - WebVue support

The instruction LOGDISPLAY mode SETDATETIME is now supported in the context of a WebVue
session.

Web Server Extensions

> WebVue
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Instruction WINDOW mode POPUPCLOSE - WebVue support Web Server Extensions
The instruction WINDOW mode POPUPCLOSE is now supported in the context of a WebVue > WebVue

session.

Support for line breaks in texts (SPR #66080) Web Server Extensions
WebVue now correctly supports line breaks (\n) for Text elements. > WebVue

Two-finger scrolling and zooming on touch devices Web Server Extensions
Two-finger scrolling and zooming is now correctly supported on touch devices. > WebVue

Small font size in Send Text animation (SPR #66342, 66038) Web Server Extensions

When a Send Text animation was configured with direct input, the font size for displaying and > WebVue
typing the text were different.

Also in: 12.0.11
Support of SCADA Basic modes INSERT and REMOVE for CHECKLIST, Web Server Extensions
COMBOBOX, LISTBOX and OPTIONLIST instructions (SPR #66028) > WebVue
The SCADA Basic modes INSERT and REMOVE of the instructions CHECKLIST, COMBOBOX, Also in: 12.0.11

LISTBOX and OPTIONLIST are now supported in WebVue.

Show/hide columns WebScheduler

It is now possible to hide the columns s Standard Week Empty and Is Exception Period Active. By Also in: 12.0.16
doing so, the time to load the list of timetables is greatly reduced.
The setting to add to the WebScheduler web.config file is the following:

<setting name="HideSpecialColumns"

serializeAs="String">
<value>True</value>

</setting>

BACnet exception handling (SPR #66582) WebScheduler
Handling of Exception Schedule has been reworked to improve interop with devices thatdonot  Alsgo in: 12.0.11,
clear obsolete exception entries themselves. 11.2.06089, 11.1.06123,

11.0.06101
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5. Performance

Improved mapping dialog Data Acquisition >
When using the mapping dialog, all the properties are now read at once when changing the BACnet Client
object selection instead of only reading visible properties. It helps having a smoother rendering

when navigating among the properties.

GDI object leak (SPR #67251) HMI > Form controls

A memory leak occurred when opening a mimic containing Form controls (Combo-box, List-box,  Also in: 12.0.15
Option-list, Tree view). One GDI object was lost for each control using a custom font.

Time to load populations (SPR #68210) Real time data
The time to load populations having a filter on only one extended attribute has been

significantly improved. With a configuration containing 150.000 alarms and 700 alarm

syntheses, the loading time has been decreased from 11mn to 1mn.

Filtering based on populations (SPR #66703, 66695) Real time data
Since version 12 Initial Release, runtime performances related to population filters were Also in: 12.0.12
degraded due to a regression.

Applying a population filter could take several minutes to be fully performed. It is now almost

instantaneous.

Degraded response time (SPR #67120) Web Server Extensions
Since version 12.0 Initial Release, general performances when requesting Web Services were > Web Services Toolkit
degraded up to 50 folds (100 read requests within 50 seconds instead of 1 seconds). This fix -

restores performances to a level similar to version 11.2. Also in: 12.0.15

Image caching (SPR #66155) Web Server Extensions
Images loaded in mimics and symbols were not cached by the web browser, thus they were > WebVue

loaded every time the mimic was opened. .

The setting to add to the GraphicalData web.config file is the following - Value in seconds, Also in: 12.0.16

default to 0 (expiration controlled by the web browser) :

<setting name="CacheMaxAge" serializeAs="String">
<value>0</value>

</setting>

There is no need for customization to take advantage of the default value.
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6. Audit & diagnostic

LAN Audit counter - Incorrect value

The Audit counter indicating the number of pending messages in the mailbox for the LAN
manager was incorrect.

Audit
Also in: 11.2.06082

IOPCSynclO traces incorrectly activated (SPR #66604)

Some traces were always generated despites having not been activated, in particular those
related to the OPC server IOPCSynclO events.

Communication
interfaces > OPC Server
Also in: 11.2.06089

Frame error message (SPR #60764)

To avoid pollution of traces, frame error messages are no longer repeated at each polling
period, but only on status change.

Data Acquisition >
Other built-in drivers

Operating System and IS Version (SPR #64714)

Operating System and IIS version are now included in exports of diagnostics information.

Deployment tools >
Web Deployment
Console

Incorrect error message with -k command line argument (SPR #63669)

Incorrect messages were displayed in the event viewer when the -k command line argument
was misconfigured or when the remote license was not available.

General
Also in: 11.2.06092
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7. Installation

OPC-UA Gateway version 1.5.6 Add-ons and Tools

Update of the installation package of the OPC-UA Gateway available in the Add-ons & Tools
section of the DVD.

Availability of the KNX add-on (SPR #68513) Data Acquisition > KNX

The KNX add-on, available since version 11.2, was not shipped with the installation package and  A|so in: 12.0.20
had to be downloaded from the Technical Ressources web site. It is now part of the installation

package.

Support for Microsoft SQL Server 2019 Historical data
Update of the readme file and the online help to reflect support for SQL Server 2019 which is Also in: 12.0.20
effective since Maintenance Release 12.0.14.

Timestamping server for Authenticode signature Installation
Change of the timestamping server used for Authenticode signature of installation packages and  A|so in: 12.0.20
binary files. ’
The trust chain of the new timestamping server is attached to the following root certificate: 11.2.06098

®  Friendly name: DigiCert

®  Serial number: Oce7e0e517d846fe8fe560fc1bf03039
®  Common name: DigiCert Assured ID Root CA

®  Valid from : Friday, November 10, 2006 1:00:00 AM

®  Valid to : Monday, November 10, 2031 1:00:00 AM
Make sure this certificate is in the list of trusted certificates.
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8.  Security

Secret storage (SPR #67338, 67309, 63934)

Multiple password fields for devices were displayed in plain text in the Application Explorer.
They are now masked in Ul and stored ciphered:

SMS Account - PIN Code,

SNMP Manager - Authentication Key (Network and Device),
SNMP Manager - Privacy Key (Network and Device),
BACnet - Device Management Password (Device).

Configuration
Environments

Secret storage (SPR #68391)

The storage of the Authentication password for IEC 61850 devices is now protected and can
include quotes.

Data Acquisition > IEC
61850 Client
Also in: 12.0.20

Subject Alternative Name (SAN) in certificates (SPR #68064)

It is now possible to add a Subject Alternative Name (SAN) of type dNSName to certificate
requests and to self-signed certificates.

Deployment tools >
Web Deployment

Filling the subjectAltName with the FQDN is important because the use of the Common Name Console

for identifying a web server is deprecated and the RFC 2818 is now being enforced by some web

browsers (namely Google Chrome at the time of writing).

Access to the online help and potential security policy infringement General

(SPR #66776, 65910) Also in: 12.0.13,
Under some circumstances, access to the online help was possible before completion of project  11.2.06091

startup.

It could occur in particular by pressing the F1 key from one of the message box opened to
indicate that network access issues prevent access to the version management central folder.
Access to the file system was therefore possible before user authentication, which could be
against the security policy on some systems.

Several fixes & enhancements to user management (SPR #67616, 67615,

General > User

67614, 67613,67611, 67610, 67609, 67608, 67448, 67419, 67417, 67407, management
67391, 66306, 65994, 65221)
The list of fixes & enhancements includes:
®  Rework of the event logging when modifying the user accounts (creation, deletion and
modification of users, profiles and associations),
® Added login reason in event logging (local or web session, signature, unlocking...),
® Added logout reason in event logging (user action, time-out...),
®  Better event logging regarding account unlock actions by admins,
®  Display of the user account status in the Application Explorer (no associated profile, no
web access...),
® Complete deletion of User/Profile association in advanced security mode,
® |t was not possible to delete users without profile or with 0-level profile in advanced
security mode,
Admin users were able to deactivate themselves,
Under some circumstances, the password generator could propose a weak password in
advanced security mode.
mbedTLS library updated Security
The mbedTLS library has been updated to version 2.24.0.
OpenSSL library updated Security

The OpenSSL library has been updated to version 1.1.1h (22-Sep-2020).
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Vulnerabilities in the Web back end modules
The following vulnerabilities are fixed. They affect the interface between the Web & Mobile
back end and the web services hosted in Microsoft IIS:
® (CVE-2020-26867 - A Remote Code Execution vulnerability due to the unsafe
deserialization of messages received on the interface - Affects all versions since 8.10.
® (CVE-2020-26868 - A Denial Of Service vulnerability due to the ability for a non-
authorized user to modify information used to validate messages sent by legitimate
web clients - Only affects version 12.0.
® (CVE-2020-26869 - An information exposure vulnerability allowing a non-authorized
user to access session data of legitimate users - Only affects version 12.0.
See our Security alert page and Security Bulletin 2020-1 for more information.

Web Server Extensions
Also in: 12.0.17,
11.2.06097

Access to another web session (SPR #66644)

Under some circumstances, a web client was able to access the session of another web client,
leading to potential information disclosure and privilege elevation. This was due to the reuse of
a previously closed session Id, but with an access token not yet expired.

Web Server Extensions
Also in: 12.0.15

Weak password wrongly accepted

When renewing a password with WebVue, a weak password was accepted even if the
configuration imposed a strong one.

Web Server Extensions
> WebVue

Automatic logout not effective in WebVue (SPR #66653)

Web Server Extensions

The automatic logout was not completely effective in WebVue. > WebVue
After the inactivity timeout elapsed, it was indicated that the session ended but refreshing the -

page (with F5 or Refresh button) was opening it again without entering credentials. Also in: 12.0.12
Disable WebScheduler help (SPR #67044) WebScheduler

It is now possible to disable the access to the online help of the WebScheduler via a setting that
can be defined at the time of deployment with the WDC.
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9. Other fixes & enhancements

SPR #62922, 65363, 65368, 656595, 65651, 65884, 65897, 65912, 65991,
66030, 66136, 66137, 66144, 66164, 66165, 66248, 66280, 66292, 66299,
66331, 66450, 66693, 66740, 66750, 66786, 66795, 66798, 66805, 66890,
66934, 66938, 66976, 67047, 67087, 67088, 67226, 67298, 67345, 67373,
67415, 67501, 67631, 67663, 67721, 67891, 67923, 68029, 68037, 68040,
68060, 68120, 68136, 68144, 68148, 68149

SPR #66177, 66223 Also in: 15.2.0,
11.2.06089
SPR #66177, 66223, 69424 Also in: 12.0.23,
11.2.06088
SPR #68498 Also in: 12.0.20
SPR #68268 Also in: 12.0.20,
11.2.06097
SPR #65348, 68261 Also in: 12.0.19
SPR #67223, 67986 Also in: 12.0.17
SPR #67486 Also in: 12.0.16
SPR #66811, 66857 Also in: 12.0.12
SPR #66192 Also in: 12.0.11
SPR #66009, 66150 Also in: 12.0.10
SPR #66219, 66269 Also in: 12.0.9
SPR #67466 Also in: 11.2.06093
SPR #66370, 66465 Also in: 11.2.06088
SPR #65935, 66079 Also in: 11.2.06086
SPR #66309 Also in: 11.2.06085,
11.1.06122, 11.0.06098
SPR #65700 Also in: 11.2.06081,
11.1.06118
Reference: PcVue 15 Release Notes Last update: April 2, 2026
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18. Known Issues

[Fixed] Alarm synthesis timestamp changed on server switchover (SPR  Alarms

#71548) 15.2.0
On a server switch from passive to active, an alarm synthesis is recalculated, including its value Also in: 15.1.0, 15.0.0,
and timestamp. If the alarm synthesis has not changed, the value is not set. But, since a 12.0.20

regression introduced in Maintenance Release 12.0.20 the timestamp is updated, causing event
triggering if any.
[Edit: Fixed in 15.2.4 and 12.0.28].

Audit counter mean values are inaccurate (SPR #65251) Audit

Calculation of mean values is wrong for audit counters (error every 27 hours). 15.2.0
Also in: 15.1.0, 15.0.0,
12.0.7

Lost instances (SPR #67013) Configuration

Under some circumstances, all instances are lost. Investigations indicate that this may be Environments >

caused by the deletion of the root node. . . .
While the investigations continue to uncover and fix the source of the issue, changes have been  Application Architect
made to mitigate and prevent the root node deletion. 15.2.0

Specific diagnostic traces have been added to indicate that an attempt to delete the root node Also in: 15.1.0. 15.0.0
occurs. In addition, a specific backup (in addition to the rolling backup files) is now performed CooT T T
to ensure that instances configuration will not be lost. 12.0.13
These changes are in effect starting with the Maintenance Release 12.0.13.

If you run an earlier release of version 12 and notice that the instances root node is not
displayed in the Instances tab of the Application Architect, you have probably run into the issue
and the instances are lost. In such situation, stop PcVue and recover a valid instances
configuration from the rolling backup files located the C\Templates\Back folder. Do not restart
PcVue multiple times before you recover your configuration as it exposes you to losing the
useful rolling backup.

Upgrade Potential behavior change for alarm syntheses (SPR #67799, Configuration

66701, 60594) Environments >

Starting with version 11.2 Release, by default, new alarm synthesis items created with the App“cation Architect
Application Explorer or the XML Generic Import do not take the population filter into account.

This change was not introduced for alarm syntheses created with the Application Architect, 1 5‘2-(,)

leading to the following potential issues if your project includes populations and alarm Also in: 15.1.0, 15.0.0,
syntheses created based on templates and instances with the Application Architect: 12.0.16, 11.2.06094

® |f you have migrated or are migrating a project from version 11.1 or earlier to version
11.2 or later, you should check with the Application Explorer that alarm syntheses are
configured to fit your requirements (take into account or ignore population). If
configuration does not fit, reverse the value of the 'Take population filter into account'
using the Application Architect and proceed with a full synchronization.

® Do the same verification and configuration changes if your project was once migrated
to 11.2 (earlier than 11.2.06094), and is now being migrated to 11.2.06094 or later.

® Do the same verification and configuration changes if your project was once migrated
to 12 (earlier than 12.0.16), and is now being migrated to 12.0.16 or later.

® |nall cases, pay particular attention to alarm syntheses created with version 11.2 and
12, as it is likely that the population filter property is not applied as it used to be with
earlier versions.
You are not impacted by this issue if you do not use population filtering in your project, or if
alarm syntheses are not created based on application modeling with the Application Architect.

Supported operating systems for the KNX Add-on Data Acquisition > KNX
The KNX add-on is only supported on the following operating systems, with the exclusion of any 15.2.0
virtual environment: Also in: 15.1.0, 15.0.0,

®  Windows 7 SP1 (x64), 12.0.7, 11.2.05001
®  Windows Server 2008 R2 SP1 (x64).

[Fixed] Unexpected value sent to PLC (SPR #71855) Data Acquisition >

Under some circumstances, commands on bit and register variables do not send the good Other built-in drivers
value. The issue only affects data acquisition drivers configured behind the Equipment node of

the Application Explorer (Modbus, S7...). Drivers such as BACnet, OPC, IEC ... are not affected. 15.2.3

The issue only occurs in a very specific and unlikely condition. A series of particular values must

be present in adjacent addresses in the memory area where the frame is stored. But it brings a

significant risk on the physical process if the PLC does not check the received values

(consistency and range) before controlling a process' actuator.

The issue is a regression introduced in 15.2.0, it affects all releases from 15.2.0 to 15.2.3

(included).

[Edit: Fixed in 15.2.4 - We strongly recommend users to update].
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[Fixed] Deferred attributes no longer archived (SPR #76007, 75523)

The value of deferred extended attributes is no longer recorded as part of a log list if using
proprietary archive.
[Fixed in: 15.2.13, 16.3.3]

Historical data

15.2.11
Also in: 16.3.0, 16.2.5

SQL filtering on HMI variables (SPR #65903)

When using the Grid control in variable tracking mode, the Sqgl syntax cannot be used to filter
HMI variables.

HMI > Grid control
15.2.0
Also in: 15.1.0, 15.0.0,
12.0.7

Upgrade [Fixed] Installation failure on Windows 7 SP1 and Windows Installation
Server 2008 R2 (SPR #70329, 70199) 15.2.0

The Feature release 15.2 cannot be installed successfully on Windows 7 SP1 and Windows

Server 2008 R2.

The issue affects the 15.2.0 and 15.2.1.

[Edit: Fixed in 15.2.2]

[fixed] Client/Server networking instability if recent hardening is Networking
enabled (SPR #76197, 76112, 75016) 15.2.12

If the security fix described in security bulletin SB2025-4 is enabled, networking packets can be
falsely detected as malformed, causing a server station to force a disconnection. This issue
leads to a situation where a client station may not be able to stay connected to a server station
in a stable way.

Recommendation for 16.3.1, 16.3.2, 15.2.12 and 12.0.31:

The issue does not manifest itself if the recent hardened connection mechanism is disabled. To
disable this mechanism, the security alteration setting named 'Networking.Allow security
altering configuration options' must be checked and the property 'Allow stations with altered
security' on Nodes must be set to Yes.

Fixed in 16.3.3, 15.2.13 and 12.0.32.

The security bulletin SB2025-4 is updated (Rev B).

Also in: 16.3.1, 12.0.31

[Fixed] Instruction SEQ_BUFFER mode REPLACEFIELD - Cannot
replace more than 12 characters (SPR #72480)

In Maintenance Release 15.2.4, only the first 12 characters are considered when using the
instruction SEQ_BUFFER mode REPLACEFIELD.
[Edit: Fixed in 15.2.5]

Scripting > SCADA
Basic
15.2.4

BeforeClose script not triggered (SPR #68418)

Since version 12.0.7, the SCADA Basic function called upon closing a mimic was not correctly
triggered when the mimic was closed via SCADA Basic.

[Edit: Fixed in 12.0.20 and 15.0.0 for PcVue desktop]

A fix for WebVue is planned for a later release.

Scripting > SCADA
Basic

15.2.0
Also in: 15.1.0, 12.0.20

Issue with host name resolution on Android (SPR #65724)

Android versions earlier than 5.1 are known to be affected by a bug related to host name
resolution.

When using DHCP, the issue prevents from using a host name other than a Fully Qualified
Domain Name even if the host name is properly registered in a local DNS and the DNS server
automatically updates itself to reflect DHCP leases. The issue is that Android devices do not use
the DNS search path provided by DHCP.

Please refer to the Google Issue Tracker for more information:
https://issuetracker.google.com/issues/36916949

Web Server Extensions
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Drag handling with Firefox (SPR #70455)

If a position animation with Cursor mode enabled is used on an image, the user needs to click
twice in Firefox to perform the action.

Web Server Extensions
> WebVue
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Known limitation related to hiding control zone highlighting (SPR

#69621, 69606, 68375)

At the time of writing, hiding the control zone highlighting (according to the HMI option) is only
implemented for rectangle shapes.

Web Server Extensions
> WebVue
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Known limitation related to the animation Send register in Step mode
(SPR #66012)

The '+' and '-' buttons are not rendered in WebVue when using the Send register animation
with the Step mode enabled.

Web Server Extensions
> WebVue
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7
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Restrictions related to web browsers

Each web browser can come with its own restrictions, in particular when security is at stake.
Below is a list of known behaviors, specific to one or the other web browser available on the
market at the time of writing. These restrictions may be cleared and others appear depending
on web browser updates and their publisher's strategy.

®  Safari on iOS - When the Safari web browser is closed without logging out from
WebVue, WebVue is re-open by default the next time the user opens Safari, but the
user will not be able to successfully login, and will be stuck on the WebVue loading
page. This is due to the Safari snapshot of the last visited page where Safari displays
the web page without actually requesting the web server. The solution is to go to the
address bar and click the Go button, or ask Safari to reload the page.

®  Google Chrome - The password manager of Chrome does not store credentials if the
connection to the web server is insecure. As a consequence, if you do not have a
proper certificate on the web server, users will not be able to use the Chrome
password manager to store their credentials.

®  Microsoft Edge - Edge in versions prior to 79 (Jan 2020) does not store the session
cookie when using the local computer as a web server with a binding on the hostname
at the IIS level. As a consequence, you cannot successfully log in, and can see a
warning message indicating that the version of the client is not compatible with the
server. The solution is to add .local to the computer host name when setting up the
web site binding with the Web Deployment Console (for example,
https://mycomputername.local instead of https://mycomputername).

Web Server Extensions
> WebVue

15.2.0
Also in: 15.1.0, 15.0.0,
12.0.7

SCADA Basic scripting of form controls (SPR #65938)

When scripting form controls in SCADA Basic in a WebVue context, the GET modes such as
GETSELECTEDINDEX, GETTEXT... do not return the correct value if the currently selected item
was selected either via the keyboard or another script (with a mode such as
SETSELECTEDINDEX).

These GET modes work properly if the selection was done via mouse-click or a tap (on a touch
device).

Web Server Extensions
> WebVue
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Support for WebFont requires manual installation on Windows 7 SP1

(1S 7.5) (SPR #65847)

If the Web Server runs 1IS 7.5 - a Windows 7 desktop or Windows 2008 R2 server computer -
the default font (Times New Roman) is used instead of the Roboto Web Font for texts inside
pre-defined WebVue pages and mimic tittles. Texts used in animations within mimics and
symbols are not affected.

This issue is due to the lack of pre-configured support for WebFont in 1IS 7.5.

The solution is to install the MIME type handler for .woff files manually using the IIS manager.
This issue may be fixed in a later version of the Web Deployment Console.

Web Server Extensions
> WebVue
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Upgrade WebScheduler migration issue

In order to fit with Microsoft Windows default privileges for the 1IS_IUSRS group, the
configuration files of the ScheduleData service are now stored in the folder
ScheduleData\AppData on the IIS Web server.

These files, namely ScheduleDataAccess.xml and SchedulesAccess.dat, used to be stored in the
folder ScheduleData\config.

Upon migrating a project to PcVue 12.0, it is advised to move the files manually to avoid losing
customization of any piece of configuration. The manual copy shall take place after installation
and deployment of the WebScheduler (using the WDC).

WebScheduler
15.2.0

Also in: 15.1.0, 15.0.0,
12.0.7

Reference: PcVue 15 Release Notes
Copyright ©2026 - ARC Informatique. All rights reserved — LN I MIN3

Last update: April 2, 2026
Page 123/124



-~ PcVu e)

PCVUE 15 RELEASE
NOTES

\ ARC Informatique

' Private limited company
’ capitalized at 1 250 000 €
RCS Nanterre B 320 695 356
APE 5829C / SIREN 320 695 356
VAT N° FR 19320695 356
Headquarters
40 avenue Pierre Lefaucheux,
92100 Boulogne-Billancourt, France
| Tel: +33 141 14 36 00

Hotline: +33 1 41 14 36 25
Email: arcnews@arcinfo.com
WWW.pcvue.com

safety
o c"o,

ARC Informatique is
ISO 9001, ISO 14001 and
ISO 27001 certified

% |spacol >
4 IS0 14001
" 18027001

Crp. <&
Yad 515

We would love to hear your thoughts and suggestions
so we can improve this document
Contact us at team-doc@pcvuesolutions.com

Copyright ©2026 - ARC Informatique. All rights reserved — LI N0 B3


mailto:arcnews@arcinfo.com
mailto:team-doc@pcvuesolutions.com?subject=[Feedback]%20Release%20Notes

	1. Maintenance Release 15.2.14 (15.2.14900)
	1. Fixes
	2. Critical fixes
	3. Security
	4. Other fixes & enhancements

	2. Maintenance Release 15.2.13 (15.2.13902)
	1. Fixes
	2. Critical fixes
	3. Enhancements
	4. Performance
	5. Security
	6. Other fixes & enhancements

	3. Maintenance Release 15.2.12 (15.2.12900)
	1. New features
	2. Fixes
	3. Enhancements
	4. Security
	5. Other fixes & enhancements

	4. Maintenance Release 15.2.11 (15.2.11901)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Performance
	6. Installation
	7. Security
	8. Other fixes & enhancements

	5. Maintenance Release 15.2.10 (15.2.10900)
	1. Fixes
	2. Critical fixes
	3. Performance
	4. Other fixes & enhancements

	6. Maintenance Release 15.2.9 (15.2.09900)
	1. Fixes
	2. Critical fixes
	3. Enhancements
	4. Security
	5. Other fixes & enhancements

	7. Maintenance Release 15.2.8 (15.2.08900)
	1. Fixes
	2. Enhancements
	3. Security
	4. Other fixes & enhancements

	8. Maintenance Release 15.2.7 (15.2.07900)
	1. Fixes
	2. Enhancements
	3. Security
	4. Other fixes & enhancements

	9. Maintenance Release 15.2.6 (15.2.06901)
	1. Fixes
	2. Critical fixes
	3. Enhancements
	4. Other fixes & enhancements

	10. Maintenance Release 15.2.5 (15.2.05901)
	1. Fixes
	2. Critical fixes
	3. Enhancements
	4. Performance
	5. Other fixes & enhancements

	11. Maintenance Release 15.2.4 (15.2.04900)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Installation
	6. Security
	7. Other fixes & enhancements

	12. Maintenance Release 15.2.3 (15.2.03900)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Performance
	6. Security
	7. Other fixes & enhancements

	13. Maintenance Release 15.2.2 (15.2.02900)
	1. New features
	2. Fixes
	3. Enhancements
	4. Installation
	5. Security
	6. Other fixes & enhancements

	14. Maintenance Release 15.2.1 (15.2.01900)
	1. Fixes
	2. Enhancements
	3. Installation
	4. Security

	15. Feature Release 15.2.0 (15.2.00900)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Performance
	6. Audit & diagnostic
	7. Installation
	8. Security
	9. Other fixes & enhancements

	16. Feature Release 15.1.0 (15.1.00900)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Performance
	6. Audit & diagnostic
	7. Installation
	8. Security
	9. Other fixes & enhancements

	17. Initial Release 15.0.0 (15.0.00902)
	1. New features
	2. Fixes
	3. Critical fixes
	4. Enhancements
	5. Performance
	6. Audit & diagnostic
	7. Installation
	8. Security
	9. Other fixes & enhancements

	18. Known Issues

