4
PcVue >

PCVUE 12 RELEASE NOTES

7 SUMMARY:

This document contains information about changes in PcVue 12. It includes information up to
Maintenance Release 12.0.31.

Last update ‘ 03/11/2025

Revision ‘ 1.1

Confidentiality TLP:CLEAR

The information in this book is subject to change without notice and does not represent a commitment on the part of the
publisher. The software described in this book is furnished under a license agreement and may only be used or copied in
accordance with the terms of that agreement. It is against the law to copy software on any media except as specifically
allowed in the license agreement. No part of this manual may be reproduced or transmitted in any form or by any means
without the express permission of the publisher. The author and publisher make no representation or warranties of any kind
with regard to the completeness or accuracy of the contents herein and accept no liability of any kind including but not
limited to performance, merchantability, fitness for any particular purpose, or any losses or damages of any kind caused or
alleged to be caused directly or indirectly from this book. In particular, the information contained in this book does not
substitute to the instructions from the products’ vendor. This book may contain material belonging to third-parties. Such
information is used exclusively in internal work processes and is not intended to be disclosed. In addition, this notice is not
a claim of property on such third-party information.

All product names and trademarks mentioned in this document belong to their respective owner
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1.  Maintenance Release 12.0.31 (12.0.31900)

1. Security

Vulnerabilities in the client/server Networking (SPR # 74711, 74710, Networking

74709) Also in: 16.3.1, 15.2.12
The following vulnerabilities are fixed. They affect the TCP-based client/server Networking

feature:

®  (CVE-2025-9998 - Improper validation of packets sequencing - Affects all versions.

® (CVE-2025-9999 - Improper validation of payload elements - Affects all versions.
See our Security alert page for more information.
[Edit: The fix in 12.0.31, 15.2.12, 16.3.1 an 16.3.2 is not effective. Refer to the section Known
issues for more information.]

Reference: PcVue 12 Release Notes Last update: November 3, 2025
Copyright ©2025 - ARC Informatique. All rights reserved — LI Mg M\ Page 5/50


https://www.pcvue.com/security#SB2025-4

4
PcVue >

2.  Maintenance Release 12.0.30 (12.0.30900)

1.  Fixes
Fatal error with large .hds temporary file (SPR #73098, 69357, 66782) Historical data
A fatal error occurred when the size of a temporary file exceeded 2 Gb. Also in: 15.2.0

From now on, these files are limited to 2 Gb and are indexed when reaching this limit.

2. Enhancements

Driver Udp Genisys - Support for redundancy (SPR #73476) Data Acquisition >

The Udp Genisys driver now supports field device redundancy. Other built-in drivers
Also in: 15.2.9

Driver Udp Genisys - Switch polling mode Data Acquisition >

The driver Udp Genisys now supports the following SCADA Basic instruction to switch indication  Qther built-in drivers
request from master poll to master recall: .
CIMWAY(“SENDMSG”,“network.device”,“ResetRecallFlag”); Also in: 15.2.9

3. Installation

OPC UA Gateway version 1.6.0 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools
section of the DVD.

4.  Security
Buffer overflow vulnerability (SPR #73486) Data Acquisition > IEC
The following vulnerability is fixed. It affects the IEC 61850 client driver: 61850 Client

®  (CVE-2024-34057 - Buffer overflow in the Triangle MicroWork’s IEC 61850 Client library Also in: 15.2.9
- Affects all versions since 10.0. : e
See our Security alert page for more information.

Vulnerability in the Microsoft Visual Basic for Applications runtime Scripting > VBA

(SPR #73056) Also in: 15.2.8
The following vulnerability is fixed. It affects the VBA runtime:
® (CVE-2010-0815 & CVE-2021-1854 - Remote Code Execution - Affects all versions since

9.0.
See our Security alert page for more information.

5. Other fixes & enhancements

SPR #74125

Reference: PcVue 12 Release Notes Last update: November 3, 2025
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3. Maintenance Release 12.0.29 (12.0.29900)

1. Fixes

Error with text variable in Data export name (SPR #69664, 68837, 68832)  Data Export
Text variables were not correctly supported when used in the Name property of a Data export Also in: 15.2.0, 15.1.5

item.
Failed to export all data (SPR #72532) Data Export
Under some circumstances, when multiple data to export had the same timestamp, the data Also in: 15.2.6

export could fail to export all archived data matching the time filter.

2.  Security
OPC UA Gateway version 1.5.14 Add-ons and Tools
Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 15.2.7

section of the DVD.
This version of the OPC UA Gateway addresses the following security vulnerabilities:

® 7DI-CAN-20497 / CVE-2023-32172
®  7ZDI-CAN-20576 / CVE-2023-32173

®  7ZDI-CAN-20577 / CVE-2023-32174
Please note that the version 1.5.13 released earlier this year addressed the following security
vulnerabilities:

® (CVE-2022-4304
CVE-2023-0286
ZDI-CAN-20353 / CVE-2023-41185
ZDI-CAN-20494 / CVE-2023-32170
ZDI-CAN-20495 / CVE-2023-32171

®  7DI-CAN-20497 / CVE-2023-32172
See our Security alert page for more information.

3. Other fixes & enhancements

SPR #70346, 72458 Also in: 15.2.6
SPR #71732, 72461 Also in: 15.2.4
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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4. Maintenance Release 12.0.28 (12.0.28900)

1. Fixes

Alarm synthesis timestamp changed on server switchover (SPR #71548)
On a server switch from passive to active, an alarm synthesis is recalculated, including its value
and timestamp. If the alarm synthesis has not changed, the value is not set. But, since a
regression introduced in Maintenance Release 12.0.20 the timestamp was updated, causing
event triggering if any.

This is a known issue in 12.0.20, all subsequent Maintenance Releases of version 12 until
12.0.27 (included) and all releases of version 15 until 15.2.3 (included).

Alarms
Also in: 15.2.4

Could not delete actions associated to alarms (SPR #71293)

Since 12.0.25, 15.1.5 and 15.2.0 it was no longer possible to delete actions associated to alarms
in the behavior panel of the Application Explorer.

Configuration
Environments >
Application Explorer
Also in: 15.2.3

Memory leak with BACnet objects (SPR #70978)

Under some circumstances, a memory leak occurred on a client station (typically the web back
end) when accessing BACnet Schedule or Calendar objects for the WebScheduler.

The issue only occurred if the server station producing the BACnet objects was not available at
the time of the request from the client station.

Data Acquisition >
BACnet Client
Also in: 15.2.3

Incorrect time restriction with development licenses (SPR #71147)

If a development license was rented from a network slot, data acquisition was incorrectly
limited to 1 hour instead of 4.

General > Licensing
Also in: 15.2.3

Infinite loop at startup with a network license (SPR #71568)

Under some circumstances, an infinite loop could occur at startup when using a network
dongle.

The issue occurred in a scenario when the license owner is not accessible. Clicking the Quit
button caused the renter station to go in an infinite loop.

It was a regression introduced in 15.2.3.

General > Licensing
Also in: 15.2.4

Null timestamp for saved variables (SPR #67079)

If a variable was saved while its status was inhibited, it was re-initialized with a null timestamp.

Real time data
Also in: 15.2.5

Upgrade Error handling when importing configuration (SPR #71781)

Error handling was not consistent across a number of SCADA Basic instructions designed to
import configuration:

®  Instruction EXPRESSION mode IMPORT_FILE_ONVAR;
®  |Instruction EXPRESSION mode IMPORT_FILE_TEMP

® Instruction ASSOCIATEDACTIONS mode IMPORTBYFILE
[ ]

Instruction EVENT mode IMPORTBYFILE
They now return:

®  (:If the file is not accessible or contains nothing to treat (add/delete/modify)
®  >0: Number of lines processed from the file (add/delete/modify) if the import
succeeds or fails

The error values documented in the online help were no longer in line with the implementation
since version 10.

Scripting > SCADA
Basic
Also in: 15.2.5

Instruction EVENT mode ADDPROG - Variable with multiple events
(SPR #70979)

Since version 12, when for a given variable, multiple events were created with the SCADA Basic
instruction EVENT mode ADDPROG, only the first and last ones were executed.

Scripting > SCADA
Basic
Also in: 15.2.3

Instruction WINDOW mode CHANGE - Intellisense (SPR #72098, 72077)
The instruction WINDOW mode CHANGE was missing in the Intellisense.

Scripting > SCADA
Basic

Animations on the tree-view control (SPR #70786)

Animations on tree-view nodes were not executed.
The issue was a regression introduced in 12.0.25.

Web Server Extensions

> WebVue
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2. Critical fixes

Invalid trend point on shutdown (SPR #71407, 71324, 71311) Historical data

When using an HDS archive unit, the invalid point (quality 64) was no longer stored when Also in: 15.2.4
shutting down PcVue.
The issue was a regression introduced in Maintenance Releases 12.0.26 and 15.2.1.

3. Enhancements

Sunair - Support for new controllers Data Acquisition >
The Sunair driver now supports T-5000A 5 kW, T-10000A 10 kW and T-10000B 10 kW Other built-in drivers
transmitter systems. .
Also in: 15.2.3
Tyco POSM IP - Support for device redundancy (SPR #71218) Data Acquisition >
The data acquisition driver Tyco POSM over IP now supports a device standby address to Other built-in drivers
manage the Centinel redundancy system. .
Also in: 15.2.3

4, Installation
OPC UA Gateway version 1.5.11 (SPR #70709) Add-ons and Tools
Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 15.2.4
section of the DVD.

5.  Security
Denial Of Service vulnerability (SPR #71486) Data Acquisition > IEC
The following vulnerability is fixed. It affects the ICCP/TASE.2 interface Add-on and the IEC 61850 Client
61850 Client driver: Al in: 15.2.3

® (CVE-2022-38138 - Access of Uninitialized Pointer vulnerability in the stack used for the SO in: e

ICCP/TASE.2 interface and the IEC 61850 Client driver.
For the IEC 61850 Client driver, it affects all versions since 10.0.
For the ICCP/TASE.2 interface, it affects all versions since 15.1.
See our Security alert page and Security Bulletin 2022-5 for more information.
Vulnerability in the email & SMS account configuration (SPR #69821, Miscellaneous
65029) Also in: 15.2.4
The following vulnerability is fixed. It affects the configuration of the email and SMS accounts:

® (CVE-2022-4312 - Cleartext Storage of Sensitive Information vulnerability, allowing a

user able to authenticate locally to access the SMTP account credentials and the SIM

card PIN code - Affects all versions since 8.10.
See our Security alert page for more information.

6.  Other fixes & enhancements
SPR #71119, 71120, 71915, 71916
SPR #70713, 71058, 71134, 71235 Also in: 15.2.3
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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5.  Maintenance Release 12.0.27 (12.0.27900)

1. Fixes

Fatal error on reading properties (SPR #70107, 69711)

Under some circumstances, a fatal error could occur when an OPC client read some vendor-
specific properties.

This issue was a regression introduced in the following Maintenance releases: 11.2.06099,
12.0.22,15.0.3 and 15.1.1.

Communication
interfaces > OPC
Server

Also in: 15.2.1,
11.2.06101

Fatal error when sending multiple write commands (SPR #70802)

Under some circumstances, a fatal error could occur on a data acquisition server when sending
write commands.

Data Acquisition >
Other built-in drivers

The issue only occurred when sending multiple write requests simultaneously, and only in case Also in: 15.2.3
of connection issues with the device.
Project name containing a space (SPR #71067) General

Fix of a regression, since version 12, a project with a space in its name failed to start when using
the -wts command line argument.

Fatal error at start-up and shutdown (SPR #70803)

Under some circumstances, a fatal error could occur at start-up or during shutdown.

Miscellaneous

Fatal error on the Web & Mobile back end server (SPR #69142, 66521)

Under some circumstances, a fatal error could occur on the Web & Mobile back end server
upon a call to the SubscriptionPolledRefresh method of the RealTimeData service for a large
number of variables. The issue occurred more frequently when the subscription comprised
optional properties or thresholds.

Web Server Extensions
> Web Services Toolkit

Fatal error with alarm synthesis (SPR #70341)

Under some circumstances, a fatal error could occur on the Web & Mobile back end server
upon connection of a web client. The issue occurred if a population was configured with the
property Take the applied population into account activated and the scope of at least one of its
variable set to Session context.

Web Server Extensions
> WebVue
Also in: 15.2.2

Incorrect handling of the Beep on new alarm property (SPR #70460,
70222)

The property Beep on new alarm on a user profile was incorrectly handled, leading to
unwanted beeps on mimic opening even without active alarms.

Web Server Extensions
> WebVue
Also in: 15.2.2

Inhibited alarms not filtered properly (SPR #68617)

Inhibited alarms were not filtered properly in the Log viewer when used in a web context.

Web Server Extensions
> WebVue
Also in: 15.2.1

Instruction TREND mode SETVAR - Legend not filled up properly (SPR

#69098)

When adding a trend with the SCADA Basic instruction TREND mode SETVAR in a web context,
the trend label in the legend was not correctly updated with the variable name when its
description was empty.

Web Server Extensions
> WebVue
Also in: 15.2.2

Support for @#V in the Trend viewer (SPR #70157)

Web Server Extensions

The Trend viewer now supports the substitution @#V used to refer to the context variable in a > WebVue
web context. .

Also in: 15.2.2
Memory leak when accessing timetables and schedules (SPR #70890, WebScheduler
70816, 70009) Also in: 15.2.3

A memory leak occurred on the Web & Mobile back end server when using the WebScheduler
to access timetable and schedule objects.

In addition, under some circumstances, a fatal error could also occur on the producer of a
BACnet schedule object upon login in the WebScheduler.

Reference: PcVue 12 Release Notes
Copyright ©2025 - ARC Informatique. All rights reserved — LI Mg M\

Last update: November 3, 2025

Page 10/50



4
PcVue >

2. Installation
Documentation update General >
The product documentation has been updated: Documentation

®  Online help in Russian - Now at the level of version 12. Also in: 15.2.1

Sentinel System driver 7.6.1 General > Licensing
Update of the installation package for the Sentinel System driver. Also in: 15.2.1

3. Security
Dream Report version 2020 R2 SP1 Add-ons and Tools
Update of the installation package for Dream Report available in the Add-ons & Tools section of  A|sg in: 15.2.1
the DVD.

This version of Dream Report addresses the following security vulnerabilities:
® (CVE-2020-13532
® (CVE-2020-13533
® (CVE-2020-13534

® (CVE-2021-21957
See our Security alert page for more information.

OPC UA Gateway version 1.5.10 Add-ons and Tools

Update of the installation package of the OPC UA Gateway available in the Add-ons & Tools Also in: 15.2.3
section of the DVD.
This version of the OPC UA Gateway addresses the following security vulnerabilities:

® (CVE-2022-29862 — Chained Certificate Loop PoD

®  (CVE-2022-29864 — Reference Counter Decrement DoS
See our Security alert page for more information.

Vulnerability in the OAuth configuration (SPR #71066, 70710) Web Server Extensions

The following vulnerability is fixed. It affects the configuration of the OAuth web service hosted  Also in: 15.2.3
in Microsoft IIS:
®  (CVE-2022-2569 - Cleartext Storage of Sensitive Information vulnerability, allowing a
user able to authenticate locally to access session data of legitimate users stored in
the OAuth database - Affects versions 12 & 15.
See our Security alert page and Security Bulletin 2022-4 for more information.

4. Other fixes & enhancements

SPR #69235
SPR #67079, 70003, 70906, 71074 Also in: 15.2.3
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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6. Maintenance Release 12.0.26 (12.0.26900)

1. Fixes

IP-ISO-S7 driver - Handle leak (SPR #69989, 69911)

Under some circumstances, a handle leak could occur when using the IP-ISO-S7 driver.

Data Acquisition >
Other built-in drivers

Also in: 15.2.1
Line printers not supporting long server list name (SPR #70170) General
A server list with a name longer than 14 characters could not be used to configure a Line Also in: 15.2.1

printer.

Incorrect historical trends (SPR #70197)

Under some circumstances, invalid points were recorded in HDS databases, leading to

inconsistent Trends display. The issue could occur after a project restart for variables that were

invalid when stopping the project.

Historical data
Also in: 15.2.1

OnMimicClose function not executed (SPR #70035)

When closing a mimic using the SCADA Basic instruction WINDOW mode CLOSE, the SCADA
Basic function configured to be executed upon mimic close was not executed.

Scripting > SCADA
Basic

Incorrect statistical values in the Trend viewer legend (SPR #70075)

Statistical values (min, max, average...) displayed in a Trend viewer legend were not always
correct due to data compression.

Web Server Extensions

> WebVue
Also in: 15.2.1

Trend cleared when scrolling (SPR #70076)

Web Server Extensions

After a request in historical mode, the trend was cleared when using the horizontal scrollbar. > WebVue

Now, the horizontal scrollbar is disabled in historical mode, as it requires executing a new .

historical request. Also in: 15.2.1
2. Other fixes & enhancements

SPR #66129

SPR #70141 Also in: 15.2.1

Reference: PcVue 12 Release Notes
Copyright ©2025 - ARC Informatique. All rights reserved — LI Mg M\

Last update: November 3, 2025
Page 12/50



4
PcVue >

7. Maintenance Release 12.0.25 (12.0.25900)

1.  Fixes
Fatal error on alarm apparition (SPR #69996, 69874) Alarms
Under some circumstances, a fatal error could occur when a new alarm was triggered while a Also in: 15.2.0
log request was in progress if the alarm matched the log request filter criteria.
Fatal error when browsing through mimics (SPR #66838) HMI
Under some circumstances, a fatal occurred when browsing through mimics while a mimicwas  A|so in: 15.0.0,

being closed.

11.2.06091

2. Critical fixes

Control animations not executed (SPR #70070, 69124) Web Server Extensions

Since Maintenance Release 12.0.24, control animations in mimics were not executed if
rendered in Web & Mobile clients. The issue affected WebVue and TouchVue.
This is a known issue in 12.0.24.

3. Enhancements

Udp Genisys - Ability to send value 0 (SPR #70038) Data Acquisition >
A new property is available for the Udp Genisys nodes to enable sending value O for bits. Other built-in drivers
Defaults to false since the control data should be reset by the device itself. .
Also in: 15.2.1
4.  Other fixes & enhancements
SPR #69894, 69895 Also in: 15.2.0, 15.1.5
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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8. Maintenance Release 12.0.24 (12.0.24900)

1. Fixes

Wrong alarm timestamp set (SPR #69559)

Fix of regression, since 12.0.20 and 15.0.0, writing the value of an alarm in a SCADA Basic script
was causing the timestamp to be changed even if the value was the same.

Alarms
Also in: 15.2.0, 15.1.3

Fatal error on Log report modification (SPR #69558)

A fatal error occurred when modifying or creating a Log report while the print spooler service
was unavailable.

Configuration
Environments >
Application Explorer
Also in: 15.2.0, 15.1.4,
11.2.06101

Tooltip truncated (SPR #69339)

Under some circumstances, the tooltip of an animation was truncated.

HMI > Animations
Also in: 15.2.0, 15.1.3,
11.2.06101

Fatal error when adding trends by script (SPR #69477)

A fatal error occurred when removing and adding trends to a Trend viewer via a SCADA Basic
script.

HMI > Trend viewer
Also in: 15.2.0, 15.1.3,
11.2.06101

Several fixes related to Recipes (SPR #69322)

The list of fixes includes:

® Anincorrect error message was displayed when a recipe file name was over 8
characters,

A fatal error occurred when validating a recipe without a title or recipe number,

Under some circumstances, updating the title or recipe number was not taken into
account or created a duplicated recipe.

Miscellaneous
Also in: 15.2.0, 15.1.5

Variables @DATE & @TIME not updated (SPR #69349)

Under some circumstances, the variables @DATE and @TIME could no longer be updated. The
issue occurred after having applied a population.

Miscellaneous
Also in: 15.2.0, 15.1.4

Instruction FTP modes DOWNLOAD & UPLOAD - GDI object leak (SPR

#69306)

A GDI object leak occurred when using the SCADA Basic instruction FTP with modes
DOWNLOAD and UPLOAD.

Scripting > SCADA
Basic
Also in: 15.2.0, 15.1.4

Instruction VARIABLE mode GET_TYPE - Did not work with HMI

variables (SPR #69337)
The instruction VARIABLE mode GET_TYPE returned an error when used with HMI variables.

Scripting > SCADA
Basic
Also in: 15.0.0

Could not execute animation (SPR #69124, 66762)

After cancelling a Send Text or Send Register animation, all the other animations were locked.

Web Server Extensions
> WebVue

Multiple animations executed at once (SPR #69124)

All the Send or Run animations configured on a graphic item were triggered at once, without
considering their order. Now they are performed one after the other when successful and not
cancelled (if a Send Register animation is cancelled for example)

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Critical fixes

Memory leaks (SPR #69240, 69217)

Memory leaks occurred when Web or Mobile clients were connected.
The issue was a regression since release 15.0.0.

Web Server Extensions
Also in: 15.2.0, 15.1.1
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3. Other fixes & enhancements

SPR #68404, 69531, 69570

SPR #69820 Also in: 15.2.0, 15.1.5

SPR #69218 Also in: 15.2.0, 15.1.3,
11.2.06101

Reference: PcVue 12 Release Notes Last update: November 3, 2025
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9. Maintenance Release 12.0.23 (12.0.23900)

1. Fixes

Could not deactivate the Network dongle role (SPR #68063)

It was not possible to deactivate the property Network dongle role in the advanced tab of a
station.

Configuration
Environments >
Application Explorer

Fatal error on disconnection (SPR #69276, 66623)

Under some circumstances, a fatal error could occur when disconnecting from an OPC Server.

Data Acquisition > OPC
Client
Also in: 15.2.0, 15.1.2

OPC items with bad quality not ignored (SPR #69148)

Since version 11.1, the setting defined in the OPC Server configuration that allows ignoring the
value of an item with quality Bad was not working properly with bit and alarm variables.

Data Acquisition > OPC
Client

Also in: 15.2.0, 15.1.1,
15.0.3, 11.2.06099

Incorrect aggregated value (SPR #69283, 67600)

Under some circumstances, invalid aggregated values were exported. The issue occurred when
no record was found in the exported time period, causing a random value to be exported.

Data Export
Also in: 15.2.0, 15.1.2

Clipboard paste (SPR #68372)

Better control of the clipboard Paste command to prevent side effects when the type of data
contained in the clipboard is not supported and not supposed to be pasted in a mimic.

HMI
Also in: 15.2.0, 15.1.2

#V not resolved (SPR #65319)

The #V substitution string was not resolved in the Trend viewer, preventing from using it in the
legend or Data export wizard.

HMI > Trend viewer
Also in: 15.1.0, 15.0.3,
11.2.06100

Instruction MAPDISPLAY - Fatal error with modes LOADDEFAULT and
EXPORT (SPR #69019)

Under some circumstances, a fatal error could occur when calling the modes LOADDEFAULT
and EXPORT in sequence.

Scripting > SCADA
Basic
Also in: 15.2.0, 15.1.1

Setting FirstDayOfWeek not correctly taken into account (SPR #69314,
68462)

The setting FirstDayOfWeek was not correctly taken into account in the Standard week display.

WebScheduler
Also in: 15.2.0, 15.1.2

2. Enhancements

Checks before running Component Registration Tool (SPR #65708)
The Component Registration Tool now checks whether an affected process is still running
before proceeding. In addition, a warning message is displayed to warn the user about the
potential overwrite of system configuration settings such as services accounts.

Deployment tools >
Component
Registration tool
Also in: 15.0.0
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3. Performance

Time to open/close a session (SPR #69199) Real time data

The time to open and close a WebVue session has been significantly improved, in particular Also in: 15.2.0, 15.1.1
when the project comprises a large amount of alarm syntheses.

For example on a project with 6000 alarms, 3000 alarm syntheses and 15000 alarm synthesis

counters:

Before performance improvement:

®  Time to open a WebVue session: 18.5 sec, including 17 sec to load alarm synthesis,

®  Time to close a WebVue session: 3 min 9 sec, including 3 min 5 sec to unload context
variables.
After performance improvement:

® Time to open a WebVue session: 4.9 sec, including 3.5 sec to load alarm synthesis,
®  Time to close a WebVue session: 2.5 sec, including 1 sec to unload context variables.

4.  Security

Vulnerabilities in the Web back end modules Web Server Extensions

This is a follow-up to fixes available since 11.2.06097, 12.0.17 and 15.0.0. This fix covers other Also in: 15.2.0. 15.1.2
ways to exploit similar Remote Code Execution vulnerabilities uncovered after more tests of the ' ’
initial fix. 11.2.06100

The following vulnerability is fixed. It affects the interface between the Web & Mobile back end

and the web services hosted in Microsoft IIS:

® (CVE-2020-26867 - A Remote Code Execution vulnerability due to the unsafe
deserialization of messages received on the interface - Affects all versions since 8.10.
See our Security alert page and Security Bulletin 2020-1 for more information.

5. Other fixes & enhancements

SPR #69217

SPR #69216, 69235 Alsoin: 15.2.0, 15.1.1

SPR #68423, 68424 Also in: 15.1.0

SPR #66177, 66223, 69424 Also in: 15.0.0,
11.2.06088
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10. Maintenance Release 12.0.22 (12.0.22900)

1. Fixes

DBImport - Log suffix not correctly managed (SPR #68868, 68864, 68744)

When using the DBImport for importing logged events, the Log suffix was not correctly
managed, leading to incorrect import.

Add-ons and Tools
Also in: 15.1.0, 15.0.3

Fatal error with OPC Server interface (SPR #68813)

Under some circumstances, a fatal error could occur when using the OPC Server interface, due
to some resources not being released properly.

Communication
interfaces > OPC
Server

Also in: 15.2.0, 15.1.1,
15.0.3, 11.2.06099

Memory leak with array of strings (SPR #68954)

A memory leak occurred when variables were mapped to an OPC DA item of type array of
strings. The amount of leake memory depended on the size of the array.

Data Acquisition > OPC
Client
Also in: 15.1.0, 15.0.3

Alarm timestamps not saved (SPR #69032)

When an alarm was configured with the Saved property enabled, not all of its timestamps
(AlaOn, AlaAck, AlaOff) were stored. Only the timestamp of its last state was recorded. These
timestamps can be used in the Alarm viewer.

General
Also in: 15.2.0, 15.1.1,
15.0.3

Unable to close mimics (SPR #69069) HMI

Under circumstances, it was not possible to close mimics when the Cache property was

enabled.

Empty Alarm and Log viewers (SPR #68670) TouchVue
Alarm and Log viewers displayed in a mimic in TouchVue remained empty even when there Also in: 15.0.0

were alarms and/or events to display.
Displaying the same mimic in WebVue worked properly.

2. Enhancements

Instruction EMAIL - Support for UNC path for attached files (SPR
#68852)

When using the EMAIL instruction, it is now possible to reference attachment files by using
UNC path (e.g. \\hostname\folder\file.txt).

Scripting > SCADA
Basic

Also in: 15.1.0, 15.0.3,
11.2.06099

Filtering HDS log list with Sql-like syntax (SPR #68855, 68823)

It is now possible to use Sql-like syntax when filtering Log lists for a Log viewer with the SCADA
Basic instruction LOGDISPLAY mode FILTER.

Web Server Extensions
> WebVue

Also in: 15.2.0, 15.1.1,
15.0.3

3. Other fixes & enhancements

SPR #66794, 68848

Also in: 11.2.06099
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11. Maintenance Release 12.0.21 (12.0.21900)

1. Fixes

Timestamp type for IEC 104 Sectors (SPR #68569)

It was not possible to configure the Timestamp type (UTC or Local) for IEC 104 Sectors modeled
with the Application Architect.

Configuration
Environments >
Application Architect
Also in: 15.1.0, 15.0.2

Memory leak on modification of text extended attributes (SPR #68634)

A memory leak occurred when writing text extended text attributes of a variable.

General
Also in: 15.1.0, 15.0.2

Virtual keypad for user animations (SPR #68669)

The virtual keypad could not be used with some user animations (user name, signature ...).

HMI > Animations
Also in: 15.1.0, 15.0.2

Fatal error on web session opening (SPR #68602)

A fatal error of the Web back end could occur when opening a web session if an alarm synthesis
was defined and the corresponding variable was missing in the configuration.

Web Server Extensions
Also in: 15.1.0, 15.0.2

Trends not displayed (SPR #68698, 67972)

Trends were not displayed when the style of invalid points was set to Invisible.

Web Server Extensions
> WebVue
Also in: 15.1.0, 15.0.2

Incorrect text encoding (SPR #67999, 61478)

Some cultures relying on non-latin characters were not correctly managed by the
WebScheduler, leading to incorrect text display.

WebScheduler
Also in: 15.1.0, 15.0.2

Setting FirstDayOfWeek not taken into account (SPR #68462)

The setting FirstDayOfWeek defined in the web.config file was not correctly taken into account.
Starting from version 15, this setting can be set with the Web Deployment Console when
deploying the WebScheduler.

WebScheduler
Also in: 15.1.0, 15.0.2

2. Enhancements

New BITMASK expression (SPR #68570)

It is now possible to use the custom field BITMASK(x) in the advanced properties of OPC
variables. The variable value is then the result of the logical bit AND operation between the
OPC item value and the mask.

Data Acquisition > OPC
Client
Also in: 15.1.0, 15.0.2

3. Security

Password displayed with virtual keypad (SPR #68668)

When unlocking a user with the virtual keypad, the password was displayed in the input dialog
instead of '*' characters.

HMI
Also in: 15.1.0, 15.0.2
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12. Maintenance Release 12.0.20 (12.0.20900)

1. Fixes

Masked alarm reappearing after passive server restart (SPR #68378)
Under some circumstances, saved alarms were incorrectly reloaded when a passive server was
restarting. Specifically, their saved Masked status could be corrupted and trigger reappearance
or disappearance of such alarms upon a restart.

Alarms
Also in: 15.1.0, 15.0.1

OPC-XML server not correctly created (SPR #68568, 68486)

OPC-XML servers were not correctly created if modeled with the Application Architect. The Url
property was missing.

Configuration
Environments >
Application Architect
Also in: 15.1.0, 15.0.2

SG-OPC - Incorrect server after synchronization (SPR #68454)

Under some circumstances, an incorrect server was set after an import synchronization. The
issue occurred when multiples servers were configured and the selected server was different
from the first one.

Configuration
Environments > Smart
Generators

Also in: 15.1.0, 15.0.1

Fatal error on passive server (SPR #68426)

A fatal error could occur when stopping a passive server due to pending reports not deleted
correctly.

Data Acquisition > IEC
61850 Client
Also in: 15.1.0, 15.0.1

Report groups disabled (SPR #68460)

Under some circumstances, a report group was disabled after receiving a report that had the
buffer overflow flag set.

Data Acquisition > IEC
61850 Client
Also in: 15.1.0, 15.0.1

Fatal error when writing an SNMP variable (SPR #68479)

Under some circumstances, a fatal error could occur when writing an SNMP variable.

Data Acquisition >
SNMP Manager
Also in: 15.1.0, 15.0.1

Memory leak on errors (SPR #68511)

Under some circumstances, a memory leak could occur when facing connectivity issues with
devices refreshed by polling. Some polled read requests were not correctly freed after errors.

Data Acquisition >
SNMP Manager
Also in: 15.1.0, 15.0.1

AD user login failure (SPR #68106)

Active Directory users could not login after a restart of the computer and until it had reached
the Domain controller at least once. From now on, group SIDs are managed in addition to user
names and their associated groups.

General > User
management
Also in: 15.0.0

Fatal error upon HDS shutdown (SPR #66900)

A fatal error could occur during shutdown when the HDS tried to record the exit invalid trend
points. It only occurred when one of the trend had no previous record available in the
database.

Historical data
Also in: 15.0.0,
11.2.06095

HDS fatal error upon shutdown (SPR #68338)

Under some circumstances, a fatal error of the HDS could occur upon project shutdown.

Historical data
Also in: 15.1.0

HDS not stopping (SPR #68314)

Under some circumstances, the HDS was not correctly stopped at project exit. The issue
occurred after having added a new trend associated to a long update rate, and the project exit
being triggered before the end of the first update period of the new trend.

Historical data
Also in: 15.1.0, 15.0.1

Fatal error when closing a mimic (SPR #67571)

Under some circumstances, a fatal could occur when closing a mimic. The issue occurred when
trying to close a mimic while it is already being closed. For example, it could happen when
mimic closure required the execution of a with VBA or SCADA Basic script taking some time to
execute.

HMI
Also in: 15.0.0,
11.2.06094

Incorrect cursor value (SPR #68428)

The cursor value displayed in the Trend viewer was incorrect for curves whose rank was over 8.

HMI > Trend viewer
Also in: 15.0.0
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Initial value of new variables not loaded (SPR #68578)

When updating a project version on a passive server, newly created variables (in this project
version) were not correctly initialized with their initial value after a server switchover.

Networking
Also in: 15.1.0, 15.0.1

Multiple active servers in a single active server association (SPR
#68379)

In a single active server historical association, multiple servers could be active simultaneously
when started at the same time or after a network failure.

Networking
Also in: 15.1.0, 15.0.1

BeforeClose script not triggered (SPR #68418)

The SCADA Basic function called upon closing a mimic was not correctly triggered when the
mimic was closed via SCADA Basic.

This fix applies to PcVue desktop only.

Scripting > SCADA
Basic
Also in: 15.0.0

Instruction FOPEN - Fatal error with unknown access mode (SPR
#68097)

A fatal error could occur when using the instruction FOPEN with an unexpected access mode
argument.

Scripting > SCADA
Basic
Also in: 15.1.0, 15.0.1

Instruction SVLOG - Last line missing in buffer (SPR #68234)

When exporting data with the SCADA Basic instruction SVLOG, the last line was missing in the
exported buffer.

Scripting > SCADA
Basic

Also in: 15.0.0,
11.2.06097

Instruction SVLOG mode EXTRACT - Lines enclosed with double-quote

(SPR #68234, 66631)

Since version 11.2.06066, every lines returned by the instruction SVLOG mode EXTRACT were
enclosed with double-quotes. This could cause compatibility issues with 3rd party software or
scripts used to parse the exported files.

Scripting > SCADA
Basic

Also in: 15.0.0,
11.2.06091

Instruction WINDOW mode CLOSEALL - Mimics close failed (SPR

#68639)

The SCADA Basic instruction WINDOW mode CLOSEALL was not working properly in a web
context. Some mimics could fail to close and remained open.

Web Server Extensions
> WebVue
Also in: 15.1.0, 15.0.1

Trend viewer average value updated in historical mode (SPR #67633)

Web Server Extensions

In the Trend viewer legend, the average value of a paused/historical trend was incorrectly > WebVue
updated based on real-time values. .

Also in: 15.0.0
Access to previous user session (SPR #66317) WebScheduler
Under some circumstances, a session reuse could occur. Also in: 15.0.0

2. Critical fixes

Loss of variables (SPR #68541, 66899)

Under some circumstances, session context and client context variables were lost when a Web
user logged in.

The issue only occurred if the compatibility setting Auto-number internal identifiers was
disabled.

Web Server Extensions
> WebVue
Also in: 15.0.0

3. Enhancements

New interop property (SPR #68568, 68486)

A new interop property is available for OPC-XML servers. It enables adding the http basic
authentication header to all requests and is designed for OPC-XML servers that do not send the
HTTP 401 error if the header is required.

Data Acquisition > OPC
Client
Also in: 15.1.0, 15.0.2

Writing the same value (SPR #68416)

Until this change, writing the same value to an internal variable was not triggering notifications
in components such as the SV Manager Toolkit even if the global variable setting Send write
request even if the value to write is the same as the current value was enabled. In such
circumstances, it is now possible to send multiple times the same value and be notified
accordingly, which is required by some on add-ons such as the KNX driver.

It was working properly with 1/O variables.

Real time data
Also in: 15.0.0
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4. Installation

Availability of the KNX add-on (SPR #68513) Data Acquisition > KNX

The KNX add-on, available since version 11.2, was not shipped with the installation package and  Also in: 15.0.0
had to be downloaded from the Technical Ressources web site. It is now part of the installation

package.

Support for Microsoft SQL Server 2019 Historical data
Update of the readme file and the online help to reflect support for SQL Server 2019 which is Also in: 15.0.0
effective since Maintenance Release 12.0.14.

Timestamping server for Authenticode signature Installation
Change of the timestamping server used for Authenticode signature of installation packages Also in: 15.0.0
and binary files. '
The trust chain of the new timestamping server is attached to the following root certificate: 11.2.06098

®  Friendly name: DigiCert

®  Serial number: Oce7e0e517d846fe8fe560fc1bf03039
®  Common name: DigiCert Assured ID Root CA

®  Valid from : Friday, November 10, 2006 1:00:00 AM

®  Valid to : Monday, November 10, 2031 1:00:00 AM
Make sure this certificate is in the list of trusted certificates.

b. Security
Secret storage (SPR #68391) Data Acquisition > IEC
The storage of the Authentication password for IEC 61850 devices is now protected and can 61850 Client
include quotes. i
Also in: 15.0.0
6.  Other fixes & enhancements
SPR #68450 Also in: 15.1.0, 15.0.1
SPR #68498 Also in: 15.0.0
SPR #68268 Also in: 15.0.0,
11.2.06097
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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13. Maintenance Release 12.0.19 (12.0.19900)

1. Fixes

Ethernet/IP Add-on - Handling of large arrays (SPR #68352)

The Ethernet/IP add-on did not handle large arrays of DWord correctly. If the array was larger
than 50 items, variables were always set to status NS (invalid).

Add-ons and Tools
Also in: 15.0.0

Mimic design screen resolution no longer forced to 1440*900 (SPR
#66529)

Mimic generated with the Application Architect were always configured with the resolution
1440%*900 for the property Design screen resolution. They are now using the active resolution at
the time of the generation.

Configuration
Environments >
Application Architect
Also in: 15.0.0

Fatal error when configuring a license renter station (SPR #67689,
67090)

A fatal error of the Application Explorer occurred when modifying the configuration of a station
to make it a license renter. The issue occurred if no license owner station was configured, or if
the owner station had been previously deleted.

Configuration
Environments >
Application Explorer
Also in: 15.0.0

Unable to start BRCB on a newly active server after switchover (SPR
#68309)

In a configuration containing several IEC 61850 networks managed by the same server
association, the server switchover was not correctly processed for all produced networks. Some
networks remained active on the passive server, meaning that URCB/BRCB were not stopped,
and thus forbade the newly active server to start them.

Data Acquisition > IEC
61850 Client
Also in: 15.0.0

Incorrect quality if range dependent on other variables (SPR #67969)

Under some circumstance, the quality of register variables could be incorrect. The issue only
occurred with OPC variables, when the variable range was defined by dependency to other
variables.

Data Acquisition > OPC
Client
Also in: 15.0.0

OPC-XML - Data types handling caused a fatal error (SPR #67622)
Under some circumstances, a fatal error could occur when processing data received from an
OPC-XML server. The issue only occurred for data of type long, uint, ushort, ulong, if they were
not already converted on the OPC server side.

Data Acquisition > OPC
Client
Also in: 15.0.0

OPC-XML - Fatal error with a disconnected server (SPR #65755)

A fatal error occurred when a GetStatus() request was sent to a disconnected server.

Data Acquisition > OPC
Client
Also in: 15.0.0

Fatal error on exit (SPR #66105)

A fatal error occurred upon exit when using frames of type Info or Command not set to the
maximum size.

Data Acquisition >
Other built-in drivers
Also in: 15.0.0,
11.2.06088

Host name resolved even when communication not started (SPR
#66228)

Data Acquisition >
SNMP Manager

Resolution of the hostname of an SNMP device was executed even when the device was not Also in: 15.0.0,
started. Hostname resolution is now executed only when data acquisition is started for the

device. 11.2.06084
Fatal error with .ico file in B directory (SPR #67904) HMI

A fatal error could occur when opening the Image selector on a library containing a .ico file. It Also in: 15.0.0

was due to an improper handling of the thumbnails for this type of files.

Incorrect display if Print format includes tabs (SPR #67841)

Alarm viewer columns were incorrectly filled when the Print format was empty or set with
tabulation characters.

HMI > Alarm viewer
Also in: 15.0.0

Virtual keypad - Validate text input with key Enter (SPR #66378, 65503)

Text input could not be validated by pressing the hardware keyboard key Enter (if any). The
input could only be validated with the OK button of the Virtual keypad.

HMI > Animations
Also in: 15.0.0
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Blinking effect (SPR #65506)

Fix of a blinking effect on the map control when a marker position was updated.

HMI > Map control
Also in: 15.0.0

Fatal error on text color modification (SPR #67988)
A fatal error could occur when editing the text color of a Text marker.

HMI > Map control
Also in: 15.0.0

Textbox control not initialized with variable content (SPR #67452)

The Textbox control was not correctly initialized with the value of a variable when used in a
mimic with a branch.

HMI > Textbox control
Also in: 15.0.0

Trends not displayed correctly on large screens (SPR #68081)

Curves were not rendered properly if the Trend Viewer was larger than 3200 pixels.

HMI > Trend viewer
Also in: 15.0.0,
11.2.06095

OPC watchdog treatment not fully executed (SPR #66922)

Under some circumstances, watchdog treatment on OPC variables was not working properly
and only part of the variables were set to NS WD on watchdog failure.

Real time data
Also in: 15.0.0,
11.2.06091

Instruction EXPORT_LOG mode GETSTATISTIC - Sort order argument
ignored (SPR #68221, 68211)

The argument StatSortOrder was not correctly taken into account when using the instruction
EXPORT_LOG mode GETSTATISTIC.

No error was returned when passing an inappropriate value, and with a correct value, it was
not taken into account and sorting was not effective.

Scripting > SCADA
Basic
Also in: 15.0.0

Instruction VARIABLE mode ASSOCIATEDLABEL - Incorrect return
value (SPR #67675)

The label name was returned instead of the label current value when the instruction VARIABLE
mode ASSOCIATEDLABEL was called for a variable of type Bit.

Scripting > SCADA
Basic
Also in: 15.0.0

Fatal error on the Web back end (SPR #67721)

Under some circumstances, a fatal error could occur on a Web back end server, due a trace
message with an incorrect format. The issue could only occur when the Mimic Details trace
level was activated in the Web back end configuration.

Web Server Extensions

Alarm viewer sorting not working with checkbox selection (SPR #68143)

In WebVue, sorting was incorrectly done on the adjacent column when the Line selection mode
was set to By checkbox.

Web Server Extensions
> WebVue
Also in: 15.0.0

Tooltip displayed for hidden buttons (SPR #68024, 67993)

The tooltip was displayed on graphic objects, even if it was hidden due to a Visibility animation.

Web Server Extensions
> WebVue
Also in: 15.0.0

Web client no longer refreshed (SPR #68066, 67305)

Under some circumstances, when using popup mimics, WebVue was no longer refreshed and
was disconnected after a while.

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Enhancements

OPC-XML - Support for Http Basic Authentication (SPR #67279, 67278,

65932)
The OPC-XML driver now supports Http Basic Authentication.

Data Acquisition > OPC
Client
Also in: 15.0.0

Driver XBUS-IP-MASTER - Handling of connection termination (SPR
#66310)

In order to improve interop with some devices, it is now possible to select if a connection shall
be terminated using the TCP RST_ACK or FIN_ACK flag.

Data Acquisition >
Other built-in drivers
Also in: 15.0.0,
11.2.06085
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3. Other fixes & enhancements

SPR #65348, 68261 Also in: 15.0.0
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14. Maintenance Release 12.0.18 (12.0.18900)

1. Fixes
Event OnSelectionChanged improperly triggered in Combo-box (SPR HMI > Form controls
#68123) Also in: 15.0.0

The event OnSelectionChanged was improperly triggered in the Combo-box control when
navigating in the dropdown list using the keypad. It is now only triggered upon validation of the
new item selection.

Animation not triggered (SPR #67697)

When a symbol was part of a group, its animations were not correctly triggered on mouse-click.

Web Server Extensions
> WebVue
Also in: 15.0.0

Hidden control zone (SPR #68024)

Control zone highlight was not properly hidden when the control zone itself was hidden
because it belonged to a hidden group or symbol.

Web Server Extensions
> WebVue

Trend viewer toggle button show/hide (SPR #67701)

The toggle button to show/hide curves (in the legend) was not working properly when trends
were dynamically set via SCADA Basic instruction TREND mode SETVAR.

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Enhancements

Replication Manager - Purging previous steps before a new replication
(SPR #65618)

When an earlier replication failed to complete, remaining steps were still pending and stored in
a dedicated table so that they can be processed later on. This feature had side effects in case
one did not want the pending steps to be executed. It is now possible to purge this table of
pending steps before executing a new replication, by using the Database Manager tool or by
using the /P command line argument:

® /P=1to purge the table,

® /P=0to keep previous steps (default).

Add-ons and Tools
Also in: 15.0.0,
11.2.06093, 11.1.06120
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15. Maintenance Release 12.0.17 (12.0.17900)

1. Fixes

Fatal error at startup (SPR #68005)

Under some circumstances, a fatal error could occur at network startup on projects with a large
number of BACnet devices among which some are disconnected.

Data Acquisition >
BACnet Client
Also in: 15.0.0

Impossible to restore communication despite time-out errors (SPR
#67881)

Under some circumstances, the communication with some TCP/IP devices could not be
restored despite multiple time-out errors. The issue was due to the PLC not responding to
requests while the underlying socket was still in an Ok state.

From now on, after a period of 180 sec in time-out error, it is possible to force a close of the
socket, which is then re-opened at the next retry.

To activate this behavior, the following keys must be added in the file C\EqtConf.ini:
[TCPIP]

EnableCloseOnConsecutiveTimeOut = 1
MaxConsecutiveTimeOutInSec = 180

Data Acquisition >
Other built-in drivers
Also in: 15.0.0,
11.2.06097

Web component not correctly deployed on older operating systems
(SPR #67994)

The Web components were not correctly deployed by the WDC on operating systems using IS
7.5 or lower, which include Windows 7, Windows Server 2008 and Windows Server 2008 R2.

Deployment tools >
Web Deployment
Console

This was due to the use of the applicationlnitialization element in the IS configuration (only Also in: 15.0.0
supported from 1IS 8.0 onward).

Function Keys configuration lost (SPR #68051) General

Since version 12.0.16, Functions Keys configuration was lost after restarting a project.

Associated actions and context mimic not accessible (SPR #67797) HMI

Under some circumstances, associated actions and context mimic were not accessible from a Also in: 15.0.0,

log or alarm viewer. The issue only occurred when the mimic was opened via a SCADA Basic

script executed at startup. 11.2.06094

Fatal error on symbol edition (SPR #67832) HMI

Under some circumstances, a fatal error could occur when modifying symbol sub-objects via Also in: 15.0.0

the Graphic Explorer.

Opening a mimic containing the Grid Control (SPR #67930) HMI > Grid control
When using the Grid Control with the Variable Tracking mode activated, the height of eachrow  Also in: 15.0.0

was unnecessarily stored in the mimic (or symbol) file. It was leading to an unusual long time to '

open the mimic, and could lead to a fatal error in some cases (due to timeout errors). 11.2.06095

VBA event KeyPressed not triggered (SPR #68045) HMI > Grid control
The VBA event KeyPressed of the Grid Control was not triggered when pressing an arrow key if ~ Also in: 15.0.0

the key was associated to a Function Key action.

Trends not displayed upon request to the archives (SPR #66731) HMI > Trend viewer
Under some circumstances, trends could disappear and no longer be displayed when Also in: 15.0.0,
requesting historical data. The issue occurred when a real time value (for one of the displayed 11.2.06095

variables) was received while processing the historical data.

Instruction KEY mode ADDPROG and ADDPROGS - Failure with key

code greater than 26

The SCADA Basic instruction KEY with modes ADDPROG and ADDPROGS failed when the key
code was greater than 26.

Scripting > SCADA
Basic
Also in: 15.0.0

Memory leak when changing a threshold on a passive server (SPR
#68034)

Under some circumstances, a memory leak could occur when executing the instruction
VARIABLE mode THRESHOLD_SETVALUE on a passive server.

Scripting > SCADA
Basic
Also in: 15.0.0,
11.2.06095
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Could not filter alarms with level 0 only (SPR #67821)

It was not possible to filter real time alarms with level 0 only (minLevel=0 and maxLevel=0).
With such requests, the maxLevel parameter was automatically set to 29.

This issue only affected web components with alarm filtering capabilities (WebVue, Web
Services Toolkit and TouchVue).

Web Server Extensions
Also in: 15.0.0

Fatal error on browse request by a web client (SPR #67983)

Under some circumstances, a fatal error could occur when the configuration of a variable was
modified while a browse request was being processed for a web client.

Web Server Extensions
Also in: 15.0.0

Fatal error when closing a web session

Under some circumstances, a fatal error could occur when closing a web client session. The
issue could be reproduced if an Alarm Syntheses was configured with the option Take the
applied Population into account, and if the value of an extended attribute was changed while
closing the web session.

Web Server Extensions
Also in: 15.0.0

2. Enhancements

Support for double spontaneous transmissions (SPR #68078)

Support for double transmission of information objects with cause of transmission
spontaneous. It can be configured in the advanced properties of IEC 104 points.

Communication
interfaces > IEC 60870-
5-104 Outstation

Also in: 15.0.0

Support of signed float 32 bits format (SPR #68105)

New format Signed float 32 bits (swapped word) is now available for built-in drivers.

Data Acquisition >
Other built-in drivers

Also in: 15.0.0
Support for extended function keys General
The list of fixes & enhancements includes: Also in: 15.0.0

®  Support of F13 to F16 function keys, Back Space and Tab keys,
®  Support of the Alt key as a modifier,
®  Error and Log messages reworked.

Instruction TRACE mode FILE - Message max length (SPR #67950)

The instruction TRACE mode FILE can now handle a message of up to 2047 characters (was 80).

Scripting > SCADA
Basic
Also in: 15.0.0

3. Installation

Documentation update

The product documentation has been updated:
®  Online help in Chinese - Now at the level of version 12,
®  Online help in Russian - Now at the level of version 11.2.

General >
Documentation

4, Security

Vulnerabilities in the Web back end modules
The following vulnerabilities are fixed. They affect the interface between the Web & Mobile
back end and the web services hosted in Microsoft IIS:
® (CVE-2020-26867 - A Remote Code Execution vulnerability due to the unsafe
deserialization of messages received on the interface - Affects all versions since 8.10.
® (CVE-2020-26868 - A Denial Of Service vulnerability due to the ability for a non-
authorized user to modify information used to validate messages sent by legitimate
web clients - Only affects version 12.0.
® (CVE-2020-26869 - An information exposure vulnerability allowing a non-authorized
user to access session data of legitimate users - Only affects version 12.0.
See our Security alert page and Security Bulletin 2020-1 for more information.

Web Server Extensions
Also in: 15.0.0,
11.2.06097
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5. Other fixes & enhancements

SPR #67223, 67986 Also in: 15.0.0
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16. Maintenance Release 12.0.16 (12.0.16900)

1. Fixes

Incorrect value and boundaries for System.Localhost.Session.Type
(SPR #67957)

The variable System.Localhost.Session.Type had an incorrect low boundary, 0 instead of -1, and
was wrongly set to -1 where the value should have been 104 when a client was connected using
the Web Services Toolkit.

The same fix applies to the values returned by the SCADA Basic instruction SESSION mode
GETTYPE.

Audit
Also in: 15.0.0

SNMP trap not sent (SPR #67679)

When configuring multiple traps with the same generic format, only the last trap was sent.

Communication
interfaces > SNMP
Agent

Also in: 15.0.0

Support for OID and Value in Generic Trap (SPR #67126)

Generic traps were not supporting OID and Value parameters properly. They now behaves as
described in the online help.

Communication
interfaces > SNMP
Agent

Also in: 15.0.0,
11.2.06092

Import failed due to expressions (SPR #67558, 67545, 67276, 66885)
When importing expressions via a Smart Generator or the Application Architect, expressions
configured with a result variable that was not produced locally were only partly loaded and did
not behave as expected at runtime.

Configuration
Environments
Also in: 15.0.0

Upgrade Alarm synthesis default property value (SPR #67799, 66701)

The default value of the property Take the applied population into account of Alarm Syntheses
items is False since version 11.2 Release.

This new default value was mistakenly not applied to Alarm syntheses created with the
Application Architect. It is now applied.

This change may introduce a behavior change in the way alarm syntheses are calculated in
some projects. Please refer to the Known issues section for more information.

Configuration
Environments >
Application Architect
Also in: 15.0.0,
11.2.06094

Fatal error when editing a property defined by expression (SPR #67450)
Under some circumstances, a fatal error could occur when opening the expression editor for
defining a property. The issue occurred when the operating system was set for the Hebrew
character set. Other non-English languages were potentially impacted also (reproduced with
French charset).

Configuration
Environments >
Application Architect
Also in: 15.0.0

Fatal error upon copy of a variable or trend (SPR #66986)

Under some circumstances, a fatal error could occur when copying a variable or a trend.

Configuration
Environments >
Application Explorer
Also in: 15.0.0,
11.2.06094

Buffered Al and AO values not recorded (SPR #66941, 66834, 66297)

The buffered values for Al and AO objects of a DNP3 device were not correctly recorded in the
archives when they were associated to trends. These values are read when connecting to the
device at startup or upon reconnection.

Data Acquisition >
DNP3 Client
Also in: 15.0.0

Driver IpOpenWebNet - Support for extension modules (SPR #67702)

The SCS extension modules were incorrectly updated when a new measurement was received
for a single Lighting Point.

Data Acquisition >
Other built-in drivers
Also in: 15.0.0

Fatal error when exporting with limited amount of exported records
(SPR #67739)

A fatal error could occur when performing an export having the advanced property "Statistics
output.Limit exported records" activated, even if the actual number of records was lower than
this limit.

Data Export
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Fatal error at project startup (SPR #67652) Historical data
Under some circumstances, a fatal error could occur at project startup due a conflict in Also in: 15.0.0,
accessing pending event logs (event logs waiting to be recorded).

11.2.06094
Upgrade Potential memory leak in Networking with mixed PcVue Networking
versions (SPR #67867) Also in: 11.2.06094

Under some circumstances, while migrating a project, a memory leak occurred on a data
acquisition server if it ran a version greater than or equal to 11.2.6086 and communicating with
a client station running with version 12.0.15 or lower. The leak occurred at each restart of a
client station, and its size was proportional to the number of variable subscriptions sent by the
client station to the server station (250 bytes per subscription - typically a leak of 2.5 MB for 10
000 variables at each restart of a client station).

Instruction KEY modes ADDPROG, ADDCLK and ADDSTD - Existing key Scripting > SCADA

not replaced (SPR #67955) Basic

When creating a new function key action with the SCADA Basic instruction KEY modes Also in: 15.0.0
ADDPROG, ADDCLK or ADDSTD, an existing definition of the key combination was not replaced

by the new one, leading to the execution of both actions when triggered.

As described in the help, any existing definition of a temporary key is now replaced, and the

instruction returns an error if the existing key is permanent (configured) and cannot be

replaced by script at runtime.

Improper disconnection WebScheduler

Without a user action causing a request to the web server, the user was forcibly disconnected Also in: 15.0.0
after the session time-out (default 1 mn). It could happen when configuring multiple schedules

before saving them at once. A keep-alive request is now sent every 10 sec to make sure the

connection is maintained.

2. Critical fixes

Several fixes in the IEC 61850 client driver (SPR #67463) Data Acquisition > IEC
Fixes are related to the handling of communication object stop/start and includes: 61850 Client

®  Fix of a fatal error that occurred when changing the configuration of several variables Also in: 15.0.0
linked to IEC 61850 report or dataset. The issue could be reproduced when doing an ’ T
Application Architect synchronization with IEC 61850 devices connected and 11.2.06094
communicating actively.

®  Variable updates could be frozen for 1 minute upon redundant data acquisition server
switch from active to passive.

®  Failure to reconnect to URCB or BRCB upon redundant data acquisition server switch
from active to passive.

3. Enhancements

Sampling period greater than the export period (SPR #67469) Data Export
It is now possible to have a sampling period equal or greater than the export period. This Also in: 15.0.0
change allows using the export feature to generate a single sampled value snapshot.
Positioning of markers (SPR #67820, 67757, 67756) HMI > Map control
It is now possible to select at design time how markers of type Symbol shall be anchored onthe  Also in: 15.0.0
map:

®  Centered,

®  Anchor point,

®  Top-left corner,

®  Top-right corner,

®  Bottom-left corner,

[ ]

Bottom-right corner.

New method to log messages (SPR #67826) Scripting > VBA
A new method Loginformation is available in VBA on the Project object. It can be used to send Also in: 15.0.0
log messages to the Event Viewer.
ThisProject.LogInformation LogLevel, LogMsg
Where LogLevel can take value 1, 2 or 3, and LogMsg is the message to be logged (string)
® 1 =Information,
® 2 =Warning,
® 3 =Error.

Reference: PcVue 12 Release Notes Last update: November 3, 2025
Copyright ©2025 - ARC Informatique. All rights reserved — LI Mg M\ Page 31/50



4
PcVue >

Show/hide columns WebScheduler

It is now possible to hide the columns Is Standard Week Empty and Is Exception Period Active. Also in: 15.0.0
By doing so, the time to load the list of timetables is greatly reduced.
The setting to add to the WebScheduler web.config file is the following:

<setting name="HideSpecialColumns"

serializeAs="String">
<value>True</value>

</setting>

4. Performance

Image caching (SPR #66155) Web Server Extensions
Images loaded in mimics and symbols were not cached by the web browser, thus they were > WebVue

loaded every time the mimic was opened. .

The setting to add to the GraphicalData web.config file is the following - Value in seconds, Also in: 15.0.0

default to O (expiration controlled by the web browser) :

<setting name="CacheMaxAge"

serializeAs="String">
<value>0</value>

</setting>

There is no need for customization to take advantage of the default value.

5. Other fixes & enhancements

SPR #67486 Also in: 15.0.0
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17. Maintenance Release 12.0.15 (12.0.15900)

1. Fixes

Driver SAIA - Equipment not correctly initialized (SPR #67443)

At startup, some devices were not correctly initialized and connection could not be established.
Startup of devices is now serialized to enforce a proper initialization.

Data Acquisition >

Other built-in drivers

Also in: 15.0.0,
11.2.06093

Fatal error on frame modification (SPR #66627)
A fatal error could occur when modifying a frame while the communication was starting.

Data Acquisition >

Other built-in drivers

Also in: 15.0.0

Fatal error with redundant servers (SPR #67440)

Under some circumstances, a fatal error could occur due to trap handling in redundant server
set-up.

Data Acquisition >
SNMP Manager
Also in: 15.0.0,
11.2.06093

Populations not correctly applied to HDS log lists (SPR #66699)

Historical data

Under some circumstances, populations were not correctly applied to HDS log lists in Log Also in: 15.0.0
Viewer, leading to an empty display. The issue occurred when multiple criteria were applied to

the same attribute.

Context mimic with variables attributes (SPR #67261) HMI

Since version 12.0, it was possible to open a context mimic from a graphic object animated with ~ A|so in: 15.0.0
a variable attribute such as #_Q, #_T or TATTx#. Such mimics only support a context based on a

variable value.

Fatal error when opening mimics in binary format (SPR #66783) HMI

Under some circumstances, a fatal error could occur when opening a mimic due to some Also in: 15.0.0
objects being loaded twice.

Graphical interface frozen (SPR #67045) HMI

Under some circumstances, the graphical interface could freeze due to the use of AVl or GIF Also in: 15.0.0
objects in mimics. The loading and display of these objects is now optimized to avoid an

overconsumption of CPU resources.

Residual objects displayed with large preview (SPR #67062) HMI

Some residual objects were displayed in images and symbols selectors when using large Also in: 15.0.0

preview.

Error message displayed when opening a map (SPR #66956)
Under some circumstances, an error message could be raised when displaying a map at project
startup, due to execution synchronization issues.

HMI > Map control
Also in: 15.0.0,
11.2.06093

Incorrect position of a symbol in design mode (SPR #67570)

In design mode, a symbol at an absolute position was incorrectly anchored in the Map Control.

HMI > Map control
Also in: 15.0.0

Instruction SQL_COMMAND mode READBUFFERCELL - Empty cells
were ignored (SPR #67266)

Scripting > SCADA
Basic

String cells having a NULL value were ignored and skipped when using the instruction Also in: 15.0.0
SQL_COMMAND with the mode READBUFFERCELL. They are now interpreted as empty strings.

Several fixes & enhancements to TouchVue (SPR #67297, 66946, 66697,  TouchVue
66640, 65853, 65370) Also in: 15.0.0

The list of fixes & enhancements includes:
®  Under some circumstances, mimics could freeze,
®  Under some circumstances, users could not logout nor login,

®  Some variable commands were not correctly triggered when embedded in object
groups, symbols or mimic tab,

® Incorrect error messages were displayed after unsubscribing a variable.
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Instruction TREND mode SETVAR - Variable description not updated
(SPR #66637)

In a WebVue context, the variable description was not updated in the legend when the curve
was modified with the SCADA Basic instruction TREND mode SETVAR.

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Critical fixes

Unable to restart serial communication (SPR #67037)

Since version 12, it was no longer possible to restart a serial communication after stopping it.
The application had to be restarted to correctly reinitialize the COM port.

Data Acquisition >
Other built-in drivers
Also in: 15.0.0

3. Performance

GDI object leak (SPR #67251)

A memory leak occurred when opening a mimic containing Form controls (Combo-box, List-box,
Option-list, Tree view). One GDI object was lost for each control using a custom font.

HMI > Form controls
Also in: 15.0.0

Degraded response time (SPR #67120)

Since version 12.0 Initial Release, general performances when requesting Web Services were
degraded up to 50 folds (100 read requests within 50 seconds instead of 1 seconds). This fix
restores performances to a level similar to version 11.2.

Web Server Extensions
> Web Services Toolkit
Also in: 15.0.0

4, Security

Access to another web session (SPR #66644)

Under some circumstances, a web client was able to access the session of another web client,
leading to potential information disclosure and privilege elevation. This was due to the reuse of
a previously closed session Id, but with an access token not yet expired.

Web Server Extensions
Also in: 15.0.0
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18. Maintenance Release 12.0.14 (12.0.14900)

1. Fixes
Invalid OPC variables after switchover (SPR #66837, 66655) Data Acquisition > OPC
Under some circumstances, variables mapped to OPC items could remain invalid after a data Client
acquisition server switchover if errors occurred during the switchover. -
The issue affected: Also in: 15.0.0,
®  Versions 11.2.06781 to 11.2.06793, 11.2.06092

®  Allreleases of 12.0 up to 12.0.14.

License for version 15 not recognized by PcVue version 12 General > Licensing

Some licenses shipped during Q2 2021 for version 15 were not recognized by PcVue version 12.
It was a known issue since 12.0.7 (Initial Release).

File & Folder filter for Project version not correctly saved (SPR #68848, General > Version

66794) management

Under some circumstances, the file selection configured in the central project management Also in: 15.0.0,

was not correctly saved. The issue could occur in particular when selecting the All files in project

directory checkbox at the project root level. 11.2.06099

Incorrect filtered list of alarms in Alarm viewer (SPR #67009) HMI > Alarm viewer
Under some circumstances, the alarms displayed in an Alarm viewer did not match the Also in: 15.0.0,
expected filter. It could occur if a filter was applied using VBA while quickly opening and closing

mimics. 11.2.06091

Fatal error with a variable name used in a tooltip (SPR #67020) HMI > Animations
A fatal error occurred when a variable with a name longer than 80 characters was used in a Also in: 15.0.0

tooltip.

Fatal error when opening a web client (SPR #67012) Web Server Extensions

Under some circumstances, a fatal error of the web back end station could occur when running >~ \WebVue
a WebVue client. This issue was due a synchronization issue with the server. .
Also in: 15.0.0

2. Enhancements

New substitution characters for timestamp formatting - 12-hour clock HMI
(SPR #67015) Also in: 15.0.0

New substitution characters are available in the Alarm viewer, the Log viewer and the Trend
viewer for timestamp formatting based on 12-hour clock representation:

®  #H: Hours from 1 through 12 (as opposed to #h for 00 through 23),

®  #p: AM/PM designator.
In additional, only for the Alarm viewer, #H and #p support the suffix AlaOn, AlaAck and AlaOff.
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19. Maintenance Release 12.0.13 (12.0.13900)

1. Fixes

IEC 104 variables not refreshed (SPR #66723)

Under some circumstances, some IEC 104 variables could not be refreshed at startup or on
server switchover.

Data Acquisition > IEC
60870-5 Client

ActiveX controls based on .Net loaded twice (SPR #66858) HMI

ActiveX controls based on .Net components were loaded twice. Also in: 15.0.0
Fatal error with symbol containing a Trend viewer (SPR #66968) HMI

A fatal error occurred when manipulating a symbol containing a Trend viewer with the option Also in: 15.0.0
Save runtime properties activated.

Unable to edit symbol from the Graphic Explorer (SPR #66665) HMI

Under some circumstances, it was not possible to edit a symbol directly from the Graphic Also in: 15.0.0
Explorer. The issue occurred when the anchor point of a symbol was invalid.

Images not stretched (SPR #66947, 65941) Web Server Extensions
The option Stretch image was not taken into account when rendering images used in Images > WebVue
animations (e.g.: Image on Bit). .

(6 Image on 1) Also in: 15.0.0
Incorrect colors in Trend viewer (SPR #66754) Web Server Extensions
Under some circumstances, color of traces were incorrect in a Trend viewer. The issue occurred >~ \WebVue
when a trend historical request was executed while another one was still in progress. Also in: 15.0.0

n: U,

2. Critical fixes

Emergency purge not executed (SPR #67005)

Since version 12.0, the emergency purge was no longer executed properly. In addition, if no
scheduled purge was configured, the issue could lead to potential storage issues and changes
no longer recorded.

Historical data
Also in: 15.0.0

Empty result when Population applied to an HDS log list (SPR #66699)

Since version 12.0 release, when a population was applied to an HDS log list, no result was
returned nor displayed.

Historical data

3. Enhancements

Default mode of On text animations (SPR #66983)

HMI > Animations

On text animations now use the Variable mode by default (was using Value mode). Also in: 15.0.0
4, Security

Access to the online help and potential security policy infringement General

(SPR #66776, 65910) Also in: 15.0.0,

Under some circumstances, access to the online help was possible before completion of project  11.2.06091

startup.

It could occur in particular by pressing the F1 key from one of the message box opened to
indicate that network access issues prevent access to the version management central folder.
Access to the file system was therefore possible before user authentication, which could be
against the security policy on some systems.
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20. Maintenance Release 12.0.12 (12.0.12900)

1. Fixes
Code page displayed in string values (SPR #66842) Data Acquisition >
When the code page was different from UTF-8, string values were prefixed with the applied BACnet Client
code page (UCS-2, DBCS...). .
Also in: 15.0.0
Time-out on variable initialization (SPR #66803) Data Acquisition >
Under some circumstances, a time-out could occur when initializing DNP3 variables. DNP3 Client
Also in: 15.0.0
Fatal error when exiting the VCR mode (SPR #66773) Historical data > VCR
Under some circumstances, a fatal error could occur when exiting PcVue if running in VCR Also in: 15.0.0
mode and while playing records.
Fatal error when loading the content file of a tree view (SPR #66779) HMI > Form controls
A fatal error occurred when updating the content of a tree-view control by loading a content Also in: 15.0.0
file defined by a variable link. The initial loading worked properly, the issue occurred when ’
loading another file including items with animations. 11.2.06091
Trend viewer runtime configuration lost (SPR #66736) HMI > Trend viewer
The runtime configuration of Trend viewer was not correctly saved with branched mimics. Also in: 15.0.0
Trend viewer runtime properties lost (SPR #66648) HMI > Trend viewer
The runtime properties of Trend viewer was lost when a curve's label contained a comma. Also in: 15.0.0,
11.2.06090
Instruction CIMWAY mode READFRAME - Fatal error when read request Scripting > SCADA
failed (SPR #66607) Basic
A fatal error could occur when a read request triggered by the instruction CIMWAY mode Also in: 15.0.0
READFRAME failed.
Alarm viewer with first column empty (SPR #66855, 59115) Web Server Extensions

A fatal error of the web back end occurred when displaying a mimic in WebVue if it contained > WebVue
an alarm viewer with the first column configured to be empty.

Also in: 15.0.0
Blinking colors not working in animation (SPR #66679) Web Server Extensions
Blinking colors were not correctly supported in an animation when changing from blinking to > WebVue
fixed color. .

Also in: 15.0.0
Blinking colors with indexed colors (SPR #66091) Web Server Extensions
Blinking colors were not properly displayed on text objects when using indexed colors. > WebVue

Also in: 15.0.0
Fatal error with included mimics (SPR #66854) Web Server Extensions
A fatal error occurred when an included mimic was opened with a Link open animation when > WebVue
the parent mimic was named explicitly (instead of using the * character). .

Also in: 15.0.0
Object flickering with translation animation (SPR #66725) Web Server Extensions
In WebVue, graphic objects were flickering when configured with a translation animation and > WebVue
rendered partly outside of the visible window. Also in: 15.0.0

n: U,

SCADA Basic script not executed on mimic opening (SPR #66785, 66340) Web Server Extensions

SCADA Basic script on mimic opening were not executed in WebVue when the mimic was > WebVue
containing an empty Trend viewer. .
Also in: 15.0.0
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Send and Link animations not available on transparent graphic objects
(SPR #66577, 66327)

Send and Link animations were not executed when configured on an object with invisible
border and background. The control zone was not active nor displayed.

Web Server Extensions
> WebVue
Also in: 15.0.0

Translation animation with improper control zone (SPR #66230)

Graphic objects configured with a translation animation were always highlighted with a control

zone even if the cursor mode was not activated on the animation.

Web Server Extensions
> WebVue
Also in: 15.0.0

Trends not set with SCADA Basic instruction (SPR #66340)

Opening a mimic and defining trends with the SCADA Basic instruction SETVAR in the same
script was not working properly.

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Critical fixes

Polling stopped after 25 days (SPR #66766)

The cyclic polling mechanisms used by the IEC 61850 data acquisition driver stopped working
properly after a period of 25 days. It was necessary to restart the application to recover a
correct behavior.

The affected mechanisms were the following:

®  Polling of Datagroup (all versions affected),

Polling of DataSet (all versions affected),

Polling of watchdog (all versions affected),

Cyclic attempt to reconnect a disconnected device (all versions affected),
Cyclic re-synch Gl for reports (affected since version 11.2),

Cyclic attempt to reconnect disconnected reports (affected since version 11.2).

Data Acquisition > IEC
61850 Client

Also in: 15.0.0,
11.2.06090

3. Enhancements

OPC-XML - Support for arrays (SPR #66898)

When using OPC-XML, it was not possible to map a variable on a specific index of an array of
items (string, boolean, 14, Ul4...). This feature was already available with the OPC-DA client.

Data Acquisition > OPC
Client
Also in: 15.0.0

4, Performance

Filtering based on populations (SPR #66703, 66695)

Since version 12 Initial Release, runtime performances related to population filters were
degraded due to a regression.

Applying a population filter could take several minutes to be fully performed. It is now almost
instantaneous.

Real time data
Also in: 15.0.0

5.  Security

Automatic logout not effective in WebVue (SPR #66653)

Web Server Extensions

The automatic logout was not completely effective in WebVue. > WebVue

After the inactivity timeout elapsed, it was indicated that the session ended but refreshing the .

page (with F5 or Refresh button) was opening it again without entering credentials. Also in: 15.0.0
6.  Other fixes & enhancements

SPR #66811, 66857 Also in: 15.0.0
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21. Maintenance Release 12.0.11 (12.0.11900)

1. New features

Support for included mimics and popups (SPR #66242, 66024)

Included mimics and popups are now supported in WebVue.
It was a known issue since 12.0.7 (Initial Release).

Web Server Extensions
> WebVue
Also in: 15.0.0

Support of iPad OS 13
WebVue now supports the Safari web browser shipped with iPad OS 13.

Web Server Extensions
> WebVue
Also in: 15.0.0

2. Fixes

Fatal error when displaying libraries of mimics or symbols thumbnails

(SPR #66499, 66480)

A fatal error of the Library Explorer, the Application Explorer or the Application Architect
occurred when changing the displayed library of mimics and/or symbols if in thumbnails display
mode.

Configuration
Environments
Also in: 15.0.0,
11.2.06088

Fatal error when creating a variable (SPR #66630)
Under some circumstances, a fatal error could occur when creating a variable. The issue

occurred when a branch segment of the variable was used in another branch previously deleted
(e.g. B1.B2 and B2.B3).

Configuration
Environments >
Application Explorer
Also in: 15.0.0

Fatal error upon modification of Equipment configuration (SPR #66627)

Under some circumstances, a fatal error could occur when modifying the configuration of an
Equipment or a Frame while Communication was starting.

Data Acquisition >
Other built-in drivers

#x substitution with free archive units

The substitution #x (timestamp quality) did not work properly when used to record logged
events on free archive units.

Historical data
Also in: 15.0.0,
11.2.06087

Associated labels not correctly displayed with mismatching label type
(SPR #66371)

Under some circumstances, the displayed associated label was incorrect. The issue occurred
when the compatibility setting Allow use of mismatched associated label type was enabled,
with a variable of type alarm configured with a Bit Associated Label.

HMI > Animations
Also in: 15.0.0

Background image position (SPR #66458)

Background image settings were not correctly interpreted in the Chart Control, leading to an
incorrect positioning of the image.

HMI > Chart control
Also in: 15.0.0

Font not properly initialized (SPR #66411)

Under some circumstances, when using the ASCII format, text fonts were not properly
initialized. Consequently, the text graphic item failed to load and display.

HMI > Graphics
Also in: 15.0.0,
11.2.06087

Send Bit animation - Mode Handled and Pulse reworked (SPR #66459,
66439, 66334)
The Send Bit animation has been reworked, in particular the modes Handled and Pulse:

®  With Handled mode, the bit value was not reverted when the mimic lost focus,

®  Pulse mode was executed only when the HMI option Mimic.Animations.Send
bit.Handled & Pulse execution was set to Standard.

Web Server Extensions
> WebVue
Also in: 15.0.0

Time filter wrongly disabled in the Log viewer (SPR #66606)

The Time filter in the Log viewer was incorrectly disabled if the access to filtering options was
disabled.

Web Server Extensions
> WebVue
Also in: 15.0.0
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3. Critical fixes

Session context not taken into account in RealTimeData service (SPR
#66609, 66410)

Session context was not correctly managed in the RealTimeData service of the WST. As an
example, the USER variable was returning the name of the user logged on the back end hosting
the services (if any) instead of the name of the user authenticated as part of the WST session.

Web Server Extensions
> Web Services Toolkit
Also in: 15.0.0

4, Enhancements

Allow write commands when equipment is in error (SPR #66436)

Prior to this modification, write commands were not sent when the equipment was seen in
error. In particular, they were not executed on valid write-only frames when another frame had
a status error.

Now, writes commands are sent based on the frame status instead of the device status.

Data Acquisition >
Other built-in drivers
Also in: 15.0.0

Ability to disable file opening after data export (SPR #65359)

From now on, when the user does not have the desktop rights, the Data Export Wizard of the
Trend Viewer and the Grid Control no longer asks the user if he/she wants to open the
generated file, a simple information is displayed, thus preventing the access to the file system.

Data Export
Also in: 15.0.0

Small font size in Send Text animation (SPR #66342, 66038)

When a Send Text animation was configured with direct input, the font size for displaying and
typing the text were different.

Web Server Extensions
> WebVue
Also in: 15.0.0

Support of SCADA Basic modes INSERT and REMOVE for CHECKLIST,

COMBOBOX, LISTBOX and OPTIONLIST instructions (SPR #66028)

The SCADA Basic modes INSERT and REMOVE of the instructions CHECKLIST, COMBOBOX,
LISTBOX and OPTIONLIST are now supported in WebVue.

Web Server Extensions
> WebVue
Also in: 15.0.0

BACnet exception handling (SPR #66582)

Handling of Exception Schedule has been reworked to improve interop with devices that do not
clear obsolete exception entries themselves.

WebScheduler

Also in: 15.0.0,
11.2.06089, 11.1.06123,
11.0.06101

5. Other fixes & enhancements

SPR #66192

Also in: 15.0.0
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22. Maintenance Release 12.0.10 (12.0.10900)

1. Fixes

Missing warning if PcVue is not running (SPR #66092)

No warning was displayed when launching a configuration tool (including the Application
Explorer, Application Architect and Smart Generators) while the PcVue main process (Sv32.exe)
was not running.

It was a regression affecting version 12.0 Initial and Maintenance Releases.

Configuration
Environments
Also in: 15.0.0

Smart Generator for Wago - Incorrect mapping (SPR #66348, 65717)
The last variable of a frame was incorrectly mapped if the last available index in the frame did
not fit the size of the data point to map.

The issue occurred in particular when the last data point to map was of type REAL.

Configuration
Environments > Smart
Generators

Also in: 15.0.0,
11.2.06087

Fatal error at startup (SPR #66066, 66017)

A fatal error occurred at startup of the Web Deployment Console if the computer name had
been changed at the operating system level.

This was a known issue since 12.0.7 (Initial Release).

Deployment tools >
Web Deployment
Console

Also in: 15.0.0

Issue when changing the binding (SPR #65998, 65964)

When changing the binding of a web site, the Registry service endpoint was not properly re-
configured, preventing the web site from being operational.

The workaround was to delete and recreate the web site or to modify the WDC configuration
file manually.

It was a known issue since 12.0.7 (Initial Release).

Deployment tools >
Web Deployment
Console

Also in: 15.0.0

Failed to import multiple events (SPR #66361, 66158)

Importing multiple events on variable at once failed if the last part of their name was identical.
The issue could be reproduced when generating multiple instances of a template comprising an
event with the Application Architect.

Development kits >
XML Generic Import
Toolkit

Also in: 15.0.0,
11.2.06086

Could not load or generate log reports (SPR #66341, 62750)

It was not possible to load or generate log reports from a station using a server license. This
change also fixes an issue related to user rights for log reports (as defined in the Window tab of
a user profile).

Historical data
Also in: 15.0.0,
11.2.06086

Instruction WINDOW mode IS_OPEN - Handling of the '*' (SPR #66337)
Using the value '*' for the branch argument when calling the instruction WINDOW mode
IS_OPEN no longer worked.

This issue was a regression introduced in version 11.2.06048.

Scripting > SCADA
Basic

Also in: 15.0.0,
11.2.06086

Issue with long string literals (SPR #66255)

Using a string literal with a size longer than 80 characters generated a memory overrun that
could lead to a PcVue fatal error.

Scripting > SCADA
Basic

Also in: 15.0.0,
11.2.06086

Calendar dialog box not modal (SPR #66099)

The calendar dialog box of the Trend viewer could be improperly hidden behind the mimic. It is
now managed correctly as a modal dialog.

Web Server Extensions
> WebVue
Also in: 15.0.0

Incorrect behavior of the send register animation (SPR #66236)

If a user double-clicked on a send register animation (instead of a single click), WebVue
improperly opened an empty confirmation dialog box that the user could not close.

Web Server Extensions
> WebVue
Also in: 15.0.0
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Lost control zones (SPR #66209)

Web Server Extensions

Control zones were lost on polygons after executing them once. > WebVue
Also in: 15.0.0
2. Critical fixes
Fix an issue with Windows updates causing a fatal error at startup General

This change fixes an issue introduced by a series of Windows Updates rolled out by Microsoft in

August 2019 that caused a fatal error at startup of PcVue and FrontVue.
At the time of writing, the list of suspected Windows Updates is the following:

Windows update

KB4512508 (OS Build 18362.295)
KB4511553 (OS Build 17763.678)

and Windows Server 2019

KB4512534 (OS Build 17763.720)

and Windows Server 2019

KB4512501 (OS Build 17134.950)
KB4512509 (OS Build 17134.984)
KB4512516 (OS Build 16299.1331)
KB4512494 (OS Build 16299.1365)
KB4512507 (OS Build 15063.1988)
KB4512474 (OS Build 15063.2021)
KB4512517 (OS Build 14393.3144)

and Windows Server 2016

KB4512495 (OS Build 14393.3181)

and Windows Server 2016

KB4512497 (OS Build 10240.18305)
(RTM)

KB4517276 (OS Build 10240.18308)
(RTM)

KB4512488 (Monthly Rollup)

Server 2012 R2

KB4512478 (Preview of Monthly Rollup)
Server 2012 R2

KB4512518 (Monthly Rollup)
KB4512512 (Preview of Monthly Rollup)
KB4512506 (Monthly Rollup)

Windows Server 2008 R2 SP1
KB4512514 (Preview of Monthly Rollup)
Windows Server 2008 R2 SP1
KB4512476 (Monthly Rollup)
KB4512499 (Preview of Monthly Rollup)

Release date
August 13th, 2019
August 13th, 2019

August 17th, 2019
August 13th, 2019
August 19th, 2019
August 13th, 2019
August 16th, 2019
August 13th, 2019
August 17th, 2019
August 13th, 2019
August 17th, 2019
August 13th, 2019
August 17th, 2019
August 13th, 2019
August 17th, 2019
August 13th, 2019
August 17th, 2019
August 13th, 2019
August 17th, 2019

August 13th, 2019
August 17th, 2019

The issue affected versions 10.0, 11.0, 11.1, 11.2 and 12.0.
Earlier releases of these PcVue and FrontVue versions cannot be used if any of these Windows

Updates is installed.

Applies to
Windows 10 version 1903
Windows 10 version 1809,

Windows 10 version 1809,

Windows 10 version 1803
Windows 10 version 1803
Windows 10 version 1709
Windows 10 version 1709
Windows 10 version 1703
Windows 10 version 1703
Windows 10 version 1607,

Windows 10 version 1607,
Windows 10 version 1507

Windows 10 version 1507

Also in: 11.2.06087,
11.1.06122, 11.0.06100,
10.0SP2_Update

Windows 8.1, and Windows

Windows 8.1, and Windows

Windows Server 2012
Windows Server 2012
Windows 7 SP1, and

Windows 7 SP1, and

Windows Server 2008 SP2
Windows Server 2008 SP2

3. Other fixes & enhancements

SPR #66009, 66150

Also in: 15.0.0
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23. Maintenance Release 12.0.9 (12.0.09900)

1. Fixes

BACnet helpers frozen

Under some circumstances, BACnet helpers and the Application Explorer could freeze after
having selected a BACnet variable which object-type is defined by its numeric Id.

Configuration
Environments >
Application Explorer
Also in: 15.0.0,
11.2.06078

Memory leak with Trend Logs (SPR #66205)

A significant memory leak occurred when retrieving Trend Logs.

Data Acquisition >
BACnet Client

Also in: 15.0.0,
11.2.06084
Fatal error with image and symbol selectors (SPR #66005) HMI
It was possible to try to insert an image or a symbol using the corresponding selector evenifno  Also in: 15.0.0
mimic was open, causing a fatal error.
Mimic incorrectly resized and positioned when switching to Design HMI
mode (SPR #66196) Also in: 15.0.0

Under some circumstances, when switching a mimic from runtime to design mode, its size and
position were incorrectly recalculated due to screen resolution adaptation.

Instruction LOGDISPLAY mode FILTER - Fatal error with multiple INC
clauses (SPR #66217)

A fatal error occurred when using a filter having multiple INC clauses and using the % wildcard.
e.g.: =(#A1 INC %Domain%) && (#A2 INC %Nature%)

Scripting > SCADA
Basic
Also in: 15.0.0

Misleading message displayed (SPR #66068)

When a web back end endpoint was configured but the corresponding feature was not
installed, a misleading message was displayed at startup: "No configuration found for the
backend. Use web deployment console to deploy" instead of indicating that the feature was not
installed.

Web Server Extensions

Also in: 15.0.0

Incorrect blinking color on alarms (SPR #66111)

Under some circumstances, the blinking color of graphical items remained even after a status
change of the alarm, typically after its acknowledgment.

Web Server Extensions

> WebVue
Also in: 15.0.0

Web client frozen after closing foreground mimic (SPR #66179)

Under some circumstances, the web client could freeze after closing a foreground mimic when
another foreground or modal mimic was opened.

Web Server Extensions

> WebVue
Also in: 15.0.0

Web client frozen with modal mimic in background (SPR #66037)

Under some circumstances, after opening a mimic from a modal mimic, the web client could
freeze due to the modal mimic being moved to background and no longer being accessible.

Web Server Extensions

> WebVue
Also in: 15.0.0

Zoom actions not working in the Trend Viewer (SPR #66048)

Under some circumstances, the zoom actions of the Trend Viewer were not working properly.

Web Server Extensions

> WebVue
Also in: 15.0.0
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2. Critical fixes

Upgrade Upgrade of HDS table schema (SPR #66166) Historical data

With version 12, the length of Log list names can be up to 100 characters long (was 12).

This change affects the schema of HDS log tables (column LogList).

The change in table schema is done automatically at startup if the size of the database is less
than 10 Gb.

If the size is higher, the traces ask you to run the migration script.

The issue is that the migration script, as supplied with the installation package 12.0.7 and
12.0.8, was wrongly altering the column EvtTitle instead of the column LogList, causing the
archiving to no longer be effective after project startup.

If you have upgraded your HDS log tables with version 12.0.7 or 12.0.8, it is advised to apply the
following changes manually:

®  Alter the LogList column of Log tables to type it varchar(100),
®  Alter the EvtTitle column of Log tables to type it varchar(255),
®  Make sure the value of DBVersion is set to 4.

If you are upgrading your HDS log tables with version 12.0.9 or later, no specific action is
required apart from running the migration script.

3. Other fixes & enhancements

SPR #66219, 66269 Also in: 15.0.0
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24. Maintenance Release 12.0.8 (12.0.08901)

1. Fixes

Incorrect OPC values returned (SPR #66161) Communication

Under some circumstances, OPC items could not be read correctly by OPC clients, in particular interfaces > OPC
when requesting a group containing invalid or unknown items. Server

Also in: 15.0.0,
11.2.06083

Reports not processed in case of large datasets (SPR #66118) Data Acquisition > IEC

Reports were not handled properly when associated to a dataset with more than 150 members.  §1850 Client
The fix is validated with up to 1000 dataset members associated to a Report Control Block.

Also in: 15.0.0
VBA form issue with the map control (SPR #65854) HMI > Map control
Under some circumstances, when a VBA form was open on top of a map control, it could Also in: 15.0.0
happen that mouse events were trapped by the map control, thus preventing correct user '
interaction in the VBA form. 11.2.06082
Fatal error when importing variables (SPR #64677) Scripting > SCADA
Under some circumstances, when the auto-number internal identifiers (variable tagname) Basic
setting was not activated, a fatal error could occur when importing variables with the SCADA .
Basic instruction VARIABLE modes IMPORTFILE or IMPORTBUFFER. Also in: 15.0.0,
11.2.06081
Reference: PcVue 12 Release Notes Last update: November 3, 2025
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25. Known Issues

[Fixed] Alarm synthesis timestamp changed on server switchover (SPR
#71548)

On a server switch from passive to active, an alarm synthesis is recalculated, including its value
and timestamp. If the alarm synthesis has not changed, the value is not set. But, since a
regression introduced in Maintenance Release 12.0.20 the timestamp is updated, causing event
triggering if any.

[Edit: Fixed in 15.2.4 and 12.0.28].

Alarms

12.0.20

Also in: 15.2.0, 15.1.0,
15.0.0

Audit counter mean values are inaccurate (SPR #65251)
Calculation of mean values is wrong for audit counters (error every 27 hours).

Audit
12.0.7
Also in: 15.2.0, 15.1.0,
15.0.0

Lost instances (SPR #67013)

Under some circumstances, all instances are lost. Investigations indicate that this may be
caused by the deletion of the root node.

While the investigations continue to uncover and fix the source of the issue, changes have been
made to mitigate and prevent the root node deletion.

Specific diagnostic traces have been added to indicate that an attempt to delete the root node
occurs. In addition, a specific backup (in addition to the rolling backup files) is now performed
to ensure that instances configuration will not be lost.

These changes are in effect starting with the Maintenance Release 12.0.13.

If you run an earlier release of version 12 and notice that the instances root node is not
displayed in the Instances tab of the Application Architect, you have probably run into the issue
and the instances are lost. In such situation, stop PcVue and recover a valid instances
configuration from the rolling backup files located the C\Templates\Back folder. Do not restart
PcVue multiple times before you recover your configuration as it exposes you to losing the
useful rolling backup.

Configuration
Environments >
Application Architect
12.0.13

Also in: 15.2.0, 15.1.0,
15.0.0

Upgrade Potential behavior change for alarm syntheses (SPR #67799,
66701, 60594)

Starting with version 11.2 Release, by default, new alarm synthesis items created with the
Application Explorer or the XML Generic Import do not take the population filter into account.
This change was not introduced for alarm syntheses created with the Application Architect,
leading to the following potential issues if your project includes populations and alarm
syntheses created based on templates and instances with the Application Architect:

® |f you have migrated or are migrating a project from version 11.1 or earlier to version
11.2 or later, you should check with the Application Explorer that alarm syntheses are
configured to fit your requirements (take into account or ignore population). If
configuration does not fit, reverse the value of the 'Take population filter into account'
using the Application Architect and proceed with a full synchronization.

® Do the same verification and configuration changes if your project was once migrated
to 11.2 (earlier than 11.2.06094), and is now being migrated to 11.2.06094 or later.

® Do the same verification and configuration changes if your project was once migrated
to 12 (earlier than 12.0.16), and is now being migrated to 12.0.16 or later.

® |nall cases, pay particular attention to alarm syntheses created with version 11.2 and
12, as it is likely that the population filter property is not applied as it used to be with
earlier versions.
You are not impacted by this issue if you do not use population filtering in your project, or if
alarm syntheses are not created based on application modeling with the Application Architect.

Configuration
Environments >
Application Architect
12.0.16

Also in: 15.2.0, 15.1.0,
15.0.0, 11.2.06094

Supported operating systems for the KNX Add-on

The KNX add-on is only supported on the following operating systems, with the exclusion of any
virtual environment:

®  Windows 7 SP1 (x64),
®  Windows Server 2008 R2 SP1 (x64).

Data Acquisition > KNX
12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0, 11.2.05001

Supported operating systems for the LNS data acquisition driver
The LNS data acquisition driver is only supported on the following operating systems:
®  Windows 7 SP1 (x64),
®  Windows 8.1 (x64),
®  Windows Server 2008 R2 SP1 (x64),

®  Windows Server 2012 (x64).
Starting with version 15, the LNS data acquisition driver is validated with IzoT Net Server 4.5
(also known as OpenLNS) and supports recent operating systems.

Data Acquisition > LNS
12.0.7
Also in: 11.2.05001
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Xbus-1P-Master - Handling of connection termination (SPR #66310)

Some devices require connection termination using the TCP FIN_ACK flag instead of the usual
RST_ACK.

In the case, receiving the TCP RST_ACK caused the device to reboot.

In order to improve interop with such devices, a change was implemented to make it possible
to configure if a connection shall be terminated using the TCP RST_ACK or FIN_ACK flag.
[Changed in versions 11.2.06085, 12.0.19 and 15.0].

Data Acquisition >
Other built-in drivers
12.0.7

[Fixed] Issue when changing the binding (SPR #65998, 65964)

When changing the binding of a web site (from hostname to IP or IP to FQDN for example) and
re-deploying, the Registry service end-point is not properly re-configured, preventing the web
site from being operational.

The workaround is to delete and recreate the web site or to modify the WDC configuration file
manually.

[Fixed in 12.0.10]

Deployment tools >
Web Deployment
Console

12.0.7

[Fixed] WDC will not start after changing the computer name (SPR
#66066, 66017)

Because the WDC checks that the IIS configuration it holds matches the computer where it is
run, if the computer name of an IIS Web server is changed after a deployment with the WDC,
then the WDC will fail to start again.

[Edit: Fixed in 12.0.10]

Deployment tools >
Web Deployment
Console

12.0.7

License for version 15 not recognized by PcVue version 12

Some licenses shipped during Q2 2021 for version 15 are not recognized by PcVue version 12.
If you encounter the issue, update to Maintenance Release 12.0.14 or a later Maintenance
Release of version 12, or contact our sales representative.

[Fixed in 12.0.14]

General > Licensing
12.0.13

Upgrade [Fixed] Upgrade of HDS table schema

With version 12, the length of Log list names can be up to 100 characters long (was 12).

This change affects the schema of HDS log tables (column LogList).

The change in table schema is done automatically at startup if the size of the database is less
than 10 Gb.

If the size is higher, the traces ask you to run the migration script.

The issue is that the migration script, as supplied with the installation package 12.0.7 and
12.0.8, was wrongly altering the column EvtTitle instead of the column LogList, causing the
archiving to no longer be effective after project startup.

If you have upgraded your HDS log tables with version 12.0.7 or 12.0.8, it is advised to apply the
following changes manually:

® Alter the LogList column of Log tables to type it varchar(100),
®  Alter the EvtTitle column of Log tables to type it varchar(255),
®  Make sure the value of DBVersion is set to 4.

[Edit: Fixed in 12.0.9] If you are upgrading your HDS log tables with version 12.0.9 or later, no
specific action is required apart from running the migration script.

Historical data
12.0.7

SQL filtering on HMI variables (SPR #65903)

When using the Grid control in variable tracking mode, the Sqgl syntax cannot be used to filter
HMI variables.

HMI > Grid control
12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

[Fixed] Potential memory leak in Networking with mixed PcVue
versions (SPR #67867)

Under some circumstances, while migrating a project, a memory leak occurs on a data
acquisition server if it runs a version greater than or equal to 11.2.6086 and communicates with
a client station running with version 12.0.15 or lower. The leak occurs at each restart of a client
station, and its size is proportional to the number of variable subscriptions sent by the client
station to the server station (250 bytes per subscription - typically a leak of 2.5 MB for 10 000
variables at each restart of a client station).

[Edit: Fixed in 11.2.06094 - The leak is fixed whatever version 12 build is running on the client
station]

[Edit: Fixed in 12.0.16 - The leak is fixed whatever version 11.2 build is running on the serve
station]

Networking
12.0.16
Also in: 11.2.06094
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Client/Server networking instability if recent hardening is enabled (SPR
#76112)

If the security fix described in security bulletin SB2025-4 is enabled, networking packets can be
falsely detected as malformed, causing a server station to force a disconnection. This issue leads
to a situation where a client station may not be able to stay connected to a server station in a
stable way.

Recommendation:

The issue does not manifest itself if the recent hardened connection mechanism is disabled. To
disable this mechanism, the security alteration setting named 'Networking.Allow security
altering configuration options' must be checked and the property 'Allow stations with altered
security' on Nodes must be set to Yes.

Fix planned in 16.3.3, 15.2.13 and 12.0.32.

Networking

12.0.31

Also in: 16.3.2,16.3.1,
15.2.12

BeforeClose script not triggered (SPR #68418)

Since version 12.0.7, the SCADA Basic function called upon closing a mimic was not correctly
triggered when the mimic was closed via SCADA Basic.

[Edit: Fixed in 12.0.20 and 15.0.0 for PcVue desktop]

A fix for WebVue is planned for a later release.

Scripting > SCADA
Basic

12.0.20

Also in: 15.2.0, 15.1.0,
15.0.0

[Fixed] Control animations not executed (SPR #70070, 69124)
In Maintenance Release 12.0.24, control animations in mimics are not executed if rendered in
Web & Mobile clients.

We recommend users of WebVue and TouchVue not to use the Maintenance Release 12.0.24.
[Edit: Fixed in 12.0.25]

Web Server Extensions
12.0.24

Issue with host name resolution on Android (SPR #65724)

Android versions earlier than 5.1 are known to be affected by a bug related to host name
resolution.

When using DHCP, the issue prevents from using a host name other than a Fully Qualified
Domain Name even if the host name is properly registered in a local DNS and the DNS server
automatically updates itself to reflect DHCP leases. The issue is that Android devices do not use
the DNS search path provided by DHCP.

Please refer to the Google Issue Tracker for more information:
https://issuetracker.google.com/issues/36916949

Web Server Extensions
12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

[Fixed by Apple] Issue in the Trend viewer with the Safari browser (SPR
#65731)

With the Safari Web browser, the hexadecimal code of colors is displayed instead of the actual
colors in the Trend viewer's legend.

The fix is available in Safari 12.1 shipped with i0S 12.2 and macOS 10.14.4. It is also available
for macOS 10.13.6 and 10.12.6. (Added support for <input type="color">)

Web Server Extensions
> WebVue
12.0.7

[Fixed] Limited support for included mimics and popups
Support for included mimics and popups in WebVue is still limited compared to the behavior of

the desktop client.
[Edit: Fixed in 12.0.11]

Web Server Extensions
> WebVue
12.0.7

Drag handling with Firefox (SPR #70455)

If a position animation with Cursor mode enabled is used on an image, the user needs to click
twice in Firefox to perform the action.

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

Known limitation related to hiding control zone highlighting (SPR

#69621, 69606, 68375)

At the time of writing, hiding the control zone highlighting (according to the HMI option) is only
implemented for rectangle shapes.

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

Known limitation related to the animation Send register in Step mode
(SPR #66012)

The '+' and '-' buttons are not rendered in WebVue when using the Send register animation
with the Step mode enabled.

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0
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Restrictions related to web browsers

Each web browser can come with its own restrictions, in particular when security is at stake.
Below is a list of known behaviors, specific to one or the other web browser available on the
market at the time of writing. These restrictions may be cleared and others appear depending
on web browser updates and their publisher's strategy.

®  Safari on iOS - When the Safari web browser is closed without logging out from
WebVue, WebVue is re-open by default the next time the user opens Safari, but the
user will not be able to successfully login, and will be stuck on the WebVue loading
page. This is due to the Safari snapshot of the last visited page where Safari displays
the web page without actually requesting the web server. The solution is to go to the
address bar and click the Go button, or ask Safari to reload the page.

®  Google Chrome - The password manager of Chrome does not store credentials if the
connection to the web server is insecure. As a consequence, if you do not have a
proper certificate on the web server, users will not be able to use the Chrome
password manager to store their credentials.

®  Microsoft Edge - Edge in versions prior to 79 (Jan 2020) does not store the session
cookie when using the local computer as a web server with a binding on the hostname
at the IIS level. As a consequence, you cannot successfully log in, and can see a
warning message indicating that the version of the client is not compatible with the
server. The solution is to add .local to the computer host name when setting up the
web site binding with the Web Deployment Console (for example,
https://mycomputername.local instead of https://mycomputername).

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

SCADA Basic scripting of form controls (SPR #65938)

When scripting form controls in SCADA Basic in a WebVue context, the GET modes such as
GETSELECTEDINDEX, GETTEXT... do not return the correct value if the currently selected item
was selected either via the keyboard or another script (with a mode such as
SETSELECTEDINDEX).

These GET modes work properly if the selection was done via mouse-click or a tap (on a touch
device).

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

Support for WebFont requires manual installation on Windows 7 SP1

(1S 7.5) (SPR #65847)

If the Web Server runs 1IS 7.5 - a Windows 7 desktop or Windows 2008 R2 server computer -
the default font (Times New Roman) is used instead of the Roboto Web Font for texts inside
pre-defined WebVue pages and mimic tittles. Texts used in animations within mimics and
symbols are not affected.

This issue is due to the lack of pre-configured support for WebFont in 1IS 7.5.

The solution is to install the MIME type handler for .woff files manually using the IIS manager.
This issue may be fixed in a later version of the Web Deployment Console.

Web Server Extensions
> WebVue

12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0

Upgrade WebScheduler migration issue

In order to fit with Microsoft Windows default privileges for the 1IS_IUSRS group, the
configuration files of the ScheduleData service are now stored in the folder
ScheduleData\AppData on the IIS Web server.

These files, namely ScheduleDataAccess.xml and SchedulesAccess.dat, used to be stored in the
folder ScheduleData\config.

Upon migrating a project to PcVue 12.0, it is advised to move the files manually to avoid losing
customization of any piece of configuration. The manual copy shall take place after installation
and deployment of the WebScheduler (using the WDC).

WebScheduler
12.0.7

Also in: 15.2.0, 15.1.0,
15.0.0
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We would love to hear your thoughts and suggestions
so we can improve this document
Contact us at team-doc@pcvuesolutions.com
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